aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenning Heinold <h.heinold@tarent.de>2010-07-12 14:51:20 +0200
committerHenning Heinold <h.heinold@tarent.de>2010-07-26 15:34:20 +0200
commit9f3c5e8bfa78da10433c4a8ea8de899a8c5a9400 (patch)
treedefc1cb233f352b05cf2c95a87f390404a81a7c6
parentddc5a98f9c116873f46cd9b9c1dbf0dfc27d09ce (diff)
downloadopenembedded-9f3c5e8bfa78da10433c4a8ea8de899a8c5a9400.tar.gz
jacl: backport from openembedded-dev
* checksum is already in conf/checksums.ini Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl>
-rw-r--r--recipes/jacl/jacl-native_1.4.1.bb4
-rw-r--r--recipes/jacl/jacl_1.4.1.bb20
2 files changed, 24 insertions, 0 deletions
diff --git a/recipes/jacl/jacl-native_1.4.1.bb b/recipes/jacl/jacl-native_1.4.1.bb
new file mode 100644
index 0000000000..b0a0638dde
--- /dev/null
+++ b/recipes/jacl/jacl-native_1.4.1.bb
@@ -0,0 +1,4 @@
+require jacl_${PV}.bb
+
+inherit java-native
+
diff --git a/recipes/jacl/jacl_1.4.1.bb b/recipes/jacl/jacl_1.4.1.bb
new file mode 100644
index 0000000000..7c66c3ef7c
--- /dev/null
+++ b/recipes/jacl/jacl_1.4.1.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "Tcl interpreter for Java"
+LICENSES = "BSD"
+
+HOMEPAGE = "http://sourceforge.net/projects/tcljava"
+
+SRC_URI = "http://downloads.sourceforge.net/tcljava/jacl${PV}.tar.gz"
+
+inherit java-library
+
+S = "${WORKDIR}/jacl${PV}"
+
+DEPENDS = "fastjar-native"
+
+do_compile() {
+ mkdir -p build
+
+ javac -sourcepath src/tcljava:src/jacl -d build `find src/tcljava src/jacl -name "*.java"`
+
+ fastjar -C build -c -f ${JARFILENAME} .
+}