aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenning Heinold <h.heinold@tarent.de>2010-07-12 15:22:37 +0200
committerHenning Heinold <h.heinold@tarent.de>2010-07-26 15:34:20 +0200
commit7dce72886aadbaeb1c68eb5a52f6c5763bddff16 (patch)
tree531b35acf04557f82dce80264e9aa14833a2814d
parentc74403b2bf14e3573840805139fb1b6b4071a6ae (diff)
downloadopenembedded-7dce72886aadbaeb1c68eb5a52f6c5763bddff16.tar.gz
classpathx: backport from openembedded-dev
* checksums alreasy in conf/checksums.ini Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl>
-rw-r--r--recipes/classpathx/gnujaf-1.1.1/datadir_java.patch23
-rw-r--r--recipes/classpathx/gnujaf-native_1.1.1.bb3
-rw-r--r--recipes/classpathx/gnujaf_1.1.1.bb35
-rw-r--r--recipes/classpathx/gnumail-1.1.2/datadir_java.patch25
-rw-r--r--recipes/classpathx/gnumail-native_1.1.2.bb10
-rw-r--r--recipes/classpathx/gnumail_1.1.2.bb42
6 files changed, 138 insertions, 0 deletions
diff --git a/recipes/classpathx/gnujaf-1.1.1/datadir_java.patch b/recipes/classpathx/gnujaf-1.1.1/datadir_java.patch
new file mode 100644
index 0000000000..807a1cbf6d
--- /dev/null
+++ b/recipes/classpathx/gnujaf-1.1.1/datadir_java.patch
@@ -0,0 +1,23 @@
+Index: activation-1.1.1/Makefile.am
+===================================================================
+--- activation-1.1.1.orig/Makefile.am 2008-03-01 10:30:06.000000000 +0100
++++ activation-1.1.1/Makefile.am 2008-03-01 10:31:04.000000000 +0100
+@@ -7,6 +7,8 @@
+ JAVADOC = @JAVADOC@
+ JAVADOCFLAGS = @JAVADOCFLAGS@
+
++JARDIR = $(datadir)/java
++
+ src = @srcdir@/source
+ dst = classes
+ doc = @srcdir@/docs
+@@ -92,7 +94,7 @@
+ $(RM) config.log config.status
+
+ install-data-local:
+- @srcdir@/mkinstalldirs $(DESTDIR)/$(datadir)/java
+- $(INSTALL_DATA) $(activation_jar) $(DESTDIR)/$(datadir)/java
++ @srcdir@/mkinstalldirs $(DESTDIR)/$(JARDIR)
++ $(INSTALL_DATA) $(activation_jar) $(DESTDIR)/$(JARDIR)
+
+ # End of Makefile.am
diff --git a/recipes/classpathx/gnujaf-native_1.1.1.bb b/recipes/classpathx/gnujaf-native_1.1.1.bb
new file mode 100644
index 0000000000..0e3e485c92
--- /dev/null
+++ b/recipes/classpathx/gnujaf-native_1.1.1.bb
@@ -0,0 +1,3 @@
+require gnujaf_${PV}.bb
+
+inherit java-native
diff --git a/recipes/classpathx/gnujaf_1.1.1.bb b/recipes/classpathx/gnujaf_1.1.1.bb
new file mode 100644
index 0000000000..1ae47172e7
--- /dev/null
+++ b/recipes/classpathx/gnujaf_1.1.1.bb
@@ -0,0 +1,35 @@
+DESCRIPTION = "Provides a mean to type data and locate components suitable for performing various kinds of action on it."
+LICENSE = "GPL + library exception"
+AUTHOR = "GNU ClasspathX"
+
+SRC_URI = "\
+ http://ftp.gnu.org/gnu/classpathx/activation-${PV}.tar.gz \
+ file://datadir_java.patch;patch=1 \
+ "
+
+# java-library must be last (it defines do_stage)
+inherit autotools java-library
+
+S = "${WORKDIR}/activation-${PV}"
+
+DEPENDS = "fastjar-native"
+
+export JAVAC = "javac"
+
+# Fake javadoc
+export JAVADOC = "true"
+
+JARFILENAME = "activation-${PV}.jar"
+ALTJARFILENAMES = "activation.jar gnujaf.jar"
+
+do_compile() {
+ mkdir -p build
+
+ javac -sourcepath source -d build `find source -name "*.java"`
+
+ fastjar -C build -c -f ${JARFILENAME} .
+}
+
+do_install() {
+ java_install
+}
diff --git a/recipes/classpathx/gnumail-1.1.2/datadir_java.patch b/recipes/classpathx/gnumail-1.1.2/datadir_java.patch
new file mode 100644
index 0000000000..50e908d232
--- /dev/null
+++ b/recipes/classpathx/gnumail-1.1.2/datadir_java.patch
@@ -0,0 +1,25 @@
+Index: mail-1.1.2/Makefile.am
+===================================================================
+--- mail-1.1.2.orig/Makefile.am 2008-03-01 11:13:36.000000000 +0100
++++ mail-1.1.2/Makefile.am 2008-03-01 11:17:49.000000000 +0100
+@@ -7,6 +7,8 @@
+ JAVADOC = @JAVADOC@
+ JAVADOCFLAGS = @JAVADOCFLAGS@
+
++JARDIR = $(datadir)/java
++
+ src = @srcdir@/source
+ dst = classes
+ doc = @srcdir@/docs
+@@ -433,8 +435,8 @@
+ rm -rf $(gnumail_jar) $(providers_jar) META-INF $(dst) $(doc)
+
+ install-data-local:
+- @srcdir@/mkinstalldirs $(DESTDIR)/$(datadir)/java
+- $(INSTALL_DATA) $(gnumail_jar) $(DESTDIR)/$(datadir)/java
+- $(INSTALL_DATA) $(providers_jar) $(DESTDIR)/$(datadir)/java
++ @srcdir@/mkinstalldirs $(DESTDIR)/$(JARDIR)
++ $(INSTALL_DATA) $(gnumail_jar) $(DESTDIR)/$(JARDIR)
++ $(INSTALL_DATA) $(providers_jar) $(DESTDIR)/$(JARDIR)
+
+ # End of Makefile.am
diff --git a/recipes/classpathx/gnumail-native_1.1.2.bb b/recipes/classpathx/gnumail-native_1.1.2.bb
new file mode 100644
index 0000000000..5d547b7d12
--- /dev/null
+++ b/recipes/classpathx/gnumail-native_1.1.2.bb
@@ -0,0 +1,10 @@
+require gnumail_${PV}.bb
+
+inherit native
+
+DEPENDS = "fastjar-native gnujaf-native inetlib-native"
+
+EXTRA_OECONF = "\
+ --with-inetlib-jar=${STAGING_DATADIR}/java \
+ --with-activation-jar=${STAGING_DATADIR}/java \
+ "
diff --git a/recipes/classpathx/gnumail_1.1.2.bb b/recipes/classpathx/gnumail_1.1.2.bb
new file mode 100644
index 0000000000..4e67558067
--- /dev/null
+++ b/recipes/classpathx/gnumail_1.1.2.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "GNU's free implementation of the JavaMail API specification"
+LICENSE = "GPL + library exception"
+AUTHOR = "GNU ClasspathX"
+
+SRC_URI = "\
+ http://ftp.gnu.org/gnu/classpathx/mail-${PV}.tar.gz \
+ file://datadir_java.patch;patch=1 \
+ "
+
+inherit java-library autotools
+
+S = "${WORKDIR}/mail-${PV}"
+
+DEPENDS = "fastjar-native gnujaf inetlib"
+
+export JAVAC = "${STAGING_BINDIR_NATIVE}/javac"
+export JAVA = "${STAGING_BINDIR_NATIVE}/java"
+
+# Fake javadoc
+export JAVADOC = "true"
+
+EXTRA_OECONF = "\
+ --with-inetlib-jar=${STAGING_DATADIR_JAVA} \
+ --with-activation-jar=${STAGING_DATADIR_JAVA} \
+ "
+
+do_compile() {
+ oe_runmake \
+ JARDIR=${datadir_java} \
+ gnumail_jar=${JARFILENAME} \
+ providers_jar=${P}-providers.jar
+}
+
+do_install() {
+ java_install
+ oe_jarinstall ${P}-providers.jar ${PN}-providers.jar
+}
+
+do_stage() {
+ java_stage
+ oe_jarinstall -s ${P}-providers.jar ${PN}-providers.jar
+}