aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorHenning Heinold <h.heinold@tarent.de>2010-07-12 17:11:12 +0200
committerHenning Heinold <h.heinold@tarent.de>2010-07-26 15:35:26 +0200
commit6440e87767ed6aea4e89f73a11b87ae576867da6 (patch)
tree6eab9fa4f2d9b9ff54422f1bebea598e42e81edc
parent884b71f2694eec2b5375b2ab4354b525ff0949d0 (diff)
downloadopenembedded-6440e87767ed6aea4e89f73a11b87ae576867da6.tar.gz
cacaoh-openjdk-native: backported from openembedded-dev
Acked-by: Koen Kooi <koen@openembedded.org> Acked-by: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl>
-rw-r--r--recipes/cacao/cacaoh-openjdk-native.inc31
-rw-r--r--recipes/cacao/cacaoh-openjdk-native_0.99.4.bb8
2 files changed, 39 insertions, 0 deletions
diff --git a/recipes/cacao/cacaoh-openjdk-native.inc b/recipes/cacao/cacaoh-openjdk-native.inc
new file mode 100644
index 0000000000..7670215a33
--- /dev/null
+++ b/recipes/cacao/cacaoh-openjdk-native.inc
@@ -0,0 +1,31 @@
+DESCRIPTION = "Header generator for Cacao JVM - Needed for cross-compilation builds"
+HOMEPAGE = "http://www.cacaojvm.org/"
+LICENSE = "GPL"
+
+DEPENDS = "libtool-native zlib-native virtual/javac-native classpath-native icedtea6-native"
+
+inherit java autotools
+
+S = "${WORKDIR}/cacao-${PV}"
+
+inherit autotools native
+
+EXTRA_OECONF = " \
+ --with-java-runtime-library=openjdk \
+ --with-java-runtime-library-classes=${STAGING_LIBDIR_JVM_NATIVE}/icedtea6-native/jre/lib/rt.jar \
+ --with-jni_md_h=${STAGING_INCDIR}/classpath \
+ --with-jni_h=${STAGING_INCDIR}/classpath \
+ --with-hpi_md_h=${STAGING_LIBDIR_JVM_NATIVE}/icedtea6-native/include/hpi \
+ --with-hpi_h=${STAGING_LIBDIR_JVM_NATIVE}/icedtea6-native/include/hpi \
+ "
+
+do_compile() {
+ # Compile the header generator only (and what is needed for it).
+ oe_runmake -C src/toolbox libtoolbox.la
+ oe_runmake -C src/vmcore libvmcore.la
+ oe_runmake -C src/cacaoh cacaoh
+}
+
+do_stage() {
+ install -m 0755 src/cacaoh/.libs/cacaoh ${STAGING_BINDIR}/cacaoh-openjdk-${PV}
+}
diff --git a/recipes/cacao/cacaoh-openjdk-native_0.99.4.bb b/recipes/cacao/cacaoh-openjdk-native_0.99.4.bb
new file mode 100644
index 0000000000..27ab6ab006
--- /dev/null
+++ b/recipes/cacao/cacaoh-openjdk-native_0.99.4.bb
@@ -0,0 +1,8 @@
+require cacaoh-openjdk-native.inc
+
+PR = "r0"
+
+SRC_URI[md5sum] = "63220327925ace13756ae334c55a3baa"
+SRC_URI[sha256sum] = "1dfc4903dc0172286df4f1740fd0f12749ac81d51c602290b47cbe83d51e1d56"
+
+SRC_URI = "http://www.complang.tuwien.ac.at/cacaojvm/download/cacao-${PV}/cacao-${PV}.tar.bz2"