aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <marcin@juszkiewicz.com.pl>2009-11-16 14:51:56 +0100
committerMarcin Juszkiewicz <marcin@buglabs.net>2009-12-02 16:39:22 +0100
commit0cfdd66f88ebeee9d6c08c152951fce9c751acf1 (patch)
tree5eb21359fa12b8a8b6de7292ba63e885651fc8df
parentc8a4fa25c47fb6a8a17182aead5f4f82973ce2d3 (diff)
downloadopenembedded-0cfdd66f88ebeee9d6c08c152951fce9c751acf1.tar.gz
xserver-xorg-conf: added BUG support
Signed-off-by: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl> Acked-by: Koen Kooi <koen@openembedded.org>
-rw-r--r--recipes/xorg-xserver/xserver-xorg-conf/bug/xorg.conf65
-rw-r--r--recipes/xorg-xserver/xserver-xorg-conf_0.1.bb2
2 files changed, 66 insertions, 1 deletions
diff --git a/recipes/xorg-xserver/xserver-xorg-conf/bug/xorg.conf b/recipes/xorg-xserver/xserver-xorg-conf/bug/xorg.conf
new file mode 100644
index 0000000000..8b6cd94ab6
--- /dev/null
+++ b/recipes/xorg-xserver/xserver-xorg-conf/bug/xorg.conf
@@ -0,0 +1,65 @@
+#
+# Initial version of X11 configuration for BugLabs BUG device.
+#
+# Up to 2 LCD modules are supported (as DISPLAY=0.0/0.1).
+# Touchscreen on first screen works properly (req tslib 0.0.6 driver).
+#
+# By default software starts on 0.0 only.
+#
+
+Section "Monitor"
+ Identifier "Monitor 1"
+EndSection
+
+Section "Monitor"
+ Identifier "Monitor 2"
+EndSection
+
+Section "Device"
+ Identifier "fbdev Device 2"
+ Driver "fbdev"
+ Option "fbdev" "/dev/fb2"
+ Option "shadowfb" "true"
+EndSection
+
+Section "Device"
+ Identifier "fbdev Device 1"
+ Driver "fbdev"
+ Option "fbdev" "/dev/fb1"
+ Option "shadowfb" "true"
+EndSection
+
+Section "Screen"
+ Identifier "fbdev Screen 2"
+ Device "fbdev Device 2"
+ Monitor "Monitor 2"
+EndSection
+
+Section "Screen"
+ Identifier "fbdev Screen 1"
+ Device "fbdev Device 1"
+ Monitor "Monitor 1"
+EndSection
+
+Section "ServerLayout"
+ Identifier "Layout"
+ Screen "fbdev Screen 1"
+ Screen "fbdev Screen 2" Below "fbdev Screen 1"
+ InputDevice "ts4" "CorePointer"
+EndSection
+
+Section "InputDevice"
+ Identifier "ts5"
+ Driver "tslib"
+ Option "Device" "/dev/input/bmi_lcd_ts5"
+EndSection
+
+Section "InputDevice"
+ Identifier "ts4"
+ Driver "tslib"
+ Option "Device" "/dev/input/bmi_lcd_ts4"
+EndSection
+
+Section "ServerFlags"
+ Option "AutoAddDevices" "false"
+EndSection
diff --git a/recipes/xorg-xserver/xserver-xorg-conf_0.1.bb b/recipes/xorg-xserver/xserver-xorg-conf_0.1.bb
index 95aa82bef9..67fc683090 100644
--- a/recipes/xorg-xserver/xserver-xorg-conf_0.1.bb
+++ b/recipes/xorg-xserver/xserver-xorg-conf_0.1.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "Machine specific xorg.conf files"
-PR = "r4"
+PR = "r5"
SRC_URI = "file://xorg.conf"