aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@koansoftware.com>2010-01-12 06:43:49 +0000
committerMarcin Juszkiewicz <marcin@buglabs.net>2010-01-13 18:15:31 +0100
commit0f86c3441a9999c85682eb20a88b5e91f91960ab (patch)
tree62b9283abeaa5c9cdd093fb1b9b4d2ed1c5b6143
parent30769bf4314e60e4e3b842b6f479e3b447438890 (diff)
downloadopenembedded-0f86c3441a9999c85682eb20a88b5e91f91960ab.tar.gz
matchbox-session: simple provider of Matchbox session for X11 startup
In GPE images we use gpe-session-scripts to provide Xsession init scripts for launching Matchbox components. But what if someone do not want GPE but want Matchbox? Poky has it cleaned in other way. Signed-off-by: Marcin Juszkiewicz <marcin@juszkiewicz.com.pl> Acked-by: Denys Dmytriyenko <denis@denix.org>
-rw-r--r--recipes/matchbox-session/matchbox-session.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/recipes/matchbox-session/matchbox-session.bb b/recipes/matchbox-session/matchbox-session.bb
new file mode 100644
index 0000000000..c9014f9000
--- /dev/null
+++ b/recipes/matchbox-session/matchbox-session.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Matchbox session support"
+RDEPENDS = "matchbox-common"
+# they do the same in other way
+RCONFLICTS = "gpe-session-scripts"
+
+do_install() {
+ install -d ${D}${sysconfdir}/X11/Xsession.d/
+ ln -sf ${bindir}/matchbox-session ${D}${sysconfdir}/X11/Xsession.d/90matchbox-session
+}
+
+PACKAGE_ARCH = "all"
+PACKAGES = "${PN}"
+
+FILES_${PN} = "${sysconfdir}"