aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2011-07-04 16:50:23 +0200
committerDenis 'GNUtoo' Carikli <GNUtoo@no-log.org>2011-07-05 17:49:39 +0200
commitd5840f76a5c4d145b1a81de48fdd7cb0dc9f2ee4 (patch)
treec0905a3414c54481f2ff798218c30af3ba60b413
parent99586e72058700db67eec1b83b00f1a050b0f374 (diff)
downloadopenembedded-d5840f76a5c4d145b1a81de48fdd7cb0dc9f2ee4.tar.gz
bug: unbreak udev 171 for bug.
This commit adds support for udev compat for udev 171, and RDEPENDS_${PN} on bug-udev for bug and bug20. The bug machine still uses a 2.6.27 kernel, and the boot was blocked at: Checking for built-in Bluetooth: no Note that this commit doesn't magically fix udev, because the init script activates udev compat only for kernel inferior to 2.6.27 and we have a 2.6.27 A future commit will address that. Signed-off-by: Denis 'GNUtoo' Carikli <GNUtoo@no-log.org>
-rw-r--r--conf/machine/bug.conf2
-rw-r--r--recipes/udev/udev_171.bb9
2 files changed, 10 insertions, 1 deletions
diff --git a/conf/machine/bug.conf b/conf/machine/bug.conf
index e45629d191..f79c9967f2 100644
--- a/conf/machine/bug.conf
+++ b/conf/machine/bug.conf
@@ -25,3 +25,5 @@ XSERVER = "xserver-xorg \
xf86-input-mouse \
xf86-video-fbdev \
xf86-input-keyboard"
+
+PREFERRED_PROVIDER_udev-compat = "udev-compat141"
diff --git a/recipes/udev/udev_171.bb b/recipes/udev/udev_171.bb
index e53b4903db..31094dc85c 100644
--- a/recipes/udev/udev_171.bb
+++ b/recipes/udev/udev_171.bb
@@ -14,7 +14,7 @@ DEFAULT_PREFERENCE = "-1"
DEPENDS = "gperf-native usbutils acl glib-2.0"
SRCREV = "${PV}"
-PR = "r0"
+PR = "r1"
# version specific SRC_URI
SRC_URI = "git://git.kernel.org/pub/scm/linux/hotplug/udev.git;protocol=git \
@@ -36,6 +36,8 @@ SRC_URI += " \
"
# Machine specific udev rules should be in their own recipe that ${PN} can add to RRECOMMENDS
+RRECOMMENDS_${PN}_bug += "bug-udev"
+RRECOMMENDS_${PN}_bug20 += "bug-udev"
S = "${WORKDIR}/git"
@@ -84,6 +86,11 @@ FILES_${PN} += "${base_libdir}/systemd"
RPROVIDES_${PN}_append = " udev-compat-wrapper"
+RDEPENDS_udev_bug += "udev-compat"
+do_unpack_append_bug() {
+ bb.build.exec_func('do_apply_compat_wrapper', d)
+}
+
do_install () {
install -d ${D}${usrsbindir} \
${D}${sbindir}