aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJeff Lance <j-lance1@ti.com>2011-06-30 21:38:08 +0000
committerDenys Dmytriyenko <denys@ti.com>2011-06-30 16:30:03 -0400
commit52f5e934535672bdf269743a6d5e05e2e1e8c0d3 (patch)
tree0ef3ddbdfd9e531e85060982cd3d2c948de31a84
parent30775f90f3d451bf83512ecbda23f32b522638e1 (diff)
downloadopenembedded-52f5e934535672bdf269743a6d5e05e2e1e8c0d3.tar.gz
am-benchmarks: Remove platform dependencies
* Remove platform dependencies and use architecture dependencies instead * Use OE BASE_PACKAGE_ARCH to determine architecture * Update the SRCREV to revision 66 * Update the recipe revision to 1.3 * Removed INSANE_SKIP NOTE - architecture dependency can be removed once CFLAGS can be passed into CCSv5 project makefile Signed-off-by: Jeff Lance <j-lance1@ti.com> Acked-by: Chase Maupin <chase.maupin@ti.com> Signed-off-by: Denys Dmytriyenko <denys@ti.com>
-rw-r--r--recipes/ti/am-benchmarks_1.3.bb38
1 files changed, 38 insertions, 0 deletions
diff --git a/recipes/ti/am-benchmarks_1.3.bb b/recipes/ti/am-benchmarks_1.3.bb
new file mode 100644
index 0000000000..6070fe8db1
--- /dev/null
+++ b/recipes/ti/am-benchmarks_1.3.bb
@@ -0,0 +1,38 @@
+#NOTE: This package is currently only supported for the Angstrom
+# distribution. Other distributions and toolchains may or
+# may not work.
+
+DESCRIPTION = "AM Benchmarks"
+HOMEPAGE = "https://gforge.ti.com/gf/project/am_benchmarks/"
+LICENSE = "BSD"
+SECTION = "system"
+PRIORITY = "optional"
+
+SRCREV = "66"
+PR = "r2+svnr${SRCPV}"
+
+SRC_URI = "svn://gforge.ti.com/svn/am_benchmarks/;module=trunk;proto=https;user=anonymous;pswd=''"
+
+S = "${WORKDIR}/trunk"
+
+do_configure() {
+ # Find all the objects.mk files for the Release target
+ files=`find ${BASE_PACKAGE_ARCH} -name "objects.mk" | grep Release`
+ for f in $files
+ do
+ sed -i -e 's|LIBS :=|LIBS := ${LDFLAGS} |' $f
+ done
+}
+
+do_compile() {
+ # don't build debug version
+ touch debug
+ export CROSS_COMPILE=${TARGET_PREFIX}
+ export ARCH=${BASE_PACKAGE_ARCH}
+ make release
+}
+
+do_install() {
+ export ARCH=${BASE_PACKAGE_ARCH}
+ make DESTDIR=${D} install
+}