aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMike Westerhof <mike@mwester.net>2011-07-13 17:50:52 -0500
committerMike Westerhof <mike@mwester.net>2011-07-13 17:50:52 -0500
commit0cdeac241f08f34a4d854e743893ea7a1e48123c (patch)
tree353e60f9a48da88fe918b7eaf9a086c0a1ea6403
parent4f46441cb5fd6677775085a37f58645464652707 (diff)
parentb59743b9136df1f427b1bd1ae260c8f30ab6e880 (diff)
downloadopenembedded-0cdeac241f08f34a4d854e743893ea7a1e48123c.tar.gz
Merge branch 'org.openembedded.dev' of git.openembedded.org:openembedded into slugos/slugos6.0-beta
-rw-r--r--conf/distro/kaeilos.conf9
-rw-r--r--recipes/beagleboard/beagleboard-test-scripts_git.bb14
-rw-r--r--recipes/bluez/bluez4/fix-build-races.patch29
-rw-r--r--recipes/bluez/bluez4_4.91.bb4
-rw-r--r--recipes/linux/linux-2.6.28/mh355/defconfig22
-rw-r--r--recipes/linux/linux-omap-psp-2.6.32/beagleboard-xmc/0008-omap3-beagle-cleaned-up-board-revision-conditions.patch4
-rw-r--r--recipes/linux/linux-omap-psp_2.6.32.bb2
-rw-r--r--recipes/mozilla/firefox_3.6.8.bb2
8 files changed, 61 insertions, 25 deletions
diff --git a/conf/distro/kaeilos.conf b/conf/distro/kaeilos.conf
index d2c928996f..b4b20b4af9 100644
--- a/conf/distro/kaeilos.conf
+++ b/conf/distro/kaeilos.conf
@@ -4,17 +4,16 @@
#@DESCRIPTION: KaeilOS Linux Distribution for Kernel 2.6 based devices
# This version is strictly conformed to Angstrom
#@MAINTAINER: Marco Cavallini <m.cavallini@koansoftware.com>
-#@VERSION: 20-01-2011
+#@VERSION: 13-07-2011
#
# KaeilOS is a registered trade mark of KOAN - Bergamo - Italia
# Use this at your own risk, we welcome bugreports filed at
# Product website : http://www.KaeilOS.com
#@--------------------------------------------------------------------
-#DISTRO_VERSION = "2009.2"
-DISTRO_VERSION = "2009.2-test-${DATE}"
-DISTRO_REVISION = "2"
-DISTRO_PR = ".7"
+DISTRO_VERSION = "2011.3-${DATE}"
+DISTRO_REVISION = "3"
+DISTRO_PR = ".8"
OLDEST_KERNEL ?= "2.6.16"
diff --git a/recipes/beagleboard/beagleboard-test-scripts_git.bb b/recipes/beagleboard/beagleboard-test-scripts_git.bb
index be0d059c98..0ee7954f02 100644
--- a/recipes/beagleboard/beagleboard-test-scripts_git.bb
+++ b/recipes/beagleboard/beagleboard-test-scripts_git.bb
@@ -1,14 +1,18 @@
## Reminder: The correct spacing for a variable is FOO = "BAR" in : PR="r1"
DESCRIPTION = "BeagleBoard test scripts"
HOMEPAGE = "http://beagleboad.org/support"
-PR = "r2"
+PR = "r3"
-SRC_URI = "git://gitorious.org/beagleboard-validation/scripts.git;protocol=git \
+SRC_URI = "git://gitorious.org/~joelf/beagleboard-validation/validation-scripts.git;protocol=git \
"
-SRCREV = "473dd2ab20d866be6168c9f992c2c9e74e485c9d"
+SRCREV = "2df76857155fbd462527c2b00ee83214483f0594"
S = "${WORKDIR}/git"
+inherit update-rc.d
+INITSCRIPT_NAME = "flash-nand-fs.sh"
+INITSCRIPT_PARAMS = "start 99 2 3 4 5 ."
+
do_install() {
TEST_FILES=" \
testaudio \
@@ -28,4 +32,8 @@ do_install() {
for i in ${TEST_FILES}; do
install -m 0755 ${S}/${i} ${D}/${bindir}
done
+ # A script to flash NAND if the board has it, and if there is valid image to flash on the SD Card.
+ # We also register it as an init script so that the SD Card auto-flashes to NAND during boot.
+ install -d ${D}/${sysconfdir}/init.d/
+ install -m 0755 ${S}/flashing/flash-nand-fs.sh ${D}/${sysconfdir}/init.d/flash-nand-fs.sh
}
diff --git a/recipes/bluez/bluez4/fix-build-races.patch b/recipes/bluez/bluez4/fix-build-races.patch
new file mode 100644
index 0000000000..47c355e90e
--- /dev/null
+++ b/recipes/bluez/bluez4/fix-build-races.patch
@@ -0,0 +1,29 @@
+Add 'local_headers' to BUILT_SOURCES so that they're treated correctly
+and we don't have a race on generating these versus using them.
+---
+ Makefile.am | 5 ++---
+ 1 file changed, 2 insertions(+), 3 deletions(-)
+
+Index: bluez-4.91/Makefile.am
+===================================================================
+--- bluez-4.91.orig/Makefile.am
++++ bluez-4.91/Makefile.am
+@@ -47,6 +47,8 @@ lib_headers = lib/bluetooth.h lib/hci.h
+ lib/rfcomm.h lib/bnep.h lib/cmtp.h lib/hidp.h
+ local_headers = $(foreach file,$(lib_headers), lib/bluetooth/$(notdir $(file)))
+
++BUILT_SOURCES = $(local_headers)
++
+ include_HEADERS += $(lib_headers)
+
+ lib_LTLIBRARIES += lib/libbluetooth.la
+@@ -56,9 +58,6 @@ lib_libbluetooth_la_SOURCES = $(lib_head
+ lib_libbluetooth_la_LDFLAGS = -version-info 14:0:11
+ lib_libbluetooth_la_DEPENDENCIES = $(local_headers)
+
+-CLEANFILES += $(local_headers)
+-
+-
+ if SBC
+ noinst_LTLIBRARIES += sbc/libsbc.la
+
diff --git a/recipes/bluez/bluez4_4.91.bb b/recipes/bluez/bluez4_4.91.bb
index 95d1d8c64a..33f0422ac1 100644
--- a/recipes/bluez/bluez4_4.91.bb
+++ b/recipes/bluez/bluez4_4.91.bb
@@ -3,13 +3,15 @@ require bluez4.inc
SRC_URI[md5sum] = "3059b7ef5168c84cd0c6a67034ce79f9"
SRC_URI[sha256sum] = "11e9279e2669db996afd464b96d2c68f41f157f6eb9b8842a0bbcad8a4eac18d"
+SRC_URI += "file://fix-build-races.patch"
+
DEFAULT_PREFERENCE = "-1"
DEFAULT_PREFERENCE_angstrom = "1"
DEFAULT_PREFERENCE_shr = "1"
DEPENDS += "libsndfile1"
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
# Not all distros have a recent enough udev
BTUDEV = " --disable-udevrules"
diff --git a/recipes/linux/linux-2.6.28/mh355/defconfig b/recipes/linux/linux-2.6.28/mh355/defconfig
index a912594cb8..f678b15f96 100644
--- a/recipes/linux/linux-2.6.28/mh355/defconfig
+++ b/recipes/linux/linux-2.6.28/mh355/defconfig
@@ -1,7 +1,7 @@
#
# Automatically generated make config: don't edit
# Linux kernel version: 2.6.28.10
-# Sat Mar 20 22:28:15 2010
+# Thu Jun 9 12:21:12 2011
#
CONFIG_ARM=y
CONFIG_SYS_SUPPORTS_APM_EMULATION=y
@@ -45,8 +45,7 @@ CONFIG_SYSVIPC_SYSCTL=y
CONFIG_LOG_BUF_SHIFT=14
# CONFIG_CGROUPS is not set
# CONFIG_GROUP_SCHED is not set
-CONFIG_SYSFS_DEPRECATED=y
-CONFIG_SYSFS_DEPRECATED_V2=y
+# CONFIG_SYSFS_DEPRECATED_V2 is not set
# CONFIG_RELAY is not set
CONFIG_NAMESPACES=y
# CONFIG_UTS_NS is not set
@@ -104,7 +103,7 @@ CONFIG_BLOCK=y
# CONFIG_LBD is not set
# CONFIG_BLK_DEV_IO_TRACE is not set
# CONFIG_LSF is not set
-# CONFIG_BLK_DEV_BSG is not set
+CONFIG_BLK_DEV_BSG=y
# CONFIG_BLK_DEV_INTEGRITY is not set
#
@@ -258,7 +257,8 @@ CONFIG_VMSPLIT_3G=y
CONFIG_PAGE_OFFSET=0xC0000000
# CONFIG_PREEMPT is not set
CONFIG_HZ=100
-# CONFIG_AEABI is not set
+CONFIG_AEABI=y
+# CONFIG_OABI_COMPAT is not set
CONFIG_ARCH_FLATMEM_HAS_HOLES=y
# CONFIG_ARCH_SPARSEMEM_DEFAULT is not set
# CONFIG_ARCH_SELECT_MEMORY_MODEL is not set
@@ -299,9 +299,6 @@ CONFIG_CMDLINE="mem=64M console=ttyS0,115200 initrd=0x21100000,3145728 root=/dev
#
# At least one emulation must be selected
#
-CONFIG_FPE_NWFPE=y
-# CONFIG_FPE_NWFPE_XP is not set
-# CONFIG_FPE_FASTFPE is not set
# CONFIG_VFP is not set
#
@@ -312,7 +309,6 @@ CONFIG_BINFMT_ELF=y
CONFIG_HAVE_AOUT=y
# CONFIG_BINFMT_AOUT is not set
# CONFIG_BINFMT_MISC is not set
-# CONFIG_ARTHUR is not set
#
# Power management options
@@ -400,7 +396,7 @@ CONFIG_WIRELESS_OLD_REGULATORY=y
#
# Generic Driver Options
#
-CONFIG_UEVENT_HELPER_PATH="/sbin/hotplug"
+CONFIG_UEVENT_HELPER_PATH=""
CONFIG_STANDALONE=y
CONFIG_PREVENT_FIRMWARE_BUILD=y
CONFIG_FW_LOADER=y
@@ -586,6 +582,7 @@ CONFIG_SCSI_WAIT_SCAN=m
# CONFIG_SCSI_SPI_ATTRS is not set
# CONFIG_SCSI_FC_ATTRS is not set
# CONFIG_SCSI_ISCSI_ATTRS is not set
+# CONFIG_SCSI_SAS_ATTRS is not set
# CONFIG_SCSI_SAS_LIBSAS is not set
# CONFIG_SCSI_SRP_ATTRS is not set
CONFIG_SCSI_LOWLEVEL=y
@@ -1188,7 +1185,7 @@ CONFIG_RTC_DRV_AT91SAM9_GPBR=0
# CONFIG_EXT4_FS is not set
# CONFIG_REISERFS_FS is not set
# CONFIG_JFS_FS is not set
-# CONFIG_FS_POSIX_ACL is not set
+CONFIG_FS_POSIX_ACL=y
CONFIG_FILE_LOCKING=y
# CONFIG_XFS_FS is not set
# CONFIG_OCFS2_FS is not set
@@ -1199,6 +1196,7 @@ CONFIG_INOTIFY_USER=y
# CONFIG_AUTOFS_FS is not set
# CONFIG_AUTOFS4_FS is not set
# CONFIG_FUSE_FS is not set
+CONFIG_GENERIC_ACL=y
#
# CD-ROM/DVD Filesystems
@@ -1224,7 +1222,7 @@ CONFIG_PROC_SYSCTL=y
CONFIG_PROC_PAGE_MONITOR=y
CONFIG_SYSFS=y
CONFIG_TMPFS=y
-# CONFIG_TMPFS_POSIX_ACL is not set
+CONFIG_TMPFS_POSIX_ACL=y
# CONFIG_HUGETLB_PAGE is not set
# CONFIG_CONFIGFS_FS is not set
diff --git a/recipes/linux/linux-omap-psp-2.6.32/beagleboard-xmc/0008-omap3-beagle-cleaned-up-board-revision-conditions.patch b/recipes/linux/linux-omap-psp-2.6.32/beagleboard-xmc/0008-omap3-beagle-cleaned-up-board-revision-conditions.patch
index 513a1019c2..fb91cb6f28 100644
--- a/recipes/linux/linux-omap-psp-2.6.32/beagleboard-xmc/0008-omap3-beagle-cleaned-up-board-revision-conditions.patch
+++ b/recipes/linux/linux-omap-psp-2.6.32/beagleboard-xmc/0008-omap3-beagle-cleaned-up-board-revision-conditions.patch
@@ -143,8 +143,8 @@ index 4bde54b..664a9c6 100644
omap3_beagle_i2c_init();
- if (cpu_is_omap3630()) {
-+ if ((omap3_beagle_get_rev() != OMAP3BEAGLE_BOARD_XMAB) &&
-+ (omap3_beagle_get_rev() != OMAP3BEAGLE_BOARD_XMC)) {
++ if ((omap3_beagle_get_rev() == OMAP3BEAGLE_BOARD_XMAB) ||
++ (omap3_beagle_get_rev() == OMAP3BEAGLE_BOARD_XMC)) {
gpio_buttons[0].gpio = 4;
}
diff --git a/recipes/linux/linux-omap-psp_2.6.32.bb b/recipes/linux/linux-omap-psp_2.6.32.bb
index ff9e1664cb..e33dc51f2b 100644
--- a/recipes/linux/linux-omap-psp_2.6.32.bb
+++ b/recipes/linux/linux-omap-psp_2.6.32.bb
@@ -9,7 +9,7 @@ COMPATIBLE_MACHINE = "am3517-crane|beagleboard|omap3evm|am3517-evm|dm37x-evm|am3
SRCREV = "5fc29e7b2a76a64a739f857858ef0b98294aa155"
# The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc
-MACHINE_KERNEL_PR_append = "d+gitr${SRCREV}"
+MACHINE_KERNEL_PR_append = "e+gitr${SRCREV}"
SRC_URI = "git://arago-project.org/git/projects/linux-omap3.git;protocol=http;branch=master \
file://0001-Added-Crane-Board-support.patch \
diff --git a/recipes/mozilla/firefox_3.6.8.bb b/recipes/mozilla/firefox_3.6.8.bb
index 7fdda992d6..2aa529ebbf 100644
--- a/recipes/mozilla/firefox_3.6.8.bb
+++ b/recipes/mozilla/firefox_3.6.8.bb
@@ -1,7 +1,7 @@
DEPENDS += "cairo sqlite3 libnotify"
DEPENDS_append_libc-uclibc = " virtual/libintl-native"
-PR = "r4"
+PR = "r5"
# The .pc files below have "3.6" hardcoded, fix that before using them in a newer FF version!
SRC_URI = "ftp://ftp.mozilla.org/pub/mozilla.org/firefox/releases/${PV}/source/firefox-${PV}.source.tar.bz2;name=archive \