aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-04-16 23:14:30 +0200
committerMartin Jansa <Martin.Jansa@gmail.com>2010-04-16 23:14:30 +0200
commit9d93b7599f97705fb406c1335fc7ce82ba038cba (patch)
tree8f6f6de152cd704cca01cca942931c32fe942902
parentfe6ee7e734ee929630f8724c909037e8de2f33f2 (diff)
parent7397c722a8c5ae528a5a80bffe752afa4766c721 (diff)
downloadopenembedded-9d93b7599f97705fb406c1335fc7ce82ba038cba.tar.gz
Merge remote branch 'origin/org.openembedded.dev' into shr/unstable
Conflicts: recipes/u-boot/u-boot_git.bb
-rw-r--r--recipes/chromium/chromium/armv7a/include.gypi25
-rw-r--r--recipes/chromium/chromium/gypi.patch19
-rw-r--r--recipes/chromium/chromium_svn.bb129
-rw-r--r--recipes/dfu-programmer/dfu-programmer_0.5.2.bb17
-rw-r--r--recipes/dfu-programmer/dfu-programmer_svn.bb16
-rw-r--r--recipes/libxml/libxml2.inc4
-rw-r--r--recipes/mozilla/nss-3.12.6/nss.pc.in2
-rw-r--r--recipes/mozilla/nss-3.12/nss.pc.in2
-rw-r--r--recipes/mozilla/nss_3.12.6.bb2
-rw-r--r--recipes/mozilla/nss_3.12.bb2
-rw-r--r--recipes/u-boot/u-boot_git.bb59
-rw-r--r--recipes/xorg-xserver/xserver-xorg-conf/dm3730-am3715-evm/xorg.conf29
-rw-r--r--recipes/xorg-xserver/xserver-xorg-conf/omap3/xorg.conf29
-rw-r--r--recipes/xorg-xserver/xserver-xorg-conf_0.1.bb2
14 files changed, 296 insertions, 41 deletions
diff --git a/recipes/chromium/chromium/armv7a/include.gypi b/recipes/chromium/chromium/armv7a/include.gypi
new file mode 100644
index 0000000000..1a4580bff6
--- /dev/null
+++ b/recipes/chromium/chromium/armv7a/include.gypi
@@ -0,0 +1,25 @@
+{
+ 'variables': {
+
+ # Configure for armv7 compilation
+ 'target_arch': 'arm',
+ 'armv7': 1,
+
+ # Disable native client (Google's settings)
+ 'disable_nacl': 1,
+
+ # V8 config (Google's settings)
+ 'v8_use_snapshot': 'false',
+
+ # No ffmpeg binaries in the tree, so make sure the build will not fail
+ 'use_system_ffmpeg' : '1',
+
+ # Needed for ARM compilation (build fails otherwise)
+ 'linux_use_tcmalloc': 0,
+
+ # Change to your rootfs path
+ 'sysroot': '__PATH__TO_BE_REPLACED__',
+
+ #'arm_thumb': 1,
+ }
+} \ No newline at end of file
diff --git a/recipes/chromium/chromium/gypi.patch b/recipes/chromium/chromium/gypi.patch
new file mode 100644
index 0000000000..cd5542f836
--- /dev/null
+++ b/recipes/chromium/chromium/gypi.patch
@@ -0,0 +1,19 @@
+--- a/tools/gyp/pylib/gyp/__init__.py 2009-12-10 22:36:18.000000000 +0800
++++ b/tools/gyp/pylib/gyp/__init__.py 2009-12-10 22:39:23.000000000 +0800
+@@ -376,10 +376,12 @@
+
+ # If ~/.gyp/include.gypi exists, it'll be forcibly included into every
+ # .gyp file that's loaded, before anything else is included.
+- if home_dot_gyp != None:
+- default_include = os.path.join(home_dot_gyp, 'include.gypi')
+- if os.path.exists(default_include):
+- includes.append(default_include)
++ #if home_dot_gyp != None:
++ # default_include = os.path.join(home_dot_gyp, 'include.gypi')
++ # if os.path.exists(default_include):
++ # includes.append(default_include)
++
++ includes.append(__PATH__TO_BE_REPLACED__)
+
+ # Command-line --include files come after the default include.
+ if options.includes:
diff --git a/recipes/chromium/chromium_svn.bb b/recipes/chromium/chromium_svn.bb
index 0ac8a82d17..9387573c56 100644
--- a/recipes/chromium/chromium_svn.bb
+++ b/recipes/chromium/chromium_svn.bb
@@ -1,16 +1,131 @@
DESCRIPTION = "Google Chrome browser"
LICENSE = "BSD"
-DEPENDS = "perl-native python-native flex-native gperf-native"
+DEPENDS = "xextproto cairo nss"
-PV = "0.0+svnr${SRCPV}"
+SRCREV = "34027"
+PV = "0.1+svnr${SRCREV}"
-SRCREV = "17935"
-SRC_URI = "svn://src.chromium.org/svn/trunk/;module=src;proto=http"
+SRC_URI = "svn://src.chromium.org/svn/trunk/;module=src;proto=http \
+ git://git.chromium.org/cros.git;protocol=git;rev=07f1fc0ce7a4bbd57f6b057435ad86f0a98e073d\
+ http://src.chromium.org/svn/trunk/tools/depot_tools.tar.gz;name=depot \
+ file://include.gypi \
+ file://gypi.patch;patch=1 \
+"
-S = "${WORKDIR}/src/chrome"
+SRC_URI[depot.md5sum] = "0d0f198a2b3c5495f75d95b867ae89b4"
+SRC_URI[depot.sha256sum] = "1ad32db3b1028da622dae6be76564e4c926647d7f839d808897a9b33a1709b68"
+
+S = "${WORKDIR}/src"
+
+custom_cached_svn() {
+ oenote "Dealing with ${1}"
+ localpath="${DL_DIR}/chromium_`echo ${1} | sed -e 's|\/|\.|g'`_${3}.tbz2"
+ mkdir -p ${2}
+ if [ -f ${localpath} ]; then
+ oenote "Extracting ${localpath}"
+ tar -xpf ${localpath} -C ${2}
+ else
+ oenote "checkout and creating ${localpath}"
+ svn checkout http://${1} ${2} --revision ${3}
+ cd ${2}
+ tar -cjpf ${localpath} .
+ fi
+}
+
+do_fetch_post() {
+ custom_cached_svn "google-breakpad.googlecode.com/svn/trunk/src" "${S}/breakpad/src" 432
+ custom_cached_svn "src.chromium.org/svn/trunk/deps/support" "${S}/build/util/support" 20411
+ custom_cached_svn "svn.webkit.org/repository/webkit/trunk/LayoutTests/fast/events" "${S}/chrome/test/data/layout_tests/LayoutTests/fast/events" 51794
+ custom_cached_svn "svn.webkit.org/repository/webkit/trunk/LayoutTests/fast/js/resources" "${S}/chrome/test/data/layout_tests/LayoutTests/fast/js/resources" 51794
+ custom_cached_svn "svn.webkit.org/repository/webkit/trunk/LayoutTests/fast/workers" "${S}/chrome/test/data/layout_tests/LayoutTests/fast/workers" 51794
+ custom_cached_svn "svn.webkit.org/repository/webkit/trunk/LayoutTests/http/tests/resources" "${S}/chrome/test/data/layout_tests/LayoutTests/http/tests/resources" 51794
+ custom_cached_svn "svn.webkit.org/repository/webkit/trunk/LayoutTests/http/tests/workers" "${S}/chrome/test/data/layout_tests/LayoutTests/http/tests/workers" 51794
+ custom_cached_svn "svn.webkit.org/repository/webkit/trunk/LayoutTests/http/tests/xmlhttprequest" "${S}/chrome/test/data/layout_tests/LayoutTests/http/tests/xmlhttprequest" 51794
+ custom_cached_svn "svn.webkit.org/repository/webkit/trunk/LayoutTests/storage/domstorage" "${S}/chrome/test/data/layout_tests/LayoutTests/storage/domstorage" 51794
+ custom_cached_svn "src.chromium.org/svn/trunk/deps/reference_builds" "${S}/chrome/tools/test/reference_build" 33840
+ custom_cached_svn "google-url.googlecode.com/svn/trunk" "${S}/googleurl" 121
+ custom_cached_svn "nativeclient.googlecode.com/svn/trunk/src/native_client" "${S}/native_client" 1067
+ custom_cached_svn "open-vcdiff.googlecode.com/svn/trunk" "${S}/sdch/open-vcdiff" 28
+ custom_cached_svn "googletest.googlecode.com/svn/trunk" "${S}/testing/gtest" 336
+ custom_cached_svn "src.chromium.org/svn/trunk/deps/third_party/WebKit" "${S}/third_party/WebKit" 33467
+ custom_cached_svn "svn.webkit.org/repository/webkit/trunk/JavaScriptCore" "${S}/third_party/WebKit/JavaScriptCore" 51794
+ custom_cached_svn "svn.webkit.org/repository/webkit/trunk/LayoutTests" "${S}/third_party/WebKit/LayoutTests" 51794
+ custom_cached_svn "svn.webkit.org/repository/webkit/trunk/WebCore" "${S}/third_party/WebKit/WebCore" 51794
+ custom_cached_svn "svn.webkit.org/repository/webkit/trunk/WebKit/chromium" "${S}/third_party/WebKit/WebKit/chromium" 51794
+ custom_cached_svn "svn.webkit.org/repository/webkit/trunk/WebKitTools/pywebsocket" "${S}/third_party/WebKit/WebKitTools/pywebsocket" 57720
+# custom_cached_svn "src.chromium.org/svn/trunk/deps/third_party/ffmpeg/binaries/linux" "${S}/third_party/ffmpeg/binaries/chromium/linux/ia32" 33521
+# custom_cached_svn "src.chromium.org/svn/trunk/deps/third_party/ffmpeg/binaries/linux_dbg" "${S}/third_party/ffmpeg/binaries/chromium/linux/ia32_dbg" 33521
+# custom_cached_svn "src.chromium.org/svn/trunk/deps/third_party/ffmpeg/binaries/linux_64" "${S}/third_party/ffmpeg/binaries/chromium/linux/x64" 33521
+# custom_cached_svn "src.chromium.org/svn/trunk/deps/third_party/ffmpeg/binaries/linux_64_dbg" "${S}/third_party/ffmpeg/binaries/chromium/linux/x64_dbg" 33521
+ custom_cached_svn "src.chromium.org/svn/trunk/deps/third_party/ffmpeg/patched-ffmpeg-mt" "${S}/third_party/ffmpeg/source/patched-ffmpeg-mt" 44766
+ custom_cached_svn "src.chromium.org/svn/trunk/deps/third_party/hunspell128" "${S}/third_party/hunspell" 30191
+ custom_cached_svn "src.chromium.org/svn/trunk/deps/third_party/icu42" "${S}/third_party/icu" 33767
+ custom_cached_svn "ots.googlecode.com/svn/trunk" "${S}/third_party/ots" 23
+ custom_cached_svn "protobuf.googlecode.com/svn/trunk" "${S}/third_party/protobuf2/src" 219
+ custom_cached_svn "skia.googlecode.com/svn/trunk/include" "${S}/third_party/skia/include" 451
+ custom_cached_svn "skia.googlecode.com/svn/trunk/src" "${S}/third_party/skia/src" 451
+ custom_cached_svn "src.chromium.org/svn/trunk/deps/third_party/xdg-utils" "${S}/third_party/xdg-utils" 29103
+ custom_cached_svn "src.chromium.org/svn/trunk/deps/third_party/yasm/patched-yasm" "${S}/third_party/yasm/source/patched-yasm" 29937
+ custom_cached_svn "gyp.googlecode.com/svn/trunk" "${S}/tools/gyp" 766
+ custom_cached_svn "src.chromium.org/svn/trunk/deps/page_cycler/acid3" "${S}/tools/page_cycler/acid3" 19546
+ custom_cached_svn "v8.googlecode.com/svn/trunk" "${S}/v8" 3431
+}
+
+addtask fetch_post before do_unpack after do_fetch
+
+do_configure() {
+ if [ ! -e ${S}/third_party/cros ] ; then
+ mv ${WORKDIR}/git ${S}/third_party/cros/
+ fi
+ cd ${WORKDIR}
+ export GYP_GENERATORS=make
+ export PATH=${WORKDIR}/depot_tools:"$PATH"
+
+ rm -f ${S}/tools/gyp/pylib/gyp/__init__.pyc
+ rm -f ${S}/tools/gyp/pylib/gyp/__init__.pyo
+ sed -e 's|__PATH__TO_BE_REPLACED__|"${WORKDIR}/include.gypi"|' -i ${S}/tools/gyp/pylib/gyp/__init__.py
+ sed -e "s|__PATH__TO_BE_REPLACED__||" -i ${WORKDIR}/include.gypi
+
+ if [ ! -e ${WORKDIR}/.gclient ] ; then
+ depot_tools/gclient config http://src.chromium.org/svn/trunk/src
+ fi
+ # This is the command lines to download everything but it's done in do_fetch_post
+ #depot_tools/gclient sync --revision src@${SRCREV} --force --verbose
+ depot_tools/gclient runhooks --force
+}
+
+TARGET_CC_ARCH += "${LDFLAGS}"
do_compile() {
cd ${S}
- ../third_party/scons/scons.py Hammer
-}
+ export CROSSTOOL=${CROSS_DIR}/bin/${TARGET_PREFIX}
+ export AR=${CROSSTOOL}ar
+ export AS=${CROSSTOOL}as
+ export RANLIB=${CROSSTOOL}ranlib
+ oe_runmake -r ${PARALLEL_MAKE} V=1 BUILDTYPE=Release chrome
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${bindir}/chrome/
+ install -m 0755 ${S}/out/Release/chrome ${D}${bindir}/chrome/
+ install -m 0644 ${S}/out/Release/chrome.pak ${D}${bindir}/chrome/
+ install -m 0644 ${S}/out/Release/product_logo_48.png ${D}${bindir}/chrome/
+ install -d ${D}${bindir}/chrome/locales/
+ install -m 0644 ${S}/out/Release/locales/en-US.pak ${D}${bindir}/chrome/locales
+ cp -a ${S}/out/Release/obj ${D}${bindir}/chrome/
+ cp -a ${S}/out/Release/obj.target ${D}${bindir}/chrome/
+ cp -a ${S}/out/Release/resources ${D}${bindir}/chrome/
+
+ find ${D}${bindir}/chrome/ -name "*.d" -delete
+ find ${D}${bindir}/chrome/ -name "*.o" -delete
+ find ${D}${bindir}/chrome/ -name "*.a" -delete
+ find ${D}${bindir}/chrome/ -name "*.cpp" -delete
+ find ${D}${bindir}/chrome/ -name "*.h" -delete
+ find ${D}${bindir}/chrome/ -name "*.cc" -delete
+}
+
+FILES_${PN} = "/usr/bin/chrome/"
+FILES_${PN}-dbg = "/usr/bin/chrome/.debug/"
+
diff --git a/recipes/dfu-programmer/dfu-programmer_0.5.2.bb b/recipes/dfu-programmer/dfu-programmer_0.5.2.bb
new file mode 100644
index 0000000000..d35c60184d
--- /dev/null
+++ b/recipes/dfu-programmer/dfu-programmer_0.5.2.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "USB Device Firmware Upgrade utility (special atmel-version)"
+SECTION = "devel"
+AUTHOR = "Weston Schmidt <weston_schmidt@alumni.purdue.edu>"
+LICENSE = "GPL"
+
+PV = "0.5.2"
+PR = "r0"
+
+DEPENDS = "libusb"
+
+SRC_URI = " \
+ ${SOURCEFORGE_MIRROR}/project/${PN}/${PN}/${PV}/${PN}-${PV}.tar.gz;name=tar \
+ "
+SRC_URI[tar.md5sum] = "ce882d37383df698a1c530080724b191"
+SRC_URI[tar.sha256sum] = "e3c8bc1429fe1681c56ddc14fb05d29a7933aac566d13f894dca6fd916829cb9"
+
+inherit autotools
diff --git a/recipes/dfu-programmer/dfu-programmer_svn.bb b/recipes/dfu-programmer/dfu-programmer_svn.bb
new file mode 100644
index 0000000000..80ebee5da2
--- /dev/null
+++ b/recipes/dfu-programmer/dfu-programmer_svn.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "USB Device Firmware Upgrade utility (special atmel-version)"
+SECTION = "devel"
+AUTHOR = "Weston Schmidt <weston_schmidt@alumni.purdue.edu>"
+LICENSE = "GPL"
+
+SRCREV = "93"
+PV = "0.5.2+svnr${SRCPV}"
+PR = "r0"
+DEFAULT_PREFERENCE = "-1"
+
+DEPENDS = "libusb"
+
+SRC_URI = "svn://${PN}.svn.sourceforge.net/svnroot/${PN}/;module=trunk;proto=http"
+S = "${WORKDIR}/trunk/${PN}"
+
+inherit autotools
diff --git a/recipes/libxml/libxml2.inc b/recipes/libxml/libxml2.inc
index e3a58918af..23b0546da1 100644
--- a/recipes/libxml/libxml2.inc
+++ b/recipes/libxml/libxml2.inc
@@ -7,7 +7,7 @@ DEPENDS_virtclass-native = "python-native"
SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz;name=archive"
S = "${WORKDIR}/${BPN}-${PV}"
-INC_PR = "r7"
+INC_PR = "r8"
BBCLASSEXTEND = "native"
@@ -20,7 +20,7 @@ EXTRA_OECONF = "\
--with-docbook \
--with-c14n"
-XPY = ""
+XPY = " --without-python"
XPY_virtclass-native = " --with-python=${PYTHON_DIR}"
EXTRA_OECONF += "${XPY}"
diff --git a/recipes/mozilla/nss-3.12.6/nss.pc.in b/recipes/mozilla/nss-3.12.6/nss.pc.in
index ff29a1ed42..e72ee5f913 100644
--- a/recipes/mozilla/nss-3.12.6/nss.pc.in
+++ b/recipes/mozilla/nss-3.12.6/nss.pc.in
@@ -7,5 +7,5 @@ Name: NSS
Description: Mozilla Network Security Services
Version: @VERSION@
Requires: nspr
-Libs: -L${libdir} -lnss3 -lnssutil3 -lsmime3 -lssl3
+Libs: -L${libdir}/nss -lnss3 -lnssutil3 -lsmime3 -lssl3
Cflags: -I${includedir}
diff --git a/recipes/mozilla/nss-3.12/nss.pc.in b/recipes/mozilla/nss-3.12/nss.pc.in
index ff29a1ed42..55497e365d 100644
--- a/recipes/mozilla/nss-3.12/nss.pc.in
+++ b/recipes/mozilla/nss-3.12/nss.pc.in
@@ -7,5 +7,5 @@ Name: NSS
Description: Mozilla Network Security Services
Version: @VERSION@
Requires: nspr
-Libs: -L${libdir} -lnss3 -lnssutil3 -lsmime3 -lssl3
+Libs: -L${libdir}/nss -lnss3 -lnssutil3 -lsmime3 -lssl3
Cflags: -I${includedir}
diff --git a/recipes/mozilla/nss_3.12.6.bb b/recipes/mozilla/nss_3.12.6.bb
index 6634613085..7da316fb14 100644
--- a/recipes/mozilla/nss_3.12.6.bb
+++ b/recipes/mozilla/nss_3.12.6.bb
@@ -1,6 +1,8 @@
DESCRIPTION = "Mozilla's SSL and TLS implementation"
HOMEPAGE = "http://www.mozilla.org/projects/security/pki/nss/"
+PR = "r1"
+
LICENSE = "MPL1.1 GPL LGPL"
DEPENDS = "sqlite3 nspr"
diff --git a/recipes/mozilla/nss_3.12.bb b/recipes/mozilla/nss_3.12.bb
index c7bc02baf8..a6408954cb 100644
--- a/recipes/mozilla/nss_3.12.bb
+++ b/recipes/mozilla/nss_3.12.bb
@@ -3,7 +3,7 @@ HOMEPAGE = "http://www.mozilla.org/projects/security/pki/nss/"
LICENSE = "MPL1.1 GPL LGPL"
-PR = "r2"
+PR = "r3"
DEPENDS = "sqlite3 nspr"
diff --git a/recipes/u-boot/u-boot_git.bb b/recipes/u-boot/u-boot_git.bb
index 05049d60ed..e2a3c16d89 100644
--- a/recipes/u-boot/u-boot_git.bb
+++ b/recipes/u-boot/u-boot_git.bb
@@ -1,5 +1,5 @@
require u-boot.inc
-PR ="r45"
+PR ="r46"
FILESPATHPKG =. "u-boot-git:"
@@ -70,7 +70,7 @@ PV_omap3evm = "2009.03+${PR}+gitr${SRCPV}"
SRC_URI_dm3730-am3715-evm = "git://arago-project.org/git/projects/u-boot-omap3.git;protocol=git"
# This tag is v2009.11_OMAPPSP_03.00.00.05
SRCREV_dm3730-am3715-evm = "9df15c53c9a9bc1ec9c68c33821c50dc26797d6c"
-PV_dm3730-am3715-evm = "2009.11+${PR}+gitr${SRCREV}"
+PV_dm3730-am3715-evm = "2009.11+${PR}+gitr{SRCPV}"
SRCREV_am3517-evm = "e60beb13cf0"
SRC_URI_append_am3517-evm = " \
@@ -114,7 +114,7 @@ do_compile_omapzoom2 () {
SRC_URI_omapzoom36x = "git://dev.omapzoom.org/pub/scm/bootloader/u-boot.git;branch=master;protocol=git"
SRCREV_omapzoom36x = "ab45d2a787a9674bed30542139175d8e090e0749"
-PV_omapzoom36x = "1.1.4+${PR}+gitr${SRCREV}"
+PV_omapzoom36x = "1.1.4+${PR}+gitr{SRCPV}"
PE_omapzoom36x = "1"
do_compile_omapzoom36x () {
@@ -133,39 +133,42 @@ SRC_URI_overo = "git://gitorious.org/u-boot-omap3/mainline.git;branch=omap3-dev;
SRCREV_overo = "2dea1db2a3b7c12ed70bbf8ee50755089c5e5170"
PV_overo = "2009.03+${PR}+gitr${SRCPV}"
-# Davinci dm355-evm/dm365-evm/dm6446-evm - PSP.03.01.00.28 (Phase 3 build 28)
+# DaVinci dm355-evm/dm365-evm/dm6446-evm/dm6467-evm/dm6467t-evm - PSP 3.1.0/3.2.0 (build 35)
-SRC_URI_dm355-evm = "git://arago-project.org/git/projects/u-boot-davinci.git;protocol=git"
-SRCREV_dm355-evm = "f8d047c84137ab331c0ee2c3e94c3f1ec4228298"
-PV_dm355-evm = "2009.10+2009.11-rc1+${PR}+gitr${SRCPV}"
+SRC_URI_dm355-evm = "git://arago-project.org/git/projects/u-boot-davinci.git;protocol=git;branch=u-boot-davinci-2009.06"
+SRCREV_dm355-evm = "ea7387c9511ac92a46d3d147adffe36f868820e4"
+PV_dm355-evm = "2009.05+2009.06-rc0+${PR}+gitr{SRCPV}"
+PE_dm355-evm = "1"
-SRC_URI_dm365-evm = "git://arago-project.org/git/projects/u-boot-davinci.git;protocol=git"
-SRCREV_dm365-evm = "f8d047c84137ab331c0ee2c3e94c3f1ec4228298"
-PV_dm365-evm = "2009.10+2009.11-rc1+${PR}+gitr${SRCPV}"
+SRC_URI_dm365-evm = "git://arago-project.org/git/projects/u-boot-davinci.git;protocol=git;branch=u-boot-davinci-2009.06"
+SRCREV_dm365-evm = "ea7387c9511ac92a46d3d147adffe36f868820e4"
+PV_dm365-evm = "2009.05+2009.06-rc0+${PR}+gitr{SRCPV}"
+PE_dm365-evm = "1"
-SRC_URI_dm6446-evm = "git://arago-project.org/git/projects/u-boot-davinci.git;protocol=git"
-SRCREV_dm6446-evm = "f8d047c84137ab331c0ee2c3e94c3f1ec4228298"
-PV_dm6446-evm = "2009.10+2009.11-rc1+${PR}+gitr${SRCPV}"
+SRC_URI_dm6446-evm = "git://arago-project.org/git/projects/u-boot-davinci.git;protocol=git;branch=u-boot-davinci-2009.06"
+SRCREV_dm6446-evm = "ea7387c9511ac92a46d3d147adffe36f868820e4"
+PV_dm6446-evm = "2009.05+2009.06-rc0+${PR}+gitr{SRCPV}"
+PE_dm6446-evm = "1"
-# Davinci dm6467-evm/dm6467-evm - PSP.03.02.00 (DM6467 Beta)
+SRC_URI_dm6467-evm = "git://arago-project.org/git/projects/u-boot-dm646x.git;protocol=git"
+SRCREV_dm6467-evm = "98b31e3aae3e3fb772f8d06c18ccdd6265aa0d38"
+PV_dm6467-evm = "2009.08+${PR}+gitr{SRCPV}"
-SRC_URI_dm6467-evm = "git://arago-project.org/git/people/hemant/u-boot-dm646x.git;protocol=git"
-SRCREV_dm6467-evm = "b037106746e5b942d7ef06bfcd776a7cdfe32f68"
-PV_dm6467-evm = "1.3.4+${PR}+gitr${SRCPV}"
+SRC_URI_dm6467t-evm = "git://arago-project.org/git/projects/u-boot-dm646x.git;protocol=git"
+SRCREV_dm6467t-evm = "98b31e3aae3e3fb772f8d06c18ccdd6265aa0d38"
+PV_dm6467t-evm = "2009.08+${PR}+gitr{SRCPV}"
-SRC_URI_dm6467t-evm = "git://arago-project.org/git/people/hemant/u-boot-dm646x.git;protocol=git"
-SRCREV_dm6467t-evm = "b037106746e5b942d7ef06bfcd776a7cdfe32f68"
-PV_dm6467t-evm = "1.3.4+${PR}+gitr${SRCPV}"
+# OMAPL1 da380-omapl137/da850-omapl138-evm - PSP 3.20.0.11
-# OMAPL da380-omapl137/da850-omapl138-evm/hawkboard - master branch (hawk still .07beta)
+SRC_URI_da830-omapl137-evm = "git://arago-project.org/git/projects/u-boot-omapl1.git;protocol=git"
+SRCREV_da830-omapl137-evm = "5f16b8551b125f16cd8d58f278cb25b94272fd9f"
+PV_da830-omapl137-evm = "2009.11+${PR}+gitr{SRCPV}"
-SRC_URI_da830-omapl137-evm = "git://arago-project.org/git/projects/u-boot-omapl1.git;protocol=git;branch=master"
-SRCREV_da830-omapl137-evm = "c7159a07ed980fddf6b804864fff872aff279dce"
-PV_da830-omapl137-evm = "2009.11+gitr${SRCREV}"
+SRC_URI_da850-omapl138-evm = "git://arago-project.org/git/projects/u-boot-omapl1.git;protocol=git"
+SRCREV_da850-omapl138-evm = "5f16b8551b125f16cd8d58f278cb25b94272fd9f"
+PV_da850-omapl138-evm = "2009.11+${PR}+gitr{SRCPV}"
-SRC_URI_da850-omapl138-evm = "git://arago-project.org/git/projects/u-boot-omapl1.git;protocol=git;branch=master"
-SRCREV_da850-omapl138-evm = "c7159a07ed980fddf6b804864fff872aff279dce"
-PV_da850-omapl138-evm = "2009.11+gitr${SRCREV}"
+# hawkboard - master branch (hawk still .07beta)
SRC_URI_hawkboard = "git://arago-project.org/git/people/sekhar/u-boot-omapl1.git;protocol=git;branch=master"
SRCREV_hawkboard = "0d291f2f255e6d66a78b3dc2445362a96ae39a57"
@@ -174,7 +177,7 @@ PV_hawkboard = "2009.08+gitr${SRCPV}"
SRC_URI_dm355-leopard = "git://www.denx.de/git/u-boot-arm.git;protocol=git;branch=master \
"
SRCREV_dm355-leopard = "d650da2dd4af99967aabc43cccbd8f160eb4cea6"
-PV_dm355-leopard = "2009.05+2010.03-rc1+gitr${SRCREV}"
+PV_dm355-leopard = "2009.05+2010.03-rc1+gitr{SRCPV}"
SRC_URI_neuros-osd2 = "git://github.com/neuros/u-boot.git;protocol=git;branch=neuros"
SRCREV_neuros-osd2 = "8de979d346624c0e4cfe2e5c0f08ce20ca4b5d14"
diff --git a/recipes/xorg-xserver/xserver-xorg-conf/dm3730-am3715-evm/xorg.conf b/recipes/xorg-xserver/xserver-xorg-conf/dm3730-am3715-evm/xorg.conf
new file mode 100644
index 0000000000..983bb0823a
--- /dev/null
+++ b/recipes/xorg-xserver/xserver-xorg-conf/dm3730-am3715-evm/xorg.conf
@@ -0,0 +1,29 @@
+Section "Module"
+ Load "extmod"
+ Load "dbe"
+ Load "glx"
+ Load "freetype"
+ Load "type1"
+ Load "record"
+ Load "dri"
+EndSection
+
+Section "Monitor"
+ Identifier "Builtin Default Monitor"
+EndSection
+
+Section "Device"
+ Identifier "Builtin Default fbdev Device 0"
+ Driver "omapfb"
+EndSection
+
+Section "Screen"
+ Identifier "Builtin Default fbdev Screen 0"
+ Device "Builtin Default fbdev Device 0"
+ Monitor "Builtin Default Monitor"
+EndSection
+
+Section "ServerLayout"
+ Identifier "Builtin Default Layout"
+ Screen "Builtin Default fbdev Screen 0"
+EndSection
diff --git a/recipes/xorg-xserver/xserver-xorg-conf/omap3/xorg.conf b/recipes/xorg-xserver/xserver-xorg-conf/omap3/xorg.conf
new file mode 100644
index 0000000000..983bb0823a
--- /dev/null
+++ b/recipes/xorg-xserver/xserver-xorg-conf/omap3/xorg.conf
@@ -0,0 +1,29 @@
+Section "Module"
+ Load "extmod"
+ Load "dbe"
+ Load "glx"
+ Load "freetype"
+ Load "type1"
+ Load "record"
+ Load "dri"
+EndSection
+
+Section "Monitor"
+ Identifier "Builtin Default Monitor"
+EndSection
+
+Section "Device"
+ Identifier "Builtin Default fbdev Device 0"
+ Driver "omapfb"
+EndSection
+
+Section "Screen"
+ Identifier "Builtin Default fbdev Screen 0"
+ Device "Builtin Default fbdev Device 0"
+ Monitor "Builtin Default Monitor"
+EndSection
+
+Section "ServerLayout"
+ Identifier "Builtin Default Layout"
+ Screen "Builtin Default fbdev Screen 0"
+EndSection
diff --git a/recipes/xorg-xserver/xserver-xorg-conf_0.1.bb b/recipes/xorg-xserver/xserver-xorg-conf_0.1.bb
index 2cc6360141..283bc58f1f 100644
--- a/recipes/xorg-xserver/xserver-xorg-conf_0.1.bb
+++ b/recipes/xorg-xserver/xserver-xorg-conf_0.1.bb
@@ -1,5 +1,5 @@
DESCRIPTION = "Machine specific xorg.conf files"
-PR = "r24"
+PR = "r25"
SRC_URI = "file://xorg.conf"