aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoger Monk <r-monk@ti.com>2010-05-26 13:41:30 +0100
committerKoen Kooi <koen@openembedded.org>2010-05-28 09:21:12 +0200
commit2b363197c06f9c61fb924bee40bc83b533cac01b (patch)
treeb12c67b1e61aacd86b8753eec6f21938a3bda987
parentf692b724d9cb01cfa6f3bc6a5f171084b1cc503c (diff)
downloadopenembedded-2b363197c06f9c61fb924bee40bc83b533cac01b.tar.gz
u-boot: Install UBOOT_BINARY in /boot, add package for -fw-utils
* Drop binary in target /boot folder to allow compatible set of boot files to be installed in target image alongside kernel, etc * Create new package for the firmware utils * Bump PR Acked-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Roger Monk <r-monk@ti.com> Signed-off-by: Koen Kooi <k-kooi@ti.com>
-rw-r--r--recipes/u-boot/u-boot.inc16
-rw-r--r--recipes/u-boot/u-boot_git.bb2
2 files changed, 15 insertions, 3 deletions
diff --git a/recipes/u-boot/u-boot.inc b/recipes/u-boot/u-boot.inc
index 24dcb2b966..323eaef318 100644
--- a/recipes/u-boot/u-boot.inc
+++ b/recipes/u-boot/u-boot.inc
@@ -17,8 +17,6 @@ UBOOT_BINARY ?= "u-boot.bin"
UBOOT_IMAGE ?= "u-boot-${MACHINE}-${PV}-${PR}.bin"
UBOOT_SYMLINK ?= "u-boot-${MACHINE}.bin"
-INSANE_SKIP_${PN} = True
-
do_compile () {
unset LDFLAGS
unset CFLAGS
@@ -29,6 +27,10 @@ do_compile () {
}
do_install () {
+ install -d ${D}/boot
+ install ${S}/${UBOOT_BINARY} ${D}/boot/${UBOOT_IMAGE}
+ ln -sf ${UBOOT_IMAGE} ${D}/boot/${UBOOT_BINARY}
+
if [ -e ${WORKDIR}/fw_env.config ] ; then
install -d ${D}${base_sbindir}
install -d ${D}${sysconfdir}
@@ -36,8 +38,18 @@ do_install () {
install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_printenv
install -m 755 ${S}/tools/env/fw_printenv ${D}${base_sbindir}/fw_setenv
fi
+
}
+FILES_${PN} = "/boot"
+# no gnu_hash in uboot.bin, by design, so skip QA
+INSANE_SKIP_${PN} = True
+
+PACKAGES += "${PN}-fw-utils"
+FILES_${PN}-fw-utils = "${sysconfdir} ${base_sbindir}"
+# u-boot doesn't use LDFLAGS for fw files, needs to get fixed, but until then:
+INSANE_SKIP_${PN}-fw-utils = True
+
do_deploy () {
install -d ${DEPLOY_DIR_IMAGE}
install ${S}/${UBOOT_BINARY} ${DEPLOY_DIR_IMAGE}/${UBOOT_IMAGE}
diff --git a/recipes/u-boot/u-boot_git.bb b/recipes/u-boot/u-boot_git.bb
index 8dca7cfd53..03c0661aad 100644
--- a/recipes/u-boot/u-boot_git.bb
+++ b/recipes/u-boot/u-boot_git.bb
@@ -1,5 +1,5 @@
require u-boot.inc
-PR ="r49"
+PR ="r50"
FILESPATHPKG =. "u-boot-git:"