aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorChase Maupin <chase.maupin@ti.com>2010-05-27 10:59:40 -0500
committerKoen Kooi <koen@openembedded.org>2010-05-28 09:21:14 +0200
commit0539d1ef424c6e9851f2c213a1b36353c0d7330f (patch)
tree5f705c71aac0c6a932fefeddc66298fdb75937f4
parentc528aa3b9d631086017df989ffd806804fa9707a (diff)
downloadopenembedded-0539d1ef424c6e9851f2c213a1b36353c0d7330f.tar.gz
matrix-gui_svn: Add autostart package
* Added package for autostarting the matrix_gui application in X11 desktops. Package is called matrix-gui-autostart. * Added .desktop file for starting the matrix_gui application when the system is logged in. * Autostart package depends on the base matrix-gui package. Acked-by: Denys Dmytriyenko <denys@ti.com> Signed-off-by: Chase Maupin <chase.maupin@ti.com> Signed-off-by: Koen Kooi <k-kooi@ti.com>
-rw-r--r--recipes/ti/matrix-gui/matrix-gui.desktop7
-rw-r--r--recipes/ti/matrix-gui_svn.bb11
2 files changed, 17 insertions, 1 deletions
diff --git a/recipes/ti/matrix-gui/matrix-gui.desktop b/recipes/ti/matrix-gui/matrix-gui.desktop
new file mode 100644
index 0000000000..52b5831fc0
--- /dev/null
+++ b/recipes/ti/matrix-gui/matrix-gui.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=Matrix GUI
+Comment=Start the Matrix GUI application
+Exec=/usr/bin/matrix_gui /usr/share/matrix/html/menu_main.html
+Terminal=false
+Type=Application
+X-GNOME-Autostart-enabled=true
diff --git a/recipes/ti/matrix-gui_svn.bb b/recipes/ti/matrix-gui_svn.bb
index 39c80de4e2..e5fc01d7f2 100644
--- a/recipes/ti/matrix-gui_svn.bb
+++ b/recipes/ti/matrix-gui_svn.bb
@@ -6,11 +6,12 @@ PRIORITY = "optional"
SRCREV = "58"
PV = "1.0"
-PR = "r12+svnr${SRCPV}"
+PR = "r13+svnr${SRCPV}"
SRC_URI = "svn://gforge.ti.com/svn/matrix_gui/;module=trunk;proto=https;user=anonymous;pswd='' \
file://0001-Disable-cursor-override-for-X11.patch;patch=1 \
file://init \
+ file://matrix-gui.desktop \
"
S = "${WORKDIR}/trunk"
@@ -45,6 +46,14 @@ do_install() {
install -m 0644 ${S}/images/*.png ${D}/${datadir}/matrix/images/
install -d ${D}${sysconfdir}/init.d/
install -c -m 0755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/matrix-gui
+ install -d ${D}/${sysconfdir}/xdg/autostart
+ install -m 0755 ${WORKDIR}/matrix-gui.desktop ${D}/${sysconfdir}/xdg/autostart
}
+FILES_${PN}-autostart = "${sysconfdir}/xdg/autostart/matrix-gui.desktop"
FILES_${PN} += "${datadir}/matrix/*"
+
+#Make autostart package depend on matrix-gui package. Doesn't make sense
+#to install the autostart package without the underlying matrix-gui package.
+RDEPENDS_${PN}-autostart = "${PN}"
+PACKAGES =+ "${PN}-autostart"