summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSebastian Spaeth <Sebastian@SSpaeth.de>2009-11-30 16:38:13 +0100
committerSebastian Spaeth <Sebastian@SSpaeth.de>2009-11-30 16:38:13 +0100
commitd63de29cf76cada8ae8708b9161c9b008f3e314c (patch)
tree6b6bbd1d09e786f13a05231a1f0d5255287debfe
parent348b91b0667f8c477a211734c9e36f6fc0c590a9 (diff)
parent7c7550ac80575d9a32714fa9c7d91ee2d0ad23bd (diff)
downloadopenembedded-d63de29cf76cada8ae8708b9161c9b008f3e314c.tar.gz
Merge commit '7c7550ac80575d9a32714fa9c7d91ee2d0ad23bd' into shr-testing2009
-rw-r--r--classes/palmtop.bbclass4
-rw-r--r--conf/machine/om-gta02.conf2
-rw-r--r--docs/usermanual/chapters/getting_oe.xml8
-rw-r--r--recipes/e17/exhibit_svn.bb2
-rw-r--r--recipes/zaurus-utils/nandlogical-klibc-static_1.0.0.bb10
-rw-r--r--recipes/zaurus-utils/nandlogical/mtd-abi.h152
-rw-r--r--recipes/zaurus-utils/nandlogical/mtd-user.h21
-rw-r--r--recipes/zaurus-utils/nandlogical_1.0.0.bb4
8 files changed, 9 insertions, 194 deletions
diff --git a/classes/palmtop.bbclass b/classes/palmtop.bbclass
index 1420089692..b4ee62c2a3 100644
--- a/classes/palmtop.bbclass
+++ b/classes/palmtop.bbclass
@@ -21,10 +21,6 @@ EXTRA_QMAKEVARS_POST += " DEFINES+=OPIE_BINDIR='\"${bindir}\"' DEFINES+=OPIE_LIB
PACKAGES = "${PN}-dbg ${PN}-dev ${PN} ${PN}-doc ${PN}-locale"
FILES_${PN} += " ${palmtopdir} "
-FILES_${PN}-dev += " ${palmtopdir}/plugins/*/lib*.so \
- ${palmtopdir}/plugins/*/*.la \
- ${palmtopdir}/plugins/*/*.a \
- ${palmtopdir}/plugins/*/*.o "
FILES_${PN}-dbg += " ${palmtopdir}/lib/.debug \
${palmtopdir}/bin/.debug \
${palmtopdir}/plugins/*/.debug "
diff --git a/conf/machine/om-gta02.conf b/conf/machine/om-gta02.conf
index d47320e59d..5fc96ec4ed 100644
--- a/conf/machine/om-gta02.conf
+++ b/conf/machine/om-gta02.conf
@@ -51,7 +51,7 @@ USE_VT = "0"
# used by some images
ROOT_FLASH_SIZE = "256"
-IMAGE_FSTYPES += "tar.gz jffs2 ubifs"
+IMAGE_FSTYPES += "tar.gz jffs2 ubifs ubi"
# extra jffs2 tweaks
EXTRA_IMAGECMD_jffs2 = "--little-endian --eraseblock=0x20000 --pagesize=0x800 \
diff --git a/docs/usermanual/chapters/getting_oe.xml b/docs/usermanual/chapters/getting_oe.xml
index c71f32d5ae..d18c9557e3 100644
--- a/docs/usermanual/chapters/getting_oe.xml
+++ b/docs/usermanual/chapters/getting_oe.xml
@@ -53,13 +53,13 @@ $ <command>cd</command> $OEBASE</screen>
<section><title>Downloading a <application>BitBake</application> release</title>
<para>Releases are available from the berlios project website. The current
release series is <application>BitBake</application> <emphasis>1.8</emphasis>
- and the current release is <emphasis>1.8.16</emphasis>. To download execute
+ and the current release is <emphasis>1.8.18</emphasis>. To download execute
the following commands:
<screen>
$ <command>cd</command> $OEBASE
-$ <command>wget</command> http://download.berlios.de/bitbake/bitbake-1.8.16.tar.gz
-$ <command>tar</command> -xvzf bitbake-1.8.16.tar.gz
-$ <command>mv</command> bitbake-1.8.16 bitbake
+$ <command>wget</command> http://download.berlios.de/bitbake/bitbake-1.8.18.tar.gz
+$ <command>tar</command> -xvzf bitbake-1.8.18.tar.gz
+$ <command>mv</command> bitbake-1.8.18 bitbake
</screen>
</para>
diff --git a/recipes/e17/exhibit_svn.bb b/recipes/e17/exhibit_svn.bb
index 0d3f3646c9..16bd1fbee9 100644
--- a/recipes/e17/exhibit_svn.bb
+++ b/recipes/e17/exhibit_svn.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Exhibit is the ETK picture viewer"
LICENSE = "MIT BSD"
DEPENDS = "evas ecore epsilon edje eet etk efreet"
PV = "0.1.1+svnr${SRCPV}"
-PR = "r1"
+PR = "r2"
inherit e
diff --git a/recipes/zaurus-utils/nandlogical-klibc-static_1.0.0.bb b/recipes/zaurus-utils/nandlogical-klibc-static_1.0.0.bb
index 42d30c90f8..f9a6b0e55d 100644
--- a/recipes/zaurus-utils/nandlogical-klibc-static_1.0.0.bb
+++ b/recipes/zaurus-utils/nandlogical-klibc-static_1.0.0.bb
@@ -2,9 +2,6 @@ require nandlogical_${PV}.bb
FILESPATHPKG =. "nandlogical:"
-SRC_URI_append = " file://mtd-user.h \
- file://mtd-abi.h \
- "
DEPENDS += "klibc"
export CC = ${TARGET_PREFIX}klcc
@@ -14,11 +11,6 @@ export CFLAGS = ""
export CPPFLAGS = ""
export LDFLAGS = ""
-do_configure_prepend() {
- sed -i 's:<mtd/mtd-user.h>:"mtd-user.h":g' '${S}/nandlogical.c'
- sed -i 's:<mtd/mtd-abi.h>:"mtd-abi.h":g' '${S}/mtd-user.h'
-}
-
do_compile() {
- ${CC} nandlogical.c -o nandlogical ${CFLAGS} ${LDFLAGS} -static
+ ${CC} ${CFLAGS} ${LDFLAGS} -static -I${STAGING_INCDIR} nandlogical.c -o nandlogical
}
diff --git a/recipes/zaurus-utils/nandlogical/mtd-abi.h b/recipes/zaurus-utils/nandlogical/mtd-abi.h
deleted file mode 100644
index 86defe175f..0000000000
--- a/recipes/zaurus-utils/nandlogical/mtd-abi.h
+++ /dev/null
@@ -1,152 +0,0 @@
-/*
- * $Id: mtd-abi.h,v 1.13 2005/11/07 11:14:56 gleixner Exp $
- *
- * Portions of MTD ABI definition which are shared by kernel and user space
- */
-
-#ifndef __MTD_ABI_H__
-#define __MTD_ABI_H__
-
-struct erase_info_user {
- uint32_t start;
- uint32_t length;
-};
-
-struct mtd_oob_buf {
- uint32_t start;
- uint32_t length;
- unsigned char *ptr;
-};
-
-#define MTD_ABSENT 0
-#define MTD_RAM 1
-#define MTD_ROM 2
-#define MTD_NORFLASH 3
-#define MTD_NANDFLASH 4
-#define MTD_DATAFLASH 6
-#define MTD_UBIVOLUME 7
-
-#define MTD_WRITEABLE 0x400 /* Device is writeable */
-#define MTD_BIT_WRITEABLE 0x800 /* Single bits can be flipped */
-#define MTD_NO_ERASE 0x1000 /* No erase necessary */
-#define MTD_STUPID_LOCK 0x2000 /* Always locked after reset */
-
-// Some common devices / combinations of capabilities
-#define MTD_CAP_ROM 0
-#define MTD_CAP_RAM (MTD_WRITEABLE | MTD_BIT_WRITEABLE | MTD_NO_ERASE)
-#define MTD_CAP_NORFLASH (MTD_WRITEABLE | MTD_BIT_WRITEABLE)
-#define MTD_CAP_NANDFLASH (MTD_WRITEABLE)
-
-/* ECC byte placement */
-#define MTD_NANDECC_OFF 0 // Switch off ECC (Not recommended)
-#define MTD_NANDECC_PLACE 1 // Use the given placement in the structure (YAFFS1 legacy mode)
-#define MTD_NANDECC_AUTOPLACE 2 // Use the default placement scheme
-#define MTD_NANDECC_PLACEONLY 3 // Use the given placement in the structure (Do not store ecc result on read)
-#define MTD_NANDECC_AUTOPL_USR 4 // Use the given autoplacement scheme rather than using the default
-
-/* OTP mode selection */
-#define MTD_OTP_OFF 0
-#define MTD_OTP_FACTORY 1
-#define MTD_OTP_USER 2
-
-struct mtd_info_user {
- uint8_t type;
- uint32_t flags;
- uint32_t size; // Total size of the MTD
- uint32_t erasesize;
- uint32_t writesize;
- uint32_t oobsize; // Amount of OOB data per block (e.g. 16)
- /* The below two fields are obsolete and broken, do not use them
- * (TODO: remove at some point) */
- uint32_t ecctype;
- uint32_t eccsize;
-};
-
-struct region_info_user {
- uint32_t offset; /* At which this region starts,
- * from the beginning of the MTD */
- uint32_t erasesize; /* For this region */
- uint32_t numblocks; /* Number of blocks in this region */
- uint32_t regionindex;
-};
-
-struct otp_info {
- uint32_t start;
- uint32_t length;
- uint32_t locked;
-};
-
-#define MEMGETINFO _IOR('M', 1, struct mtd_info_user)
-#define MEMERASE _IOW('M', 2, struct erase_info_user)
-#define MEMWRITEOOB _IOWR('M', 3, struct mtd_oob_buf)
-#define MEMREADOOB _IOWR('M', 4, struct mtd_oob_buf)
-#define MEMLOCK _IOW('M', 5, struct erase_info_user)
-#define MEMUNLOCK _IOW('M', 6, struct erase_info_user)
-#define MEMGETREGIONCOUNT _IOR('M', 7, int)
-#define MEMGETREGIONINFO _IOWR('M', 8, struct region_info_user)
-#define MEMSETOOBSEL _IOW('M', 9, struct nand_oobinfo)
-#define MEMGETOOBSEL _IOR('M', 10, struct nand_oobinfo)
-#define MEMGETBADBLOCK _IOW('M', 11, loff_t)
-#define MEMSETBADBLOCK _IOW('M', 12, loff_t)
-#define OTPSELECT _IOR('M', 13, int)
-#define OTPGETREGIONCOUNT _IOW('M', 14, int)
-#define OTPGETREGIONINFO _IOW('M', 15, struct otp_info)
-#define OTPLOCK _IOR('M', 16, struct otp_info)
-#define ECCGETLAYOUT _IOR('M', 17, struct nand_ecclayout)
-#define ECCGETSTATS _IOR('M', 18, struct mtd_ecc_stats)
-#define MTDFILEMODE _IO('M', 19)
-
-/*
- * Obsolete legacy interface. Keep it in order not to break userspace
- * interfaces
- */
-struct nand_oobinfo {
- uint32_t useecc;
- uint32_t eccbytes;
- uint32_t oobfree[8][2];
- uint32_t eccpos[32];
-};
-
-struct nand_oobfree {
- uint32_t offset;
- uint32_t length;
-};
-
-#define MTD_MAX_OOBFREE_ENTRIES 8
-/*
- * ECC layout control structure. Exported to userspace for
- * diagnosis and to allow creation of raw images
- */
-struct nand_ecclayout {
- uint32_t eccbytes;
- uint32_t eccpos[64];
- uint32_t oobavail;
- struct nand_oobfree oobfree[MTD_MAX_OOBFREE_ENTRIES];
-};
-
-/**
- * struct mtd_ecc_stats - error correction stats
- *
- * @corrected: number of corrected bits
- * @failed: number of uncorrectable errors
- * @badblocks: number of bad blocks in this partition
- * @bbtblocks: number of blocks reserved for bad block tables
- */
-struct mtd_ecc_stats {
- uint32_t corrected;
- uint32_t failed;
- uint32_t badblocks;
- uint32_t bbtblocks;
-};
-
-/*
- * Read/write file modes for access to MTD
- */
-enum mtd_file_modes {
- MTD_MODE_NORMAL = MTD_OTP_OFF,
- MTD_MODE_OTP_FACTORY = MTD_OTP_FACTORY,
- MTD_MODE_OTP_USER = MTD_OTP_USER,
- MTD_MODE_RAW,
-};
-
-#endif /* __MTD_ABI_H__ */
diff --git a/recipes/zaurus-utils/nandlogical/mtd-user.h b/recipes/zaurus-utils/nandlogical/mtd-user.h
deleted file mode 100644
index 713f34d3e6..0000000000
--- a/recipes/zaurus-utils/nandlogical/mtd-user.h
+++ /dev/null
@@ -1,21 +0,0 @@
-/*
- * $Id: mtd-user.h,v 1.2 2004/05/05 14:44:57 dwmw2 Exp $
- *
- * MTD ABI header for use by user space only.
- */
-
-#ifndef __MTD_USER_H__
-#define __MTD_USER_H__
-
-#include <stdint.h>
-
-/* This file is blessed for inclusion by userspace */
-#include <mtd/mtd-abi.h>
-
-typedef struct mtd_info_user mtd_info_t;
-typedef struct erase_info_user erase_info_t;
-typedef struct region_info_user region_info_t;
-typedef struct nand_oobinfo nand_oobinfo_t;
-typedef struct nand_ecclayout nand_ecclayout_t;
-
-#endif /* __MTD_USER_H__ */
diff --git a/recipes/zaurus-utils/nandlogical_1.0.0.bb b/recipes/zaurus-utils/nandlogical_1.0.0.bb
index d567b48a3c..df261540bd 100644
--- a/recipes/zaurus-utils/nandlogical_1.0.0.bb
+++ b/recipes/zaurus-utils/nandlogical_1.0.0.bb
@@ -2,14 +2,14 @@ DESCRIPTION = "Nandlogical for Sharp mtd1"
LICENSE = "GPL"
DEPENDS = "mtd-utils"
COMPATIBLE_MACHINE = "(poodle|c7x0|akita|spitz|tosa)"
-PR = "r2"
+PR = "r3"
SRC_URI = "file://nandlogical.c"
S = "${WORKDIR}"
do_compile () {
- ${CC} nandlogical.c -o nandlogical ${CFLAGS} ${LDFLAGS}
+ ${CC} ${CFLAGS} ${LDFLAGS} nandlogical.c -o nandlogical
}
do_install () {