aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-12-16 17:40:05 -0800
committerKhem Raj <raj.khem@gmail.com>2009-12-16 17:40:05 -0800
commita68775b0728d89f6927ffe623889732862c629cd (patch)
treec99699ea2826de7dc1747dfca35d27b9ccfae9a9
parentda29e9aaa051f40665f818fe5884725047288a2f (diff)
downloadopenembedded-a68775b0728d89f6927ffe623889732862c629cd.tar.gz
linux-libc-headers_2.6.32.bb: New recipe.
* Patch to export sa_family_t to userspace. Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes/linux-libc-headers/linux-libc-headers-2.6.32/export_sa_family_t.patch22
-rw-r--r--recipes/linux-libc-headers/linux-libc-headers_2.6.32.bb1
2 files changed, 23 insertions, 0 deletions
diff --git a/recipes/linux-libc-headers/linux-libc-headers-2.6.32/export_sa_family_t.patch b/recipes/linux-libc-headers/linux-libc-headers-2.6.32/export_sa_family_t.patch
new file mode 100644
index 0000000000..3c8137f2de
--- /dev/null
+++ b/recipes/linux-libc-headers/linux-libc-headers-2.6.32/export_sa_family_t.patch
@@ -0,0 +1,22 @@
+diff --git a/include/linux/socket.h b/include/linux/socket.h
+index 7b3aae2..ade87cf 100644
+--- a/include/linux/socket.h
++++ b/include/linux/socket.h
+@@ -16,6 +16,8 @@ struct __kernel_sockaddr_storage {
+ /* _SS_MAXSIZE value minus size of ss_family */
+ } __attribute__ ((aligned(_K_SS_ALIGNSIZE))); /* force desired alignment */
+
++typedef unsigned short sa_family_t;
++
+ #ifdef __KERNEL__
+
+ #include <asm/socket.h> /* arch-dependent defines */
+@@ -34,8 +36,6 @@ extern void socket_seq_show(struct seq_file *seq);
+ # endif
+ #endif /* __KERNEL__ */
+
+-typedef unsigned short sa_family_t;
+-
+ /*
+ * 1003.1g requires sa_family_t and that sa_data is char.
+ */
diff --git a/recipes/linux-libc-headers/linux-libc-headers_2.6.32.bb b/recipes/linux-libc-headers/linux-libc-headers_2.6.32.bb
index 6e1fdb0996..4b98f055a4 100644
--- a/recipes/linux-libc-headers/linux-libc-headers_2.6.32.bb
+++ b/recipes/linux-libc-headers/linux-libc-headers_2.6.32.bb
@@ -7,6 +7,7 @@ PR = "r0"
DEFAULT_PREFERENCE = "-1"
SRC_URI = "${KERNELORG_MIRROR}/pub/linux/kernel/v2.6/linux-${PV}.tar.bz2 \
+ file://export_sa_family_t.patch;patch=1 \
"
S = "${WORKDIR}/linux-${PV}"