aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorYuri Bushmelev <jay4mail@gmail.com>2009-12-17 00:45:55 +0300
committerYuri Bushmelev <jay4mail@gmail.com>2009-12-17 00:45:55 +0300
commit04fc3f1a63ae26221446b692c7305309dca6d28d (patch)
tree0f138b34d9b2d814ce65d920c8b5051eb2f6f307
parent05019cad32a0ebc0b44a0fbe48c27320417b760d (diff)
parent4e9de808a7cc1f90f33864bdfe06fa9b917ea654 (diff)
downloadopenembedded-04fc3f1a63ae26221446b692c7305309dca6d28d.tar.gz
Merge branch 'jay7-akita' into org.openembedded.dev
-rw-r--r--recipes/qemu/qemu-0.10.3/fix_fortify_source_compilation.patch13
-rw-r--r--recipes/qemu/qemu_0.10.3.bb1
2 files changed, 14 insertions, 0 deletions
diff --git a/recipes/qemu/qemu-0.10.3/fix_fortify_source_compilation.patch b/recipes/qemu/qemu-0.10.3/fix_fortify_source_compilation.patch
new file mode 100644
index 0000000000..326d197167
--- /dev/null
+++ b/recipes/qemu/qemu-0.10.3/fix_fortify_source_compilation.patch
@@ -0,0 +1,13 @@
+--- qemu-0.10.3/block-vvfat.c.orig 2009-05-01 21:02:44 +0400
++++ qemu-0.10.3/block-vvfat.c 2009-12-15 22:06:04 +0300
+@@ -865,7 +865,9 @@
+ {
+ direntry_t* entry=array_get_next(&(s->directory));
+ entry->attributes=0x28; /* archive | volume label */
+- snprintf((char*)entry->name,11,"QEMU VVFAT");
++ /* snprintf((char*)entry->name,11,"QEMU VVFAT"); */
++ snprintf(entry->name, sizeof(entry->name), "QEMU VV");
++ snprintf(entry->extension, sizeof(entry->extension), "FAT");
+ }
+
+ /* Now build FAT, and write back information into directory */
diff --git a/recipes/qemu/qemu_0.10.3.bb b/recipes/qemu/qemu_0.10.3.bb
index f65f60decd..182f4b4407 100644
--- a/recipes/qemu/qemu_0.10.3.bb
+++ b/recipes/qemu/qemu_0.10.3.bb
@@ -22,6 +22,7 @@ SRC_URI = "\
file://fix_segfault.patch;patch=1 \
file://no-strip.patch;patch=1 \
file://fix_baum_c_compilation.patch;patch=1 \
+ file://fix_fortify_source_compilation.patch;patch=1 \
"
S = "${WORKDIR}/qemu-${PV}"