aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid-John Willis <John.Willis@Distant-earth.com>2009-12-11 11:42:14 +0000
committerPhilip Balister <philip@balister.org>2009-12-14 18:28:08 -0500
commitf4837837f7a926b7c2dc60c0aa8bbf3fd8b8aec7 (patch)
treec302ce64926a5f8019eafde3459923e76970502d
parent54e151d8ac503a9e24591d7a306950bdbc0b4e1c (diff)
downloadopenembedded-f4837837f7a926b7c2dc60c0aa8bbf3fd8b8aec7.tar.gz
mesa-xlib: Add 7.4.
-rw-r--r--recipes/mesa/mesa-xlib_7.4.bb20
1 files changed, 20 insertions, 0 deletions
diff --git a/recipes/mesa/mesa-xlib_7.4.bb b/recipes/mesa/mesa-xlib_7.4.bb
new file mode 100644
index 0000000000..1e752dce6f
--- /dev/null
+++ b/recipes/mesa/mesa-xlib_7.4.bb
@@ -0,0 +1,20 @@
+include mesa-common.inc
+
+PROTO_DEPS = "xf86driproto glproto"
+LIB_DEPS = "virtual/libx11 libxext libxxf86vm libxdamage libxfixes"
+
+DEPENDS = "${PROTO_DEPS} ${LIB_DEPS}"
+
+PE = "1"
+PR = "${INC_PR}.0"
+
+EXTRA_OECONF += "--with-driver=xlib"
+
+PACKAGES =+ "${PN}-xprogs"
+
+FILES_${PN}-xprogs = "${bindir}/glxdemo ${bindir}/glxgears ${bindir}/glxheads ${bindir}/glxinfo"
+
+do_install_append () {
+ install -d ${D}/${bindir}
+ install -m 0755 ${S}/progs/xdemos/{glxdemo,glxgears,glxheads,glxinfo} ${D}/${bindir}
+}