aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-12-16 17:37:55 -0800
committerKhem Raj <raj.khem@gmail.com>2009-12-16 17:37:55 -0800
commitda29e9aaa051f40665f818fe5884725047288a2f (patch)
tree33899d4a1f19eb2a61551f5432b26efd35767362
parent877f8c19536f671454e246f766bb7ac328fd4816 (diff)
downloadopenembedded-da29e9aaa051f40665f818fe5884725047288a2f.tar.gz
iptables_1.4.6.bb: Recipe for version 1.4.6.
* Switch to INC_PR. * inherit autotools Signed-off-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--conf/checksums.ini4
-rw-r--r--recipes/iptables/iptables-1.4.6/netfilter_remove_ipt_DSCP.patch28
-rw-r--r--recipes/iptables/iptables.inc19
-rw-r--r--recipes/iptables/iptables_1.3.8.bb2
-rw-r--r--recipes/iptables/iptables_1.4.6.bb6
5 files changed, 50 insertions, 9 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 1f76481579..cf43c35f77 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -12798,6 +12798,10 @@ sha256=84ac04a28ae41e17df0f181d8bc0049ae7a83baae07296e890ea5977a2952318
md5=0a9209f928002e5eee9cdff8fef4d4b3
sha256=c5c8a091ed9a1fa2dab86b4d87719064b50c202e8503046f50f299a361e6211c
+[http://netfilter.org/projects/iptables/files/iptables-1.4.6.tar.bz2]
+md5=c67cf30e281a924def6426be0973df56
+sha256=6e732798cad62163d6e033aa52e22b771246556a230c0f66cd33fe69e96d72a4
+
[ftp://ftp.debian.org/debian/pool/main/i/iptraf/iptraf_3.0.0-6.diff.gz]
md5=fe0e2944addbd5803b42e91f7e4ec5d7
sha256=5803c3f3653887896b75567daf617a8f200cecdd28beb870219b3954d9931efa
diff --git a/recipes/iptables/iptables-1.4.6/netfilter_remove_ipt_DSCP.patch b/recipes/iptables/iptables-1.4.6/netfilter_remove_ipt_DSCP.patch
new file mode 100644
index 0000000000..b833237c16
--- /dev/null
+++ b/recipes/iptables/iptables-1.4.6/netfilter_remove_ipt_DSCP.patch
@@ -0,0 +1,28 @@
+Index: iptables-1.4.6/include/linux/netfilter_ipv4/ipt_ECN.h
+===================================================================
+--- iptables-1.4.6.orig/include/linux/netfilter_ipv4/ipt_ECN.h 2009-12-15 22:05:04.713075521 -0800
++++ iptables-1.4.6/include/linux/netfilter_ipv4/ipt_ECN.h 2009-12-15 22:08:43.875470318 -0800
+@@ -8,9 +8,6 @@
+ */
+ #ifndef _IPT_ECN_TARGET_H
+ #define _IPT_ECN_TARGET_H
+-#include <linux/netfilter_ipv4/ipt_DSCP.h>
+-
+-#define IPT_ECN_IP_MASK (~IPT_DSCP_MASK)
+
+ #define IPT_ECN_OP_SET_IP 0x01 /* set ECN bits of IPv4 header */
+ #define IPT_ECN_OP_SET_ECE 0x10 /* set ECE bit of TCP header */
+Index: iptables-1.4.6/include/linux/netfilter_ipv4/ipt_ecn.h
+===================================================================
+--- iptables-1.4.6.orig/include/linux/netfilter_ipv4/ipt_ecn.h 2009-12-15 22:09:44.415445160 -0800
++++ iptables-1.4.6/include/linux/netfilter_ipv4/ipt_ecn.h 2009-12-15 22:09:58.523715835 -0800
+@@ -8,9 +8,6 @@
+ */
+ #ifndef _IPT_ECN_H
+ #define _IPT_ECN_H
+-#include <linux/netfilter_ipv4/ipt_dscp.h>
+-
+-#define IPT_ECN_IP_MASK (~IPT_DSCP_MASK)
+
+ #define IPT_ECN_OP_MATCH_IP 0x01
+ #define IPT_ECN_OP_MATCH_ECE 0x10
diff --git a/recipes/iptables/iptables.inc b/recipes/iptables/iptables.inc
index 4868abb8ee..fd16f97b0a 100644
--- a/recipes/iptables/iptables.inc
+++ b/recipes/iptables/iptables.inc
@@ -6,24 +6,27 @@ LICENSE = "GPL"
SRC_URI = "http://netfilter.org/projects/iptables/files/iptables-${PV}.tar.bz2"
S = "${WORKDIR}/iptables-${PV}"
+INC_PR = "r5"
+
PARALLEL_MAKE = ""
export COPT_FLAGS = "${CFLAGS}"
export KERNEL_DIR = "${STAGING_INCDIR}"
-do_compile () {
- unset CFLAGS
- oe_runmake BINDIR=${D}${sbindir} LIBDIR=${D}${libdir} MANDIR=${D}${mandir} NO_SHARED_LIBS=1
-}
+inherit autotools
+
+#do_compile () {
+# oe_runmake DESTDIR=${D} NO_SHARED_LIBS=1
+#}
-do_install () {
- unset CFLAGS
- oe_runmake BINDIR=${D}${sbindir} LIBDIR=${D}${libdir} MANDIR=${D}${mandir} install NO_SHARED_LIBS=1
-}
+#do_install () {
+# oe_runmake DESTDIR=${D} install NO_SHARED_LIBS=1
+#}
PACKAGES =+ "${PN}-utils"
FILES_${PN}-utils = "${sbindir}/iptables-save ${sbindir}/iptables-restore"
FILES_${PN}-doc += "${mandir}"
+FILES_${PN}-dbg += "${libexecdir}/xtables"
RRECOMMENDS = "\
kernel-module-ip-tables \
diff --git a/recipes/iptables/iptables_1.3.8.bb b/recipes/iptables/iptables_1.3.8.bb
index 520e33624d..47c5564997 100644
--- a/recipes/iptables/iptables_1.3.8.bb
+++ b/recipes/iptables/iptables_1.3.8.bb
@@ -1,5 +1,5 @@
require iptables.inc
-PR = "r5"
+PR = "${INC_PR}.0"
SRC_URI += "\
file://getsockopt-failed.patch;patch=1 \
diff --git a/recipes/iptables/iptables_1.4.6.bb b/recipes/iptables/iptables_1.4.6.bb
new file mode 100644
index 0000000000..433114ef87
--- /dev/null
+++ b/recipes/iptables/iptables_1.4.6.bb
@@ -0,0 +1,6 @@
+require iptables.inc
+PR = "${INC_PR}.0"
+
+SRC_URI += "\
+ file://netfilter_remove_ipt_DSCP.patch;patch=1 \
+ "