aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMartin Jansa <Martin.Jansa@gmail.com>2010-01-15 10:32:34 +0100
committerMartin Jansa <Martin.Jansa@gmail.com>2010-01-15 10:32:34 +0100
commit7355a373626eb5baed742e990276dac6fae3d943 (patch)
tree9959f64b1c282a4341b221d26cc399d815598c2c
parent453e4b7331944b780ba02446fb882f1c41cd062c (diff)
parenteb0805d926c8cf4c1f48d21ee9402786c3209df9 (diff)
downloadopenembedded-7355a373626eb5baed742e990276dac6fae3d943.tar.gz
Merge branch 'org.openembedded.dev' of git.openembedded.org:openembedded into martin_jansa/srcpv
-rw-r--r--recipes/fltk/efltk/fix.void.cast.patch15
-rw-r--r--recipes/tasks/task-shr-feed.bb2
2 files changed, 16 insertions, 1 deletions
diff --git a/recipes/fltk/efltk/fix.void.cast.patch b/recipes/fltk/efltk/fix.void.cast.patch
new file mode 100644
index 0000000000..d66c77f867
--- /dev/null
+++ b/recipes/fltk/efltk/fix.void.cast.patch
@@ -0,0 +1,15 @@
+From:
+http://sourceforge.net/projects/ede/forums/forum/249614/topic/3458921
+
+diff -uNr efltk.orig/src/core/filename_list.cpp efltk/src/core/filename_list.cpp
+--- efltk.orig/src/core/filename_list.cpp 2007-11-16 14:17:51.000000000 +0100
++++ efltk/src/core/filename_list.cpp 2010-01-15 01:03:59.000000000 +0100
+@@ -59,7 +59,7 @@
+ // The vast majority of Unix systems want the sort function to have this
+ // prototype, most likely so that it can be passed to qsort without any
+ // changes:
+- return scandir(dir, list, 0, (int(*)(const void*,const void*))sort);
++ return scandir(dir, list, 0, (int(*)(const dirent **,const dirent **))sort);
+ #else
+ // This version is when we define our own scandir (WIN32 and perhaps
+ // some Unix systems) and apparently on Irix:
diff --git a/recipes/tasks/task-shr-feed.bb b/recipes/tasks/task-shr-feed.bb
index 89d034bdb3..54789ac489 100644
--- a/recipes/tasks/task-shr-feed.bb
+++ b/recipes/tasks/task-shr-feed.bb
@@ -104,7 +104,7 @@ RDEPENDS_${PN} += "\
libpurple-protocol-icq \
vagalume \
ppp \
-# bluez-hcidump \
+ bluez-hcidump \
kbdd \
kexec-tools \
mc \