aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Zimmermann <zimmermann@vdm-design.de>2009-10-08 09:00:22 +0000
committerKlaus Kurzmann <mok@fluxnetz.de>2009-10-09 11:46:00 +0200
commitc115412f1b40dfbfeda453832df0f777ab234859 (patch)
treecd73ec9b15ce31bd059115acb14a9db514131346
parent399ca5b31b6d9de3653b4056f44fcd260c836314 (diff)
downloadopenembedded-c115412f1b40dfbfeda453832df0f777ab234859.tar.gz
xserver-xorg: Add patch to rotate touchscreen together with screen (thx to daniels from #xorg-devel)
Signed-off-by: Klaus Kurzmann <mok@fluxnetz.de>
-rw-r--r--recipes/xorg-xserver/xserver-xorg-1.7.0/randr-support-1.7.0.patch96
-rw-r--r--recipes/xorg-xserver/xserver-xorg_1.7.0.bb3
2 files changed, 98 insertions, 1 deletions
diff --git a/recipes/xorg-xserver/xserver-xorg-1.7.0/randr-support-1.7.0.patch b/recipes/xorg-xserver/xserver-xorg-1.7.0/randr-support-1.7.0.patch
new file mode 100644
index 0000000000..fb8d3815be
--- /dev/null
+++ b/recipes/xorg-xserver/xserver-xorg-1.7.0/randr-support-1.7.0.patch
@@ -0,0 +1,96 @@
+diff -Nur xorg-server-1.7.0.orig/hw/xfree86/common/xf86Xinput.c xorg-server-1.7.0/hw/xfree86/common/xf86Xinput.c
+--- xorg-server-1.7.0.orig/hw/xfree86/common/xf86Xinput.c 2009-09-24 07:12:00.000000000 +0200
++++ xorg-server-1.7.0/hw/xfree86/common/xf86Xinput.c 2009-10-08 11:45:50.000000000 +0200
+@@ -95,6 +95,8 @@
+
+ #include "os.h"
+
++#define RR_Rotate_All (RR_Rotate_0|RR_Rotate_90|RR_Rotate_180|RR_Rotate_270)
++
+ EventListPtr xf86Events = NULL;
+
+ /**
+@@ -1086,4 +1088,67 @@
+ EnableDevice(dev, TRUE);
+ }
+
++/* Taken from evdev-properties.h. */
++#define EVDEV_PROP_SWAP_AXES "Evdev Axes Swap"
++#define EVDEV_PROP_INVERT_AXES "Evdev Axis Inversion"
++
++/* This is a hack until we get device -> CRTC association. */
++void
++xf86InputRotationNotify(Rotation rotation)
++{
++ DeviceIntPtr dev;
++ LocalDevicePtr local;
++ int ret;
++ int swap_axes = 0;
++ CARD8 invert[2] = { 0, 0 };
++ static Atom prop_swap = 0, prop_invert = 0;
++ static int atom_generation = -1;
++
++ if (atom_generation != serverGeneration) {
++ prop_swap = 0;
++ prop_invert = 0;
++ }
++
++ switch (rotation & RR_Rotate_All) {
++ case RR_Rotate_0:
++ break;
++ case RR_Rotate_90:
++ swap_axes = 1;
++ invert[0] = 1;
++ break;
++ case RR_Rotate_180:
++ invert[0] = 1;
++ invert[1] = 1;
++ break;
++ case RR_Rotate_270:
++ swap_axes = 1;
++ invert[1] = 1;
++ break;
++ }
++
++ if (!prop_swap)
++ prop_swap = MakeAtom(EVDEV_PROP_SWAP_AXES,
++ strlen(EVDEV_PROP_SWAP_AXES), TRUE);
++ if (!prop_invert)
++ prop_invert = MakeAtom(EVDEV_PROP_INVERT_AXES,
++ strlen(EVDEV_PROP_INVERT_AXES), TRUE);
++
++ for (dev = inputInfo.devices; dev; dev = dev->next) {
++ local = dev->public.devicePrivate;
++ ret = XIChangeDeviceProperty(dev, prop_swap, XA_INTEGER, 8,
++ PropModeReplace, 1, &swap_axes, FALSE);
++ if (ret != Success) {
++ xf86Msg(X_ERROR, "Changing swap_xy property failed!\n");
++ continue;
++ }
++ ret = XIChangeDeviceProperty(dev, prop_invert, XA_INTEGER, 8,
++ PropModeReplace, 2, invert, FALSE);
++ if (ret != Success) {
++ xf86Msg(X_ERROR, "Changing invert property failed!\n");
++ continue;
++ }
++ }
++}
++
++
+ /* end of xf86Xinput.c */
+diff -Nur xorg-server-1.7.0.orig/hw/xfree86/modes/xf86Crtc.c xorg-server-1.7.0/hw/xfree86/modes/xf86Crtc.c
+--- xorg-server-1.7.0.orig/hw/xfree86/modes/xf86Crtc.c 2009-10-01 08:27:36.000000000 +0200
++++ xorg-server-1.7.0/hw/xfree86/modes/xf86Crtc.c 2009-10-08 11:28:42.000000000 +0200
+@@ -391,6 +391,12 @@
+ if (didLock)
+ crtc->funcs->unlock (crtc);
+
++ /*
++ * Rotate Touchscreen
++ */
++ xf86InputRotationNotify(crtc->rotation);
++
++
+ return ret;
+ }
+
diff --git a/recipes/xorg-xserver/xserver-xorg_1.7.0.bb b/recipes/xorg-xserver/xserver-xorg_1.7.0.bb
index 3ad989f1b5..58b3614535 100644
--- a/recipes/xorg-xserver/xserver-xorg_1.7.0.bb
+++ b/recipes/xorg-xserver/xserver-xorg_1.7.0.bb
@@ -3,10 +3,11 @@ require xorg-xserver-common.inc
DESCRIPTION = "the X.Org X server"
DEPENDS += "pixman libpciaccess openssl dri2proto glproto mesa xorg-minimal-fonts"
PE = "2"
-PR = "r0"
+PR = "r1"
SRC_URI += "file://sysroot_fix.patch;patch=1 \
file://dolt-fix.patch;patch=1 \
+ file://randr-support-1.7.0.patch;patch=1 \
"
do_install_prepend() {
mkdir -p ${D}/${libdir}/X11/fonts