aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Zimmermann <zimmermann@vdm-design.de>2009-10-22 13:13:34 +0000
committerKlaus Kurzmann <mok@fluxnetz.de>2009-10-22 16:17:16 +0200
commit07fce6b0d6fb1f3546b5173455894c0bbac732bf (patch)
treed219780b35ff28ae9b8e195105d29b15ea20c841
parentfd99d70a19e327b40329c942616f19e04567afd9 (diff)
downloadopenembedded-07fce6b0d6fb1f3546b5173455894c0bbac732bf.tar.gz
openbox: update recipe and add obconf
Signed-off-by: Klaus Kurzmann <mok@fluxnetz.de>
-rw-r--r--recipes/openbox/files/client.c.patch47
-rw-r--r--recipes/openbox/files/prompt.c.patch24
-rw-r--r--recipes/openbox/obconf_2.0.3.bb12
-rw-r--r--recipes/openbox/openbox_3.4.7.2.bb13
4 files changed, 95 insertions, 1 deletions
diff --git a/recipes/openbox/files/client.c.patch b/recipes/openbox/files/client.c.patch
new file mode 100644
index 0000000000..39150ddd67
--- /dev/null
+++ b/recipes/openbox/files/client.c.patch
@@ -0,0 +1,47 @@
+--- openbox-3.4.7.2/openbox/client.c~ 2009-10-22 14:12:16.000000000 +0200
++++ openbox-3.4.7.2/openbox/client.c 2009-10-22 14:12:16.000000000 +0200
+@@ -1205,6 +1205,11 @@
+ ret = XGetWindowAttributes(ob_display, self->window, &wattrib);
+ g_assert(ret != BadWindow);
+
++ /* matz changed */
++ wattrib.width = 480;
++ wattrib.height = 640;
++ /* end matz changed */
++
+ RECT_SET(self->area, wattrib.x, wattrib.y, wattrib.width, wattrib.height);
+ POINT_SET(self->root_pos, wattrib.x, wattrib.y);
+ self->border_width = wattrib.border_width;
+@@ -1630,9 +1635,9 @@
+ self->min_ratio = 0.0f;
+ self->max_ratio = 0.0f;
+ SIZE_SET(self->size_inc, 1, 1);
+- SIZE_SET(self->base_size, -1, -1);
+- SIZE_SET(self->min_size, 0, 0);
+- SIZE_SET(self->max_size, G_MAXINT, G_MAXINT);
++ SIZE_SET(self->base_size, 480, 590);
++ SIZE_SET(self->min_size, 480, 550);
++ SIZE_SET(self->max_size, 480, 640);
+
+ /* get the hints from the window */
+ if (XGetWMNormalHints(ob_display, self->window, &size, &ret)) {
+@@ -1655,13 +1660,16 @@
+ }
+
+ if (size.flags & PMinSize)
+- SIZE_SET(self->min_size, size.min_width, size.min_height);
++ /* SIZE_SET(self->min_size, size.min_width, size.min_height); */
++ SIZE_SET(self->min_size, 480, 550);
+
+ if (size.flags & PMaxSize)
+- SIZE_SET(self->max_size, size.max_width, size.max_height);
++ /* SIZE_SET(self->max_size, size.max_width, size.max_height); */
++ SIZE_SET(self->max_size, 480, 640);
+
+ if (size.flags & PBaseSize)
+- SIZE_SET(self->base_size, size.base_width, size.base_height);
++ /* SIZE_SET(self->base_size, size.base_width, size.base_height); */
++ SIZE_SET(self->base_size, 480, 550);
+
+ if (size.flags & PResizeInc && size.width_inc && size.height_inc)
+ SIZE_SET(self->size_inc, size.width_inc, size.height_inc);
diff --git a/recipes/openbox/files/prompt.c.patch b/recipes/openbox/files/prompt.c.patch
new file mode 100644
index 0000000000..212943441c
--- /dev/null
+++ b/recipes/openbox/files/prompt.c.patch
@@ -0,0 +1,24 @@
+--- openbox-3.4.7.2/openbox/prompt.c~ 2009-10-22 14:14:34.000000000 +0200
++++ openbox-3.4.7.2/openbox/prompt.c 2009-10-22 14:14:34.000000000 +0200
+@@ -348,8 +348,8 @@
+
+ /* the user can't resize the prompt */
+ hints.flags = PMinSize | PMaxSize;
+- hints.min_width = hints.max_width = w;
+- hints.min_height = hints.max_height = h;
++ hints.min_width = hints.max_width = w = 480;
++ hints.min_height = hints.max_height = h = 640;
+ XSetWMNormalHints(ob_display, self->super.window, &hints);
+
+ if (self->mapped) {
+@@ -358,8 +358,8 @@
+ req.display = ob_display;
+ req.parent = RootWindow(ob_display, ob_screen);
+ req.window = self->super.window;
+- req.width = w;
+- req.height = h;
++ req.width = w = 480;
++ req.height = h = 640;
+ req.value_mask = CWWidth | CWHeight;
+ XSendEvent(req.display, req.window, FALSE, StructureNotifyMask,
+ (XEvent*)&req);
diff --git a/recipes/openbox/obconf_2.0.3.bb b/recipes/openbox/obconf_2.0.3.bb
new file mode 100644
index 0000000000..42906c776d
--- /dev/null
+++ b/recipes/openbox/obconf_2.0.3.bb
@@ -0,0 +1,12 @@
+DESCRIPTION = "openbox configuration program"
+AUTHOR = "icculus.org/openbox"
+HOMEPAGE_URL="http://icculus.org/openbox/index.php/ObConf:About"
+
+PR = "r0"
+
+DEPENDS = "openbox gtk+ libglade"
+RDEPENDS = "openbox gtk+"
+SRC_URI = "http://icculus.org/openbox/${PN}/${PN}-${PV}.tar.gz"
+S = "${WORKDIR}/${PN}-${PV}"
+
+inherit pkgconfig autotools \ No newline at end of file
diff --git a/recipes/openbox/openbox_3.4.7.2.bb b/recipes/openbox/openbox_3.4.7.2.bb
index 2b15861e80..b4df114775 100644
--- a/recipes/openbox/openbox_3.4.7.2.bb
+++ b/recipes/openbox/openbox_3.4.7.2.bb
@@ -1,9 +1,16 @@
DESCRIPTION = "openbox Window Manager"
SECTION = "x11/wm"
-DEPENDS = ""
+DEPENDS = "glib-2.0 libxml2 pango"
+RDEPENDS = "libxml2 pango"
+RRECOMMENDS = "startup-notification libxcursor "
+
+PR = "r1"
SRC_URI = "http://icculus.org/openbox/releases/openbox-${PV}.tar.gz"
+SRC_URI_append_om-gta02 += "file://client.c.patch;patch=1 \
+ file://prompt.c.patch;patch=1 "
+S = "${WORKDIR}/${PN}-${PV}"
inherit autotools update-alternatives
EXTRA_OECONF += "--with-plugins=none"
@@ -24,3 +31,7 @@ ALTERNATIVE_PATH = "${bindir}/openbox"
ALTERNATIVE_NAME = "x-window-manager"
ALTERNATIVE_LINK = "${bindir}/x-window-manager"
ALTERNATIVE_PRIORITY = "10"
+
+do_stage() {
+ autotools_stage_all
+}