aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGraeme Gregory <gg@slimlogic.co.uk>2009-12-09 17:09:52 -0700
committerGraeme Gregory <dp@xora.org.uk>2009-12-10 00:12:59 +0000
commitcbca434e98e6a29f3676f109601b033aa8412aa9 (patch)
tree6ae65e178229187aad922170d0fd2129c5647a52
parentef7b6b4d61dd6dd16e26dd8f77712c9c6816c718 (diff)
downloadopenembedded-cbca434e98e6a29f3676f109601b033aa8412aa9.tar.gz
php_5.2.11.bb : add latest version of php 5.2 series.
Re-enabled pcntl as it seems to be compiling, removed string.c patch as that seemed to be no longer required and rehashed other patches for the new version.
-rw-r--r--conf/checksums.ini4
-rw-r--r--recipes/php/php-5.2.11/acinclude-xml2-config.patch18
-rw-r--r--recipes/php/php-5.2.11/pear-makefile.patch13
-rw-r--r--recipes/php/php_5.2.11.bb86
4 files changed, 121 insertions, 0 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 8d6c6f5aa9..1cd45c9d1b 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -21490,6 +21490,10 @@ sha256=3e9510ce715f28b7e6b803fcdadb73b37c83792c0b5e1e9bcb066ab972649996
md5=e6029fafcee029edcfa2ceed7a005333
sha256=e105b6aad55589aecf20ae70ab7aa81eb202296fc52531f62e546af23077cca1
+[http://us2.php.net/distributions/php-5.2.11.tar.bz2]
+md5=286bf34630f5643c25ebcedfec5e0a09
+sha256=9bcd14ceda2b4bd7abcc7eb59bd74bae490d9335e4207580de783b48aa7e8f23
+
[http://us2.php.net/distributions/php-5.2.5.tar.bz2]
md5=1fe14ca892460b09f06729941a1bb605
sha256=5cac1e70df5019ebdfdab2e0b8b216f7fdf56b9895c9f68c993313918249bba3
diff --git a/recipes/php/php-5.2.11/acinclude-xml2-config.patch b/recipes/php/php-5.2.11/acinclude-xml2-config.patch
new file mode 100644
index 0000000000..bf519d2934
--- /dev/null
+++ b/recipes/php/php-5.2.11/acinclude-xml2-config.patch
@@ -0,0 +1,18 @@
+--- /orig-acinclude.m4 2007-02-20 15:03:25.000000000 +0200
++++ /acinclude.m4 2007-02-20 15:03:24.000000000 +0200
+@@ -2359,12 +2359,9 @@
+ AC_DEFUN([PHP_SETUP_LIBXML], [
+ AC_CACHE_CHECK([for xml2-config path], ac_cv_php_xml2_config_path,
+ [
+- for i in $PHP_LIBXML_DIR /usr/local /usr; do
+- if test -x "$i/bin/xml2-config"; then
+- ac_cv_php_xml2_config_path="$i/bin/xml2-config"
+- break
+- fi
+- done
++
++ ac_cv_php_xml2_config_path="$PHP_LIBXML_DIR/xml2-config"
++
+ ])
+
+ if test -x "$ac_cv_php_xml2_config_path"; then
diff --git a/recipes/php/php-5.2.11/pear-makefile.patch b/recipes/php/php-5.2.11/pear-makefile.patch
new file mode 100644
index 0000000000..487f507a02
--- /dev/null
+++ b/recipes/php/php-5.2.11/pear-makefile.patch
@@ -0,0 +1,13 @@
+Index: php-5.2.11/pear/Makefile.frag
+===================================================================
+--- php-5.2.11.orig/pear/Makefile.frag 2009-08-02 13:11:15.000000000 -0600
++++ php-5.2.11/pear/Makefile.frag 2009-12-09 16:13:38.700972014 -0700
+@@ -11,7 +11,7 @@
+ PEAR_SUFFIX = -ds a$(program_suffix)
+
+ install-pear-installer: $(SAPI_CLI_PATH)
+- @$(top_builddir)/sapi/cli/php $(PEAR_INSTALL_FLAGS) pear/install-pear-nozlib.phar -d "$(peardir)" -b "$(bindir)" ${PEAR_PREFIX} ${PEAR_SUFFIX}
++ @$(PHP_NATIVE_DIR)/php $(PEAR_INSTALL_FLAGS) pear/install-pear-nozlib.phar -d "$(peardir)" -b "$(bindir)" ${PEAR_PREFIX} ${PEAR_SUFFIX}
+
+ install-pear:
+ @echo "Installing PEAR environment: $(INSTALL_ROOT)$(peardir)/"
diff --git a/recipes/php/php_5.2.11.bb b/recipes/php/php_5.2.11.bb
new file mode 100644
index 0000000000..06a9fe2668
--- /dev/null
+++ b/recipes/php/php_5.2.11.bb
@@ -0,0 +1,86 @@
+require php.inc
+
+DEPENDS = "zlib libxml2 virtual/libiconv php-native lemon-native mysql"
+
+PR = "r0"
+
+SRC_URI += "file://pear-makefile.patch;patch=1 \
+ "
+export THREADS="pthread"
+export LIBS=" -lpthread "
+
+EXTRA_OECONF = " --without-iconv \
+ --enable-discard-path \
+ --enable-sockets \
+ --enable-shared \
+ --enable-pcntl \
+ --enable-memory-limit \
+ --enable-wddx \
+ --enable-embedded-mysqli \
+ --enable-magic-quotes \
+ --enable-fastcgi \
+ --with-zlib --with-zlib-dir=${STAGING_LIBDIR}/.. \
+ --with-libxml-dir=${STAGING_BINDIR_CROSS} \
+ --with-mysql="${STAGING_DIR_TARGET}${layout_exec_prefix}" \
+# --with-mysqli = "${STAGING_BINDIR_NATIVE}/mysql_config" \
+ --without-pdo-sqlite \
+ "
+
+export LD_LIBRARY_PATH = "${STAGING_LIBDIR}"
+export PHP_NATIVE_DIR = "${STAGING_BINDIR_NATIVE}"
+export PHP_PEAR_PHP_BIN = "${bindir}/php"
+
+do_configure_append() {
+ find ${S} -type f | xargs sed -i 's:I/usr/include:I${STAGING_INCDIR}:g'
+}
+
+# fixme
+do_install_append() {
+ mv ${D}/${STAGING_DIR_NATIVE}/${sysconfdir} ${D}/${sysconfdir}
+ rm -rf ${D}/${STAGING_DIR_NATIVE}
+ rm -rf ${D}/.registry
+ rm -rf ${D}/.channels
+ rm -rf ${D}/.[a-z]*
+}
+
+PACKAGES = "${PN}-dbg \
+ ${PN}-cli \
+ ${PN}-cgi \
+ ${PN}-pear \
+ ${PN}-dev \
+ ${PN}-doc \
+ ${PN} \
+"
+
+
+FILES_${PN}-dbg =+ "${bindir}/.debug"
+
+FILES_${PN}-doc += "${libdir}/php/doc"
+
+FILES_${PN}-cli = "${bindir}/php"
+FILES_${PN}-cgi = "${bindir}/php-cgi"
+
+FILES_${PN}-pear = "${bindir}/pear* ${bindir}/pecl \
+ ${libdir}/php/PEAR \
+ ${libdir}/php/PEAR.php \
+ ${libdir}/php/System.php ${libdir}php/peclcmd.php ${libdir}/php/pearcmd.php \
+ ${libdir}/php/.channels ${libdir}/php/.channels/.alias \
+ ${libdir}/php/.channels\__uri.reg \
+ ${libdir}/php/.channels\pear.php.net.reg ${libdir}/php/.channels/pecl.php.net.reg \
+ ${libdir}/php/.registry \
+ ${libdir}/php/Archive/Tar.php \
+ ${libdir}/php/Console/Getopt.php ${libdir}/php/OS/Guess.php \
+ ${sysconfdir}/pear.conf"
+
+
+FILES_${PN}-dev = "${includedir}/php ${libdir}/build \
+ ${bindir}/phpize ${bindir}/php-config \
+ ${libdir}/php/.depdb ${libdir}/php/.depdblock ${libdir}/php/.filemap ${libdir}/php/.lock \
+ ${libdir}/php/test "
+
+FILES_${PN} = "${libdir}/php"
+FILES_${PN} += "${bindir}"
+
+RDEPENDS_${PN}-pear = ${PN}
+RDEPENDS_${PN}-cli = ${PN}
+RDEPENDS_${PN}-dev = ${PN}