aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2008-11-12 11:15:52 +0000
committerGraeme Gregory <dp@xora.org.uk>2008-11-12 15:23:08 +0000
commitd876de8271a798310cd226c5c2db81843fbf2c8a (patch)
tree1cf5bae6345c6c47a5e2c0e7e77287490883ccf7
parente2f7722a89a2fa001e3fc04322f3d37ed045a79b (diff)
downloadopenembedded-d876de8271a798310cd226c5c2db81843fbf2c8a.tar.gz
xserver-xorg-conf_0.1.bb : split the xorg.conf out of xserver-xorg
package to prevent xserver-xorg becoming a machine package.
-rw-r--r--packages/xorg-xserver/xorg-xserver-common.inc9
-rw-r--r--packages/xorg-xserver/xserver-xorg-conf/omap3evm/xorg.conf (renamed from packages/xorg-xserver/xserver-xorg/omap3evm/xorg.conf)0
-rw-r--r--packages/xorg-xserver/xserver-xorg-conf/xorg.conf0
-rw-r--r--packages/xorg-xserver/xserver-xorg-conf_0.1.bb11
-rw-r--r--packages/xorg-xserver/xserver-xorg/xorg.conf135
5 files changed, 13 insertions, 142 deletions
diff --git a/packages/xorg-xserver/xorg-xserver-common.inc b/packages/xorg-xserver/xorg-xserver-common.inc
index 84e3c30978..d391ffe60b 100644
--- a/packages/xorg-xserver/xorg-xserver-common.inc
+++ b/packages/xorg-xserver/xorg-xserver-common.inc
@@ -16,8 +16,7 @@ libxkbui libxxf86misc libxi libdmx libxtst libxres mesa libxcalibrate"
RECOMMENDS_${PN} = "hal"
XORG_PN = "xorg-server"
-SRC_URI = "${XORG_MIRROR}/individual/xserver/${XORG_PN}-${PV}.tar.bz2 \
- file://xorg.conf"
+SRC_URI = "${XORG_MIRROR}/individual/xserver/${XORG_PN}-${PV}.tar.bz2"
S = "${WORKDIR}/${XORG_PN}-${PV}"
@@ -30,7 +29,7 @@ EXTRA_OECONF_append_arm = " ac_cv_header_linux_apm_bios_h=no "
PACKAGES =+ "xserver-security-policy"
FILES_xserver-security-policy += "${libdir}/xserver/SecurityPolicy"
-RRECOMMENDS_${PN} += "xserver-security-policy xkeyboard-config xorg-minimal-fonts rgb"
+RRECOMMENDS_${PN} += "xserver-security-policy xkeyboard-config xorg-minimal-fonts rgb xserver-xorg-conf"
PACKAGES =+ "${PN}-xprint ${PN}-xvfb ${PN}-utils"
@@ -45,14 +44,10 @@ FILES_${PN}-dbg += "${libdir}/xorg/modules/.debug \
${libdir}/xorg/modules/*/*/.debug \
"
-CONFFILES_${PN} += "${sysconfdir}/X11/xorg.conf"
-
do_stage() {
autotools_stage_all
}
do_install_append () {
- install -d ${D}/${sysconfdir}/X11
- install -m 0644 ${WORKDIR}/xorg.conf ${D}/${sysconfdir}/X11/
ln -sf ${datadir}/fonts/X11 ${D}/${libdir}/X11/fonts
}
diff --git a/packages/xorg-xserver/xserver-xorg/omap3evm/xorg.conf b/packages/xorg-xserver/xserver-xorg-conf/omap3evm/xorg.conf
index 983bb0823a..983bb0823a 100644
--- a/packages/xorg-xserver/xserver-xorg/omap3evm/xorg.conf
+++ b/packages/xorg-xserver/xserver-xorg-conf/omap3evm/xorg.conf
diff --git a/packages/xorg-xserver/xserver-xorg-conf/xorg.conf b/packages/xorg-xserver/xserver-xorg-conf/xorg.conf
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/xorg-xserver/xserver-xorg-conf/xorg.conf
diff --git a/packages/xorg-xserver/xserver-xorg-conf_0.1.bb b/packages/xorg-xserver/xserver-xorg-conf_0.1.bb
new file mode 100644
index 0000000000..1ff83ea27b
--- /dev/null
+++ b/packages/xorg-xserver/xserver-xorg-conf_0.1.bb
@@ -0,0 +1,11 @@
+DESCRIPTION = "Machine specific xorg.conf files"
+
+SRC_URI = "file://xorg.conf"
+
+do_install() {
+ install -d ${D}/${sysconfdir}/X11
+ install -m 0644 ${WORKDIR}/xorg.conf ${D}/${sysconfdir}/X11/
+}
+
+CONFFILES_${PN} += "${sysconfdir}/X11/xorg.conf"
+
diff --git a/packages/xorg-xserver/xserver-xorg/xorg.conf b/packages/xorg-xserver/xserver-xorg/xorg.conf
deleted file mode 100644
index 4b327022f6..0000000000
--- a/packages/xorg-xserver/xserver-xorg/xorg.conf
+++ /dev/null
@@ -1,135 +0,0 @@
-
-# xorg configuration
-
-Section "ServerLayout"
- Identifier "Default Layout"
- Screen 0 "Screen0" 0 0
- InputDevice "Mouse0" "CorePointer"
- InputDevice "Keyboard0" "CoreKeyboard"
-EndSection
-
-Section "Files"
-
-# RgbPath is the location of the RGB database. Note, this is the name of the
-# file minus the extension (like ".txt" or ".db"). There is normally
-# no need to change the default.
-# Multiple FontPath entries are allowed (they are concatenated together)
-# By default, Red Hat 6.0 and later now use a font server independent of
-# the X server to render fonts.
-# FontPath "unix/:7100"
- FontPath "/usr/lib/X11/fonts/misc"
-EndSection
-
-Section "Module"
- Load "dbe"
- Load "extmod"
- Load "fbdevhw"
-# Load "glx"
- Load "record"
- Load "freetype"
- Load "type1"
-# to enable Xv, link /dev/videox to video device, eg. ln -s video0 /dev/videox
-# Load "z4l"
-EndSection
-
-Section "InputDevice"
-
-# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
-# Option "Xleds" "1 2 3"
-# To disable the XKEYBOARD extension, uncomment XkbDisable.
-# Option "XkbDisable"
-# To customise the XKB settings to suit your keyboard, modify the
-# lines below (which are the defaults). For example, for a non-U.S.
-# keyboard, you will probably want to use:
-# Option "XkbModel" "pc102"
-# If you have a US Microsoft Natural keyboard, you can use:
-# Option "XkbModel" "microsoft"
-#
-# Then to change the language, change the Layout setting.
-# For example, a german layout can be obtained with:
-# Option "XkbLayout" "de"
-# or:
-# Option "XkbLayout" "de"
-# Option "XkbVariant" "nodeadkeys"
-#
-# If you'd like to switch the positions of your capslock and
-# control keys, use:
-# Option "XkbOptions" "ctrl:swapcaps"
-# Or if you just want both to be control, use:
-# Option "XkbOptions" "ctrl:nocaps"
-#
- Identifier "Keyboard0"
- Driver "keyboard"
- Option "XkbModel" "pc105"
- Option "XkbLayout" "us"
-EndSection
-
-Section "InputDevice"
- Identifier "Mouse0"
- Driver "mouse"
- Option "Protocol" "IMPS/2"
- Option "Device" "/dev/input/mice"
- Option "ZAxisMapping" "4 5"
- Option "Emulate3Buttons" "yes"
-EndSection
-
-Section "Monitor"
- Identifier "Monitor0"
- VendorName "Monitor Vendor"
- ModelName "NEC FP2141SB"
-# DisplaySize 400 300
-# Note: setting HorizSync/VertRefresh will override DDC probe
-# HorizSync 30.0 - 140.0
-# VertRefresh 25.0 - 160.0
- Option "dpms"
-EndSection
-
-Section "Monitor"
- Identifier "Monitor1"
- VendorName "Generic Vendor"
- ModelName "Generic Monitor"
- HorizSync 28-50
- VertRefresh 43-73
- Modeline "800x600-60" 40.0000 800 840 976 1056 600 601 605 628
- Modeline "800x600-72" 50.0000 800 856 976 1040 600 637 643 666
- Modeline "640x480-60" 25.1749 640 656 744 800 480 490 492 525 -HSync -VSync
- Modeline "640x480-72" 31.5000 640 664 704 832 480 489 492 520 -HSync -VSync
- Option "dpms"
-EndSection
-
-
-Section "Device"
- Identifier "FBDev"
- Driver "fbdev"
- #Option "shadowfb" "off"
-EndSection
-
-Section "Screen"
- Identifier "Screen0"
- Device "FBDev"
- Monitor "Monitor0"
- DefaultDepth 16
-
- SubSection "Display"
- Depth 8
- Modes "1024x768" "800x600" "640x480"
- EndSubsection
-
- SubSection "Display"
- Depth 16
- Modes "1024x768" "800x600" "640x480"
- EndSubsection
-
- SubSection "Display"
- Depth 24
- FbBpp 32
- Modes "1024x768" "800x600" "640x480"
- EndSubsection
-
-EndSection
-
-Section "DRI"
- Group 0
- Mode 0666
-EndSection
-