aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-07-16 16:31:21 +0200
committerKoen Kooi <koen@openembedded.org>2009-07-16 16:31:21 +0200
commitdd6ca0445dbd8bc9804c6c7ece7f84a235e17cf9 (patch)
tree14eedacfd0ac11f6039af04aba02f15edfc6ece4
parent2dff7b788dc52c5da3fd2c5863dfad857a7d1710 (diff)
parentb0ee2783b35fd328ba73ac92cdbee49afdb6dcdc (diff)
downloadopenembedded-dd6ca0445dbd8bc9804c6c7ece7f84a235e17cf9.tar.gz
Merge branch 'org.openembedded.dev' of git@git.openembedded.org:openembedded into org.openembedded.dev
-rw-r--r--classes/angstrom.bbclass19
-rw-r--r--conf/distro/angstrom-2008.1.conf3
-rw-r--r--conf/distro/include/angstrom.inc3
-rw-r--r--recipes/bluez/bluez-libs.inc6
-rw-r--r--recipes/bluez/bluez-utils3.inc6
-rw-r--r--recipes/linux/linux-omap_2.6.30+2.6.31-rc1.bb28
6 files changed, 25 insertions, 40 deletions
diff --git a/classes/angstrom.bbclass b/classes/angstrom.bbclass
new file mode 100644
index 0000000000..4a810a638a
--- /dev/null
+++ b/classes/angstrom.bbclass
@@ -0,0 +1,19 @@
+# anonymous support class for angstrom
+#
+# Features:
+#
+# * blacklist handling, set ANGSTROM_BLACKLIST_pn-blah = "message"
+#
+
+python () {
+ import bb
+
+ blacklist = bb.data.getVar("ANGSTROM_BLACKLIST", d, 1)
+ pkgnm = bb.data.getVar("PN", d, 1)
+
+ if blacklist:
+ bb.note("Angstrom DOES NOT support %s because %s" % (pkgnm, blacklist))
+ raise bb.parse.SkipPackage("Angstrom DOES NOT support %s because %s" % (pkgnm, blacklist))
+
+}
+
diff --git a/conf/distro/angstrom-2008.1.conf b/conf/distro/angstrom-2008.1.conf
index 470c31a788..9b1968f343 100644
--- a/conf/distro/angstrom-2008.1.conf
+++ b/conf/distro/angstrom-2008.1.conf
@@ -160,6 +160,9 @@ PREFERRED_PROVIDER_bluez-utils-dbus = "bluez-utils"
PREFERRED_PROVIDER_bluez-libs = "bluez4"
PREFERRED_PROVIDER_bluez-utils = "bluez4"
+ANGSTROM_BLACKLIST_pn-bluez-libs = "bluez3 has been replace by bluez4"
+ANGSTROM_BLACKLIST_pn-bluez-utils = "bluez3 has been replace by bluez4"
+
# we don't ship gtk-directfb by default
PREFERRED_PROVIDER_gtk+ ?= "gtk+"
PREFERRED_PROVIDER_gdk-pixbuf-loader-ani ?= "gtk+"
diff --git a/conf/distro/include/angstrom.inc b/conf/distro/include/angstrom.inc
index a40fe5fbc8..669c8ada3c 100644
--- a/conf/distro/include/angstrom.inc
+++ b/conf/distro/include/angstrom.inc
@@ -70,6 +70,9 @@ INHERIT += "debian"
#activate config checker
INHERIT += "sanity"
+#activate the blacklister
+INHERIT += "angstrom"
+
#make devshell available as task
INHERIT += "devshell"
diff --git a/recipes/bluez/bluez-libs.inc b/recipes/bluez/bluez-libs.inc
index 1de371840a..d740bd80a9 100644
--- a/recipes/bluez/bluez-libs.inc
+++ b/recipes/bluez/bluez-libs.inc
@@ -5,12 +5,6 @@ HOMEPAGE = "http://www.bluez.org"
LICENSE = "GPL"
PR = "r0"
-python () {
- distro = bb.data.getVar("DISTRO_NAME", d, 1)
- if distro == "Angstrom":
- raise bb.parse.SkipPackage("Angstrom doesn't support bluez3 anymore, only bluez4")
-}
-
SRC_URI = "http://bluez.sourceforge.net/download/bluez-libs-${PV}.tar.gz"
inherit autotools pkgconfig
diff --git a/recipes/bluez/bluez-utils3.inc b/recipes/bluez/bluez-utils3.inc
index 824a753cc1..df071b76d9 100644
--- a/recipes/bluez/bluez-utils3.inc
+++ b/recipes/bluez/bluez-utils3.inc
@@ -8,12 +8,6 @@ RREPLACES = "bluez-utils-dbus"
RCONFLICTS_${PN} = "bluez-utils-nodbus"
LICENSE = "GPL"
-python () {
- distro = bb.data.getVar("DISTRO_NAME", d, 1)
- if distro == "Angstrom":
- raise bb.parse.SkipPackage("Angstrom doesn't support bluez3 anymore, only bluez4")
-}
-
FILESPATH = "${FILE_DIRNAME}/bluez-utils-${PV}:${FILE_DIRNAME}/bluez-utils"
SRC_URI = "http://bluez.sourceforge.net/download/bluez-utils-${PV}.tar.gz \
diff --git a/recipes/linux/linux-omap_2.6.30+2.6.31-rc1.bb b/recipes/linux/linux-omap_2.6.30+2.6.31-rc1.bb
deleted file mode 100644
index c5f56fc873..0000000000
--- a/recipes/linux/linux-omap_2.6.30+2.6.31-rc1.bb
+++ /dev/null
@@ -1,28 +0,0 @@
-require linux.inc
-
-DESCRIPTION = "Linux kernel for OMAP processors"
-KERNEL_IMAGETYPE = "uImage"
-
-COMPATIBLE_MACHINE = "omap5912osk|omap1710h3|omap2430sdp|omap2420h4|beagleboard|omap3evm|omap3-pandora|overo|omapzoom"
-
-DEFAULT_PREFERENCE = "-1"
-DEFAULT_PREFERENCE_omapzoom2 = "1"
-
-SRCREV = "7c5cb7862d32cb344be7831d466535d5255e35ac"
-
-FILESPATHPKG_prepend = "linux-omap-2.6.31:"
-
-# The main PR is now using MACHINE_KERNEL_PR, for omap3 see conf/machine/include/omap3.inc
-PV = "2.6.30+2.6.31-rc1+gitr${SRCREV}"
-PR = "r0"
-
-SRC_URI = "git://git.kernel.org/pub/scm/linux/kernel/git/tmlind/linux-omap-2.6.git;protocol=git \
- file://defconfig"
-
-SRC_URI_append = " \
-"
-
-S = "${WORKDIR}/git"
-
-module_autoload_ohci-hcd_omap5912osk = "ohci-hcd"
-