aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2009-07-17 09:50:57 +0200
committerKoen Kooi <koen@openembedded.org>2009-07-17 09:50:57 +0200
commitaf87be4c7e5cd533526f8d998f8eb6602ccf9f29 (patch)
tree93cacfd7c4f588fcf4b2a9bfb2c5ef70a86c0a6a
parentdd83070ec94c60a5626a84d975cc9deea85dacaa (diff)
parent2e000d15a166e32f57ab762a53b173db98596ee4 (diff)
downloadopenembedded-af87be4c7e5cd533526f8d998f8eb6602ccf9f29.tar.gz
Merge branch 'org.openembedded.dev' of git@git.openembedded.org:openembedded into org.openembedded.dev
-rw-r--r--recipes/libopie/libopie2_cvs.bb15
-rw-r--r--recipes/libqpe/libqpe-opie_cvs.bb4
-rw-r--r--recipes/opie-taskbar/opie-taskbar/server-pro-cvs.patch68
-rw-r--r--recipes/opie-taskbar/opie-taskbar_cvs.bb4
4 files changed, 80 insertions, 11 deletions
diff --git a/recipes/libopie/libopie2_cvs.bb b/recipes/libopie/libopie2_cvs.bb
index c9f11b23e2..427f83b786 100644
--- a/recipes/libopie/libopie2_cvs.bb
+++ b/recipes/libopie/libopie2_cvs.bb
@@ -1,17 +1,18 @@
require ${PN}.inc
PV = "${OPIE_CVS_PV}"
-PR = "r12"
+PR = "r13"
DEFAULT_PREFERENCE = "-1"
SRC_URI = "${HANDHELDS_CVS};module=opie/libopie2 \
- file://c7x0_w100_disable.patch;patch=1 \
file://include.pro"
-# Patches merged upstream, keep for reference (for 1.2.2)
-# file://ipaq-lcd-rotate-cleanup.patch;patch=1 \
-# file://exports.patch;patch=1 \
-# file://wireless.patch;patch=1"
-
+# FIXME remove this!
SRC_URI_append_poodle = " file://poodle-2.6-hotkeys.patch;patch=1"
+
+do_stage_append() {
+ # special case for uic-created header files
+ install -m 0644 opiepim/ui/opimalarmdlgbase.h ${STAGING_INCDIR}/opie2/
+}
+
diff --git a/recipes/libqpe/libqpe-opie_cvs.bb b/recipes/libqpe/libqpe-opie_cvs.bb
index d3b17ac7ee..49c1a934e3 100644
--- a/recipes/libqpe/libqpe-opie_cvs.bb
+++ b/recipes/libqpe/libqpe-opie_cvs.bb
@@ -1,11 +1,11 @@
require ${PN}.inc
PV = "${OPIE_CVS_PV}"
-PR = "r5"
+PR = "r6"
SRC_URI = "${HANDHELDS_CVS};module=opie/library \
file://fix-titleheight.patch;patch=1 \
file://unbreak-logging.patch;patch=1 \
file://citytime-path-2.patch;patch=1 \
+ file://no-include-pro.patch;patch=1 \
"
-
diff --git a/recipes/opie-taskbar/opie-taskbar/server-pro-cvs.patch b/recipes/opie-taskbar/opie-taskbar/server-pro-cvs.patch
new file mode 100644
index 0000000000..72d6ce55eb
--- /dev/null
+++ b/recipes/opie-taskbar/opie-taskbar/server-pro-cvs.patch
@@ -0,0 +1,68 @@
+--- launcher/server.pro 2009-07-13 23:55:07.000000000 +0100
++++ launcher/server.pro 2009-07-17 00:03:40.000000000 +0100
+@@ -2,7 +2,7 @@
+
+ CONFIG += qt warn_on
+
+-DESTDIR = $$(OPIEDIR)/bin
++DESTDIR =
+
+ HEADERS += server.h \
+ qrr.h \
+@@ -20,7 +20,7 @@
+ shutdownimpl.h \
+ launcher.h \
+ launcherview.h \
+- $$(OPIEDIR)/core/apps/calibrate/calibrate.h \
++ calibrate/calibrate.h \
+ startmenu.h \
+ transferserver.h \
+ qcopbridge.h \
+@@ -31,7 +31,7 @@
+ serverapp.h \
+ qprocess.h \
+ screensaver.h \
+- $$(OPIEDIR)/noncore/settings/mediummount/mediumwidget.h \
++ mediummount/mediumwidget.h \
+ mediadlg.h \
+ virtualfs.h
+
+@@ -51,7 +51,7 @@
+ shutdownimpl.cpp \
+ launcher.cpp \
+ launcherview.cpp \
+- $$(OPIEDIR)/core/apps/calibrate/calibrate.cpp \
++ calibrate/calibrate.cpp \
+ transferserver.cpp \
+ packageslave.cpp \
+ irserver.cpp \
+@@ -64,21 +64,21 @@
+ qprocess.cpp \
+ qprocess_unix.cpp \
+ screensaver.cpp \
+- $$(OPIEDIR)/noncore/settings/mediummount/mediumwidget.cc \
++ mediummount/mediumwidget.cc \
+ mediadlg.cpp \
+ virtualfs.cpp
+
+
+-INCLUDEPATH += $(OPIEDIR)/core/apps/calibrate
+-DEPENDPATH += $(OPIEDIR)/core/apps/calibrate
++INCLUDEPATH += calibrate
++DEPENDPATH += calibrate
+
+-INCLUDEPATH += $(OPIEDIR)/include $(OPIEDIR)/rsync
+-DEPENDPATH += $(OPIEDIR)/rsync
++INCLUDEPATH += $(OPIEDIR)/include rsync
++DEPENDPATH += rsync
+
+-INCLUDEPATH += $(OPIEDIR)/noncore/settings/mediummount
+-DEPENDPATH += $(OPIEDIR)/noncore/settings/mediummount
++INCLUDEPATH += mediummount
++DEPENDPATH += mediummount
+
+-LIBS += -lqpe -lopiecore2 -lopieui2 -lopiesecurity2 -lqrsync
++LIBS = -lqpe -lopiecore2 -lopieui2 -lopiesecurity2 -lqrsync
+ TARGET = qpe
+
+ ## not ready for use yet
diff --git a/recipes/opie-taskbar/opie-taskbar_cvs.bb b/recipes/opie-taskbar/opie-taskbar_cvs.bb
index e84e35d820..08c4d3bbec 100644
--- a/recipes/opie-taskbar/opie-taskbar_cvs.bb
+++ b/recipes/opie-taskbar/opie-taskbar_cvs.bb
@@ -1,6 +1,6 @@
require ${PN}.inc
PV = "${OPIE_CVS_PV}"
-PR = "r16"
+PR = "r17"
SRC_URI = "${HANDHELDS_CVS};module=opie/core/apps/calibrate \
${HANDHELDS_CVS};module=opie/noncore/settings/mediummount \
@@ -13,6 +13,6 @@ SRC_URI = "${HANDHELDS_CVS};module=opie/core/apps/calibrate \
file://no-builtin-qss-startup.patch;patch=1 \
file://kbdlocks-runtime.patch;patch=1 \
file://restart-from-bindir.patch;patch=1 \
- file://server.pro \
+ file://server-pro-cvs.patch;patch=1 \
file://firstuse-path.patch;patch=1 \
"