aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-09-03 17:55:53 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-09-03 17:55:53 +0000
commit0632eb10e87559ecfa67305b755b065389489243 (patch)
treed6b059767767f1dc305baa4c45610fc444486030
parent77fe2053f54d554884e65c6e4336f014f7f80fe0 (diff)
downloadopenembedded-0632eb10e87559ecfa67305b755b065389489243.tar.gz
python 2.5.2 ship shlex in python-shell
-rwxr-xr-xcontrib/python/generate-manifest-2.5.py4
-rw-r--r--packages/python/python-2.5-manifest.inc4
-rw-r--r--packages/python/python_2.5.2.bb2
3 files changed, 5 insertions, 5 deletions
diff --git a/contrib/python/generate-manifest-2.5.py b/contrib/python/generate-manifest-2.5.py
index ee1b6753e3..2560853982 100755
--- a/contrib/python/generate-manifest-2.5.py
+++ b/contrib/python/generate-manifest-2.5.py
@@ -289,8 +289,8 @@ if __name__ == "__main__":
m.addPackage( 0, "python-resource", "Python Resource Control Interface", "python-core",
"lib-dynload/resource.so" )
- m.addPackage( 0, "python-shell", "Python Shell-Like Functionality", "python-core python-re",
- "cmd.* commands.* dircache.* fnmatch.* glob.* popen2.* shutil.*" )
+ m.addPackage( 1, "python-shell", "Python Shell-Like Functionality", "python-core python-re",
+ "cmd.* commands.* dircache.* fnmatch.* glob.* popen2.* shlex.* shutil.*" )
m.addPackage( 0, "python-robotparser", "Python robots.txt parser", "python-core python-netclient",
"robotparser.*")
diff --git a/packages/python/python-2.5-manifest.inc b/packages/python/python-2.5-manifest.inc
index 9ae307e7a4..68fb934e54 100644
--- a/packages/python/python-2.5-manifest.inc
+++ b/packages/python/python-2.5-manifest.inc
@@ -264,9 +264,9 @@ RDEPENDS_python-debugger="python-core python-io python-lang python-re python-str
FILES_python-debugger="${libdir}/python2.5/bdb.* ${libdir}/python2.5/pdb.* "
DESCRIPTION_python-shell="Python Shell-Like Functionality"
-PR_python-shell="ml0"
+PR_python-shell="ml1"
RDEPENDS_python-shell="python-core python-re"
-FILES_python-shell="${libdir}/python2.5/cmd.* ${libdir}/python2.5/commands.* ${libdir}/python2.5/dircache.* ${libdir}/python2.5/fnmatch.* ${libdir}/python2.5/glob.* ${libdir}/python2.5/popen2.* ${libdir}/python2.5/shutil.* "
+FILES_python-shell="${libdir}/python2.5/cmd.* ${libdir}/python2.5/commands.* ${libdir}/python2.5/dircache.* ${libdir}/python2.5/fnmatch.* ${libdir}/python2.5/glob.* ${libdir}/python2.5/popen2.* ${libdir}/python2.5/shlex.* ${libdir}/python2.5/shutil.* "
DESCRIPTION_python-bsddb="Python Berkeley Database Bindings"
PR_python-bsddb="ml1"
diff --git a/packages/python/python_2.5.2.bb b/packages/python/python_2.5.2.bb
index c68f7d5e3b..e285575149 100644
--- a/packages/python/python_2.5.2.bb
+++ b/packages/python/python_2.5.2.bb
@@ -6,7 +6,7 @@ PRIORITY = "optional"
DEPENDS = "python-native db gdbm openssl readline sqlite3 tcl tk zlib"
DEPENDS_sharprom = "python-native db readline zlib gdbm openssl"
# bump this on every change in contrib/python/generate-manifest-2.5.py
-PR = "ml9"
+PR = "ml10"
PYTHON_MAJMIN = "2.5"