aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMarcin Juszkiewicz <hrw@openembedded.org>2009-03-06 22:24:41 +0100
committerMarcin Juszkiewicz <hrw@openembedded.org>2009-03-06 22:27:06 +0100
commit38402a4968328e289ef5ae133097879521531afb (patch)
treeb42667bf6276781dc1860c3571cd2b3ba9f458f3
parentd3a1be4261971093eb20f9086e84b8f5aa09bf26 (diff)
downloadopenembedded-38402a4968328e289ef5ae133097879521531afb.tar.gz
mbw: added 1.1 version of simple memory bandwidth benchmark
Results from my devices: root@bug:~# mbw 16|grep AVG AVG Method: MEMCPY Elapsed: 0.16403 MiB: 16.00000 Copy: 97.544 MiB/s AVG Method: DUMB Elapsed: 0.12401 MiB: 16.00000 Copy: 129.023 MiB/s AVG Method: MCBLOCK Elapsed: 0.09725 MiB: 16.00000 Copy: 164.519 MiB/s root@at91sam9263ek:~# mbw 16|grep AVG AVG Method: MEMCPY Elapsed: 0.30546 MiB: 16.00000 Copy: 52.381 MiB/s AVG Method: DUMB Elapsed: 0.13668 MiB: 16.00000 Copy: 117.064 MiB/s AVG Method: MCBLOCK Elapsed: 0.15507 MiB: 16.00000 Copy: 103.181 MiB/s root@vortex86sx:~# mbw 16|grep AVG AVG Method: MEMCPY Elapsed: 0.55531 MiB: 16.00000 Copy: 28.813 MiB/s AVG Method: DUMB Elapsed: 1.04163 MiB: 16.00000 Copy: 15.361 MiB/s AVG Method: MCBLOCK Elapsed: 1.26276 MiB: 16.00000 Copy: 12.671 MiB/s
-rw-r--r--packages/mbw/mbw_1.1.bb14
1 files changed, 14 insertions, 0 deletions
diff --git a/packages/mbw/mbw_1.1.bb b/packages/mbw/mbw_1.1.bb
new file mode 100644
index 0000000000..31ba432431
--- /dev/null
+++ b/packages/mbw/mbw_1.1.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Memory bandwidth benchmark"
+AUTHOR = "Andras Horvath <Andras.Horvath@cern.ch>"
+
+SRC_URI = "http://ahorvath.web.cern.ch/ahorvath/mbw/mbw-${PV}-1.tar.gz"
+
+S = "${WORKDIR}/mbw/"
+
+inherit autotools
+
+do_install() {
+ install -d ${D}${bindir} ${D}${mandir}
+ install -m 755 mbw ${D}${bindir}
+ install -m 644 mbw.1 ${D}${mandir}/man1/
+}