aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorOtavio Salvador <otavio@ossystems.com.br>2009-02-13 14:07:08 -0200
committerOtavio Salvador <otavio@ossystems.com.br>2009-02-13 14:07:08 -0200
commit9e4e61a440edfa18f14ecf84272e10c9e22aa9c9 (patch)
tree41a63c494413550537af9025d70736a6f611b30c
parent1bd17718ed3df6521b77d6aeef36e58db7fd1fda (diff)
parent168ba1763b4b997cfb5bf5eefdbca8ae89f1dd2e (diff)
downloadopenembedded-9e4e61a440edfa18f14ecf84272e10c9e22aa9c9.tar.gz
Merge branch 'master' of git://projetos.ossystems.com.br/git/users/otavio/org.openembedded.dev into org.openembedded.dev
* 'master' of git://projetos.ossystems.com.br/git/users/otavio/org.openembedded.dev: flash-plugin: add 10.0.12.36 sun-jre6: add 1.6.0.10 parted: drop versions up to 1.8.8 package.bbclass, package_ipk.bbclass: add dynamic depends on locale packages (ipk specific) cups: add 1.3.8. rt61-firmware: add 1.2
-rw-r--r--classes/package.bbclass10
-rw-r--r--classes/package_ipk.bbclass4
-rw-r--r--conf/bitbake.conf1
-rw-r--r--conf/checksums.ini4
-rw-r--r--packages/adobe-flash/flash-plugin_10.0.12.36.bb35
-rw-r--r--packages/cups/cups-1.3.8/use_echo_only_in_init.patch11
-rw-r--r--packages/cups/cups_1.3.8.bb8
-rw-r--r--packages/parted/parted-1.8.0/memory_allocation.patch42
-rw-r--r--packages/parted/parted_1.6.23.bb12
-rw-r--r--packages/parted/parted_1.6.25.1.bb17
-rw-r--r--packages/parted/parted_1.8.0.bb18
-rw-r--r--packages/parted/parted_1.8.2.bb16
-rw-r--r--packages/parted/parted_1.8.7.bb30
-rw-r--r--packages/rt2x00/rt61-firmware_1.2.bb14
-rw-r--r--packages/sun-jre/sun-jre6_1.6.0.10.bb71
15 files changed, 148 insertions, 145 deletions
diff --git a/classes/package.bbclass b/classes/package.bbclass
index a7cdb5f2d5..55595928c6 100644
--- a/classes/package.bbclass
+++ b/classes/package.bbclass
@@ -293,16 +293,6 @@ python package_do_split_locales() {
bb.data.setVar('DESCRIPTION_' + pkg, '%s translation for %s' % (l, pn), d)
bb.data.setVar('PACKAGES', ' '.join(packages), d)
-
- # Disabled by RP 18/06/07
- # Wildcards aren't supported in debian
- # They break with ipkg since glibc-locale* will mean that
- # glibc-localedata-translit* won't install as a dependency
- # for some other package which breaks meta-toolchain
- # Probably breaks since virtual-locale- isn't provided anywhere
- #rdep = (bb.data.getVar('RDEPENDS_%s' % mainpkg, d, 1) or bb.data.getVar('RDEPENDS', d, 1) or "").split()
- #rdep.append('%s-locale*' % pn)
- #bb.data.setVar('RDEPENDS_%s' % mainpkg, ' '.join(rdep), d)
}
python populate_packages () {
diff --git a/classes/package_ipk.bbclass b/classes/package_ipk.bbclass
index 3a977291ff..99f3793447 100644
--- a/classes/package_ipk.bbclass
+++ b/classes/package_ipk.bbclass
@@ -244,6 +244,10 @@ python do_package_ipk () {
rprovides = (bb.data.getVar("RPROVIDES", localdata, 1) or "").split()
rreplaces = (bb.data.getVar("RREPLACES", localdata, 1) or "").split()
rconflicts = (bb.data.getVar("RCONFLICTS", localdata, 1) or "").split()
+
+ if not '-locale-' and not '-dbg' and not '-dev' in pkgname
+ rdepends.append('%s-locale*' % pkgname)
+
if rdepends:
ctrlfile.write("Depends: %s\n" % ", ".join(rdepends))
if rsuggests:
diff --git a/conf/bitbake.conf b/conf/bitbake.conf
index b00d12586b..9c187c0757 100644
--- a/conf/bitbake.conf
+++ b/conf/bitbake.conf
@@ -499,6 +499,7 @@ FREESMARTPHONE_GIT = "git://git.freesmartphone.org"
GENTOO_MIRROR = "http://distro.ibiblio.org/pub/linux/distributions/gentoo/distfiles"
APACHE_MIRROR = "http://www.apache.org/dist"
KERNELORG_MIRROR = "http://kernel.org"
+ADOBE_MIRROR = "http://fpdownload.macromedia.com/get/flashplayer/current/"
# You can use the mirror of your country to get faster downloads by putting
# export DEBIAN_MIRROR = "ftp://ftp.de.debian.org/debian/pool"
diff --git a/conf/checksums.ini b/conf/checksums.ini
index 4e8e0f105f..83bed25b99 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -5510,6 +5510,10 @@ sha256=ce4f7d11b3c04a7368c916ca4abc284dd0c0256f461dfb7f07df1ab445e7a5c0
md5=2bfc127cdda02834d0491ab531a20960
sha256=ce4f7d11b3c04a7368c916ca4abc284dd0c0256f461dfb7f07df1ab445e7a5c0
+[http://fpdownload.macromedia.com/get/flashplayer/current//flash-plugin-10.0.12.36-release.i386.rpm]
+md5=8845d4536fcd3a329690c93bce9bbf8e
+sha256=c7345faf10b269b3556f2e1373c4afc35f08891f8bbd54e45d49151a8c8e4ac0
+
[http://downloads.sourceforge.net/flex/flex-2.5.31.tar.bz2]
md5=363dcc4afc917dc51306eb9d3de0152f
sha256=701353279a17655d78e3b3678ad78d0375f5bf45877ad8b3507d589c42427f26
diff --git a/packages/adobe-flash/flash-plugin_10.0.12.36.bb b/packages/adobe-flash/flash-plugin_10.0.12.36.bb
new file mode 100644
index 0000000000..d6cde60031
--- /dev/null
+++ b/packages/adobe-flash/flash-plugin_10.0.12.36.bb
@@ -0,0 +1,35 @@
+# Adobe provides two versions of flash player packages
+#
+# One "unversioned" download at :
+#
+# ${ADOBE_MIRROR}/install_flash_player_9_linux.tar.gz
+#
+# And the other, versioned, which is encapsulated in RPM.
+#
+# We use the versioned one to make sure we can keep track of the
+# version and thus do repeatable builds at the cost of future download
+# failures when adobe updates.
+DESCRIPTION = "Adobe Flash 9 plugin for Mozilla/Firefox web browsers"
+LICENSE = "AdobeFlash"
+DEPENDS = "rpm2cpio-native"
+PR = "r1"
+
+SRC_URI = "${ADOBE_MIRROR}/flash-plugin-${PV}-release.i386.rpm"
+
+do_configure() {
+ rpm=${WORKDIR}/flash-plugin-${PV}-release.i386.rpm
+ if [ -f "$rpm" ]; then
+ rpm2cpio.pl $rpm | cpio -id
+ find . -type f -exec mv -i {} "`pwd`" \;
+ fi
+}
+do_install() {
+ mkdir -p ${D}${libdir}/mozilla/plugins/
+ install -m 0755 libflashplayer.so ${D}${libdir}/mozilla/plugins/
+ # AFAIK this is not needed
+ # install -m 0644 flashplayer.xpt ${D}${libdir}/mozilla/plugins/
+}
+
+FILES_${PN} = "${libdir}/* ${libdir}/X11/*"
+
+COMPATIBLE_HOST = "i.86.*-linux"
diff --git a/packages/cups/cups-1.3.8/use_echo_only_in_init.patch b/packages/cups/cups-1.3.8/use_echo_only_in_init.patch
new file mode 100644
index 0000000000..21ff0e535b
--- /dev/null
+++ b/packages/cups/cups-1.3.8/use_echo_only_in_init.patch
@@ -0,0 +1,11 @@
+--- a/init/cups.sh.in.orig 2008-10-04 16:50:46.000000000 -0300
++++ b/init/cups.sh.in 2008-10-04 16:51:39.000000000 -0300
+@@ -68,7 +68,7 @@
+ ECHO_ERROR=:
+ ;;
+
+- Linux*)
++ DISABLELinux*)
+ IS_ON=/bin/true
+ if test -f /etc/init.d/functions; then
+ . /etc/init.d/functions
diff --git a/packages/cups/cups_1.3.8.bb b/packages/cups/cups_1.3.8.bb
new file mode 100644
index 0000000000..e9fd9850e9
--- /dev/null
+++ b/packages/cups/cups_1.3.8.bb
@@ -0,0 +1,8 @@
+require cups.inc
+
+SRC_URI += "file://use_echo_only_in_init.patch;patch=1"
+PR = "r1"
+
+DEFAULT_PREFERENCE = "-1"
+
+EXTRA_OECONF += " --disable-gssapi "
diff --git a/packages/parted/parted-1.8.0/memory_allocation.patch b/packages/parted/parted-1.8.0/memory_allocation.patch
deleted file mode 100644
index ba3709680b..0000000000
--- a/packages/parted/parted-1.8.0/memory_allocation.patch
+++ /dev/null
@@ -1,42 +0,0 @@
---- parted-1.8.0/libparted/exception.c_orig 2006-12-11 19:44:23.000000000 +0000
-+++ parted-1.8.0/libparted/exception.c 2006-12-11 19:47:53.000000000 +0000
-@@ -231,6 +231,9 @@
- PedExceptionOption ex_opts, const char* message, ...)
- {
- va_list arg_list;
-+ int result;
-+ static int size = 1000;
-+
-
- if (ex)
- ped_exception_catch ();
-@@ -239,16 +242,22 @@
- if (!ex)
- goto no_memory;
-
-- ex->message = (char*) malloc (8192);
-- if (!ex->message)
-- goto no_memory;
--
- ex->type = ex_type;
- ex->options = ex_opts;
-
-- va_start (arg_list, message);
-- vsnprintf (ex->message, 8192, message, arg_list);
-- va_end (arg_list);
-+ while (1) {
-+ ex->message = (char*) malloc (size);
-+ if (!ex->message)
-+ goto no_memory;
-+ va_start (arg_list, message);
-+ result = vsnprintf (ex->message, size, message, arg_list);
-+ va_end (arg_list);
-+
-+ if (result > -1 && result < size)
-+ break;
-+ size += 10;
-+ }
-+
-
- return do_throw ();
-
diff --git a/packages/parted/parted_1.6.23.bb b/packages/parted/parted_1.6.23.bb
deleted file mode 100644
index cb9b08f407..0000000000
--- a/packages/parted/parted_1.6.23.bb
+++ /dev/null
@@ -1,12 +0,0 @@
-DESCRIPTION = "parted, the GNU partition resizing program"
-HOMEPAGE = "http://www.gnu.org/software/parted/parted.html"
-LICENSE = "GPLv2"
-SECTION = "console/tools"
-DEPENDS = "readline e2fsprogs-libs"
-PR = "r0"
-
-SRC_URI = "${GNU_MIRROR}/parted/parted-${PV}.tar.gz"
-
-EXTRA_OECONF = "--disable-Werror"
-
-inherit autotools
diff --git a/packages/parted/parted_1.6.25.1.bb b/packages/parted/parted_1.6.25.1.bb
deleted file mode 100644
index 8681055855..0000000000
--- a/packages/parted/parted_1.6.25.1.bb
+++ /dev/null
@@ -1,17 +0,0 @@
-DESCRIPTION = "parted, the GNU partition resizing program"
-HOMEPAGE = "http://www.gnu.org/software/parted/parted.html"
-LICENSE = "GPLv2"
-SECTION = "console/tools"
-DEPENDS = "readline e2fsprogs-libs"
-PR = "r0"
-
-SRC_URI = "${GNU_MIRROR}/parted/parted-${PV}.tar.gz"
-
-EXTRA_OECONF = "--disable-Werror"
-#export CFLAGS = "-mstructure-size-boundary=8"
-
-inherit autotools pkgconfig
-
-do_stage() {
- autotools_stage_all
-}
diff --git a/packages/parted/parted_1.8.0.bb b/packages/parted/parted_1.8.0.bb
deleted file mode 100644
index bff27a62e8..0000000000
--- a/packages/parted/parted_1.8.0.bb
+++ /dev/null
@@ -1,18 +0,0 @@
-DESCRIPTION = "parted, the GNU partition resizing program"
-HOMEPAGE = "http://www.gnu.org/software/parted/parted.html"
-LICENSE = "GPLv2"
-SECTION = "console/tools"
-DEPENDS = "readline e2fsprogs-libs"
-PR = "r0"
-
-SRC_URI = "${GNU_MIRROR}/parted/parted-${PV}.tar.gz \
- file://memory_allocation.patch;patch=0"
-
-EXTRA_OECONF = "--disable-Werror"
-#export CFLAGS = "-mstructure-size-boundary=8"
-
-inherit autotools pkgconfig
-
-do_stage() {
- autotools_stage_all
-}
diff --git a/packages/parted/parted_1.8.2.bb b/packages/parted/parted_1.8.2.bb
deleted file mode 100644
index 1185014aa3..0000000000
--- a/packages/parted/parted_1.8.2.bb
+++ /dev/null
@@ -1,16 +0,0 @@
-DESCRIPTION = "parted, the GNU partition resizing program"
-HOMEPAGE = "http://www.gnu.org/software/parted/parted.html"
-LICENSE = "GPLv2"
-SECTION = "console/tools"
-DEPENDS = "readline e2fsprogs-libs"
-PR = "r0"
-
-SRC_URI = "${GNU_MIRROR}/parted/parted-${PV}.tar.gz"
-
-#EXTRA_OECONF = "--disable-Werror"
-
-inherit autotools pkgconfig
-
-do_stage() {
- autotools_stage_all
-}
diff --git a/packages/parted/parted_1.8.7.bb b/packages/parted/parted_1.8.7.bb
deleted file mode 100644
index 59e3aeaece..0000000000
--- a/packages/parted/parted_1.8.7.bb
+++ /dev/null
@@ -1,30 +0,0 @@
-DESCRIPTION = "parted, the GNU partition resizing program"
-HOMEPAGE = "http://www.gnu.org/software/parted/parted.html"
-LICENSE = "GPLv2"
-SECTION = "console/tools"
-DEPENDS = "readline e2fsprogs-libs"
-PR = "r2"
-
-SRC_URI = "${GNU_MIRROR}/parted/parted-${PV}.tar.gz \
- file://syscalls.h \
- file://syscalls.patch;patch=1 \
- file://cross-gross-hack.patch;patch=1"
-
-EXTRA_OECONF = "--disable-Werror"
-
-inherit autotools pkgconfig
-
-do_configure_prepend() {
- cp ${WORKDIR}/syscalls.h ${S}/libparted/arch/
-}
-
-do_configure() {
- gnu-configize
- libtoolize --force
- autoconf
- oe_runconf
-}
-
-do_stage() {
- autotools_stage_all
-}
diff --git a/packages/rt2x00/rt61-firmware_1.2.bb b/packages/rt2x00/rt61-firmware_1.2.bb
new file mode 100644
index 0000000000..ae683c8060
--- /dev/null
+++ b/packages/rt2x00/rt61-firmware_1.2.bb
@@ -0,0 +1,14 @@
+DESCRIPTION = "Firmware for rt61 based USB wifi adaptors"
+LICENSE = "unknown"
+
+SRC_URI = "http://www.ralinktech.com.tw/data/RT61_Firmware_V${PV}.zip"
+
+S = "${WORKDIR}/RT61_Firmware_V${PV}"
+
+do_install() {
+ install -d ${D}/${base_libdir}/firmware
+ install -m 0644 rt61.bin ${D}/${base_libdir}/firmware/
+}
+
+FILES_${PN} = "${base_libdir}/firmware/"
+PACKAGE_ARCH = "all"
diff --git a/packages/sun-jre/sun-jre6_1.6.0.10.bb b/packages/sun-jre/sun-jre6_1.6.0.10.bb
new file mode 100644
index 0000000000..f67894c39a
--- /dev/null
+++ b/packages/sun-jre/sun-jre6_1.6.0.10.bb
@@ -0,0 +1,71 @@
+DESCRIPTION = "Sun J2SE Runtime Environment"
+LICENSE = "Sun Binary Code License Agreement"
+RDEPENDS_${PN} += "libx11-locale"
+RDEPENDS_${PN}-plugin += "${PN}"
+PR = "r1"
+PRIVATE_LIBS = "${@base_read_file('${WORKDIR}/${SD}.shlibs')}"
+
+SRC_URI = "http://download.java.net/dlj/binaries/jdk-6u10-dlj-linux-i586.bin"
+
+SP = "jdk-6u10-dlj-linux-i586.bin"
+SD = "jdk1.6.0_10"
+S = "${WORKDIR}"
+
+do_install() {
+ export MORE=10000
+ sh ${WORKDIR}/${SP} --accept-license >/dev/null
+ chmod -R go=u-w ${SD}
+ chmod -R u+w ${SD}
+ mkdir -p ${D}${libdir}/sun-java6-${PV}
+ mv ${S}/${SD}/jre/* ${D}${libdir}/sun-java6-${PV}
+ mkdir -p ${D}${libdir}/mozilla/plugins
+ cd ${D}${libdir}/mozilla/plugins
+ ln -s ${libdir}/sun-java6-${PV}/plugin/i386/ns7/libjavaplugin_oji.so .
+ cd ${D}${libdir}/sun-java6-${PV}
+ for p in `find . -name '*.pack'`; do
+ ./bin/unpack200 $p $(echo $p | sed 's,.pack$,.jar,g') || exit 1
+ rm $p
+ done
+ for i in bin/ControlPanel \
+ bin/javaws \
+ bin/jcontrol \
+ bin/keytool \
+ bin/orbd \
+ bin/pack200 \
+ bin/policytool \
+ bin/rmid \
+ bin/rmiregistry \
+ bin/servertool \
+ bin/tnameserv \
+ bin/unpack200
+ do
+ rm $i
+ done
+ rm -rf javaws lib/javaws*
+ rm -rf plugin/desktop plugin/i386/ns7-gcc29
+ rm -f lib/fontconfig.*.bfc lib/fontconfig.*.properties.src
+ rm -f lib/javaws.jar lib/ext/ldapsec.jar lib/cmm/PYCC.pf \
+ lib/audio/soundbank.gm
+ rm -rf lib/i386/server lib/i386/motif21 lib/i386/client/classes.jsa \
+ lib/i386/libjavaplugin_nscp_gcc29.so \
+ lib/i386/headless
+ rm -rf fonts oblique-fonts man
+ rm -rf lib/locale lib/zi lib/management
+ rm -rf lib/desktop LICENSE README COPYRIGHT THIRDPARTYLICENSEREADME.txt \
+ Welcome.html
+ # Find out what shared libs we contain and spit it out to a file
+ find . -name "*.so" -exec basename {} \; | sort | uniq > ${WORKDIR}/${SD}.shlibs
+}
+
+PACKAGES =+ "${PN}-plugin"
+FILES_${PN} = "/usr/"
+FILES_${PN}-dbg += "/usr/*/.debug /usr/*/*/.debug /usr/*/*/*/.debug /usr/*/*/*/*/.debug /usr/*/*/*/*/*/.debug"
+FILES_${PN}-plugin = "${libdir}/mozilla/plugins/* ${libdir}/sun-java6-${PV}/plugin/i386/ns7/libjavaplugin_oji.so"
+
+pkg_postinst_${PN} () {
+ grep -v JAVA_HOME /etc/environment > /etc/environment.new
+ mv /etc/environment.new /etc/environment
+ echo "JAVA_HOME=\"${libdir}/sun-java6-${PV}\"" >> /etc/environment
+}
+
+COMPATIBLE_HOST = "i.86.*-linux"