aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoman I Khimov <khimov@altell.ru>2009-04-18 23:21:00 +0400
committerRoman I Khimov <khimov@altell.ru>2009-08-18 23:10:10 +0400
commit3159994b6f02ac2ae788b8c18a1d3a33d8e6ed09 (patch)
treeac81580524935f53afe23faddbd999ef6e932be0
parentc0f50edbee1b58cdb271220adcf59336ac449c1b (diff)
downloadopenembedded-3159994b6f02ac2ae788b8c18a1d3a33d8e6ed09.tar.gz
linux-libc-headers: 2.6.29 multilib support
-rw-r--r--recipes/linux-libc-headers/linux-libc-headers_2.6.29.bb7
1 files changed, 7 insertions, 0 deletions
diff --git a/recipes/linux-libc-headers/linux-libc-headers_2.6.29.bb b/recipes/linux-libc-headers/linux-libc-headers_2.6.29.bb
index 6caddc0c2f..913f028242 100644
--- a/recipes/linux-libc-headers/linux-libc-headers_2.6.29.bb
+++ b/recipes/linux-libc-headers/linux-libc-headers_2.6.29.bb
@@ -47,3 +47,10 @@ do_stage () {
set_arch
oe_runmake headers_install INSTALL_HDR_PATH=${STAGING_DIR_HOST}${layout_prefix} ARCH=$ARCH
}
+
+do_stage_append_multilib () {
+ install -d ${STAGING_INCDIR}/${TARGET_SYS_MULTILIB}
+ ln -s ../linux ${STAGING_INCDIR}/${TARGET_SYS_MULTILIB}/linux
+ ln -s ../asm ${STAGING_INCDIR}/${TARGET_SYS_MULTILIB}/asm
+ ln -s ../asm-generic ${STAGING_INCDIR}/${TARGET_SYS_MULTILIB}/asm-generic
+}