aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorSteve Sakoman <steve@sakoman.com>2009-08-13 21:47:24 -0700
committerKoen Kooi <koen@openembedded.org>2009-08-14 09:49:44 +0200
commit28c0117b46249ff9e29d996a909efe3855239dfd (patch)
treecf084734dce26ef3469c56213e5b8af7d5de2b08
parent1708207a54e1195d43fb412a3bbef9aa7135fce1 (diff)
downloadopenembedded-28c0117b46249ff9e29d996a909efe3855239dfd.tar.gz
libbonoboui: add 2.24.1
-rw-r--r--conf/checksums.ini4
-rw-r--r--recipes/gnome/libbonoboui_2.24.1.bb61
2 files changed, 65 insertions, 0 deletions
diff --git a/conf/checksums.ini b/conf/checksums.ini
index bc214eb1ab..b5293c7ce5 100644
--- a/conf/checksums.ini
+++ b/conf/checksums.ini
@@ -13050,6 +13050,10 @@ sha256=2dd02787e5bad91e1efbfe2fe041eefe8cf13ebce9607d6dd9764c69f37233a8
md5=22bd67a0a8b7f156c02c5fc08fb1fa24
sha256=2963b3f0f348faa43eb84083ce93070ec82844205744219dec2df46ed2305775
+[http://ftp.gnome.org/pub/GNOME/sources/libbonoboui/2.24/libbonoboui-2.24.1.tar.bz2]
+md5=9ff3ec1c7aefd0b1a15a5b21ecc7b4e4
+sha256=322536bdc23a70287f229168af2538a7b36c1b5041626ba15e22902228750c29
+
[http://ftp.gnome.org/pub/GNOME/sources/libbonoboui/2.6/libbonoboui-2.6.1.tar.bz2]
md5=ee26630368b541dc101a65e46e67f5c4
sha256=9a7596434959dbecc975c5c90021da2990189016f3fc65d7362362162a4156aa
diff --git a/recipes/gnome/libbonoboui_2.24.1.bb b/recipes/gnome/libbonoboui_2.24.1.bb
new file mode 100644
index 0000000000..447dc2e8ae
--- /dev/null
+++ b/recipes/gnome/libbonoboui_2.24.1.bb
@@ -0,0 +1,61 @@
+#DEFAULT_PREFERENCE = "-1"
+
+LICENSE = "GPL"
+SECTION = "x11/gnome/libs"
+PR = "r0"
+
+inherit gnome pkgconfig
+
+FILES_${PN} += "${libdir}/libglade/2.0/*.so"
+FILES_${PN}-dev += "${libdir}/libglade/2.0/* ${datadir}/gnome-2.0/ui \
+ ${libdir}/bonobo-2.0/samples"
+FILES_${PN}-dbg += "${libdir}/bonobo-2.0/samples/.debug \
+ ${libdir}/libglade/2.0/.debug"
+
+DEPENDS = "libgnomecanvas libbonobo libgnome glib-2.0 gtk-doc gconf libxml2 libglade"
+
+EXTRA_OECONF = "--disable-gtk-doc"
+
+HEADERS = " \
+bonobo/bonobo-zoomable.h \
+bonobo/bonobo-ui-component.h \
+bonobo/bonobo-dock-layout.h \
+bonobo/bonobo-ui-type-builtins.h \
+bonobo/bonobo-canvas-component.h \
+bonobo/bonobo-widget.h \
+bonobo/bonobo-ui-engine.h \
+bonobo/bonobo-window.h \
+bonobo/bonobo-ui-toolbar.h \
+bonobo/bonobo-dock-band.h \
+bonobo/bonobo-ui-toolbar-item.h \
+bonobo/bonobo-control.h \
+bonobo/bonobo-dock-item.h \
+bonobo/bonobo-ui-config-widget.h \
+bonobo/bonobo-zoomable-frame.h \
+bonobo/bonobo-control-frame.h \
+bonobo/bonobo-dock.h \
+bonobo/bonobo-ui-main.h \
+bonobo/bonobo-canvas-item.h \
+bonobo/bonobo-ui-node.h \
+bonobo/bonobo-socket.h \
+bonobo/bonobo-selector.h \
+bonobo/bonobo-ui-sync.h \
+bonobo/bonobo-ui-util.h \
+bonobo/bonobo-plug.h \
+bonobo/bonobo-ui-toolbar-button-item.h \
+bonobo/bonobo-ui-toolbar-toggle-button-item.h \
+bonobo/bonobo-ui-container.h \
+bonobo/bonobo-file-selector-util.h \
+bonobo/bonobo-property-control.h \
+bonobo/bonobo-selector-widget.h \
+libbonoboui.h \
+bonobo.h \
+"
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/libbonoboui-2.0/bonobo
+ for i in ${HEADERS}; do
+ install -m 0644 $i ${STAGING_INCDIR}/libbonoboui-2.0/$i
+ done
+ oe_libinstall -C bonobo -a -so libbonoboui-2 ${STAGING_LIBDIR}
+}