summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2011-03-01 08:39:16 +0100
committerKoen Kooi <koen@openembedded.org>2011-03-01 08:49:02 +0100
commit679b4bb094bd0467847525967cdbe265a17d4ef5 (patch)
treeb577b62fe187d5388f6cf48ce1a5280b3e3e7551
parent497a5b36415389e9e7e06f754463b19c80b7d270 (diff)
downloadopenembedded-679b4bb094bd0467847525967cdbe265a17d4ef5.tar.gz
alsa-utils: add 1.0.24.2
Signed-off-by: Koen Kooi <koen@openembedded.org>
-rw-r--r--recipes/alsa/alsa-utils-1.0.24.2/remove-xmlto.patch33
-rw-r--r--recipes/alsa/alsa-utils_1.0.24.2.bb62
2 files changed, 95 insertions, 0 deletions
diff --git a/recipes/alsa/alsa-utils-1.0.24.2/remove-xmlto.patch b/recipes/alsa/alsa-utils-1.0.24.2/remove-xmlto.patch
new file mode 100644
index 0000000000..41691a917b
--- /dev/null
+++ b/recipes/alsa/alsa-utils-1.0.24.2/remove-xmlto.patch
@@ -0,0 +1,33 @@
+From 4fa1ac725e8d8376e99a383501cdaeedfed0ed8f Mon Sep 17 00:00:00 2001
+From: Koen Kooi <koen@dominion.thruhere.net>
+Date: Tue, 1 Mar 2011 08:37:09 +0100
+Subject: [PATCH] alsa-utils: don't run xmlto when crosscompiling
+
+Signed-off-by: Koen Kooi <koen@dominion.thruhere.net>
+---
+ alsactl/Makefile.am | 5 -----
+ 1 files changed, 0 insertions(+), 5 deletions(-)
+
+diff --git a/alsactl/Makefile.am b/alsactl/Makefile.am
+index 5cfc415..e1fa44a 100644
+--- a/alsactl/Makefile.am
++++ b/alsactl/Makefile.am
+@@ -2,9 +2,6 @@ SUBDIRS = init
+
+ sbin_PROGRAMS=alsactl
+ man_MANS=alsactl.1
+-if USE_XMLTO
+-man_MANS += alsactl_init.7
+-endif
+ EXTRA_DIST=alsactl.1 alsactl_init.xml
+
+ alsactl_SOURCES=alsactl.c state.c utils.c init_parse.c
+@@ -55,5 +52,3 @@ CLEANFILES = \
+ alsa-restore.service \
+ 90-alsa-restore.rules
+
+-%.7: %.xml
+- xmlto man $?
+--
+1.6.6.1
+
diff --git a/recipes/alsa/alsa-utils_1.0.24.2.bb b/recipes/alsa/alsa-utils_1.0.24.2.bb
new file mode 100644
index 0000000000..a2a92533c5
--- /dev/null
+++ b/recipes/alsa/alsa-utils_1.0.24.2.bb
@@ -0,0 +1,62 @@
+DESCRIPTION = "ALSA Utilities"
+HOMEPAGE = "http://www.alsa-project.org"
+SECTION = "console/utils"
+LICENSE = "GPLv2"
+DEPENDS = "alsa-lib ncurses"
+
+SRC_URI = "ftp://ftp.alsa-project.org/pub/utils/alsa-utils-${PV}.tar.bz2 \
+ file://remove-xmlto.patch \
+ "
+
+SRC_URI[md5sum] = "8238cd57cb301d1c36bcf0ecb59ce6b2"
+SRC_URI[sha256sum] = "95127f740291086486c06c28118cabca0814bde48fd14dac041a9812a5ac1be2"
+
+inherit gettext autotools
+
+EXTRA_OECONF += " --with-alsa-prefix=${STAGING_LIBDIR} --with-alsa-inc-prefix=${STAGING_INCDIR}"
+
+# This are all packages that we need to make. Also, the now empty alsa-utils
+# ipk depend on them.
+
+PACKAGES += "\
+ alsa-utils-alsamixer \
+ alsa-utils-midi \
+ alsa-utils-aplay \
+ alsa-utils-amixer \
+ alsa-utils-aconnect \
+ alsa-utils-iecset \
+ alsa-utils-speakertest \
+ alsa-utils-aseqnet \
+ alsa-utils-aseqdump \
+ alsa-utils-alsaconf \
+ alsa-utils-alsactl "
+
+# We omit alsaconf, because
+# a) this is a bash script
+# b) it creates config files not suitable for OE-based distros
+
+FILES_${PN} = ""
+FILES_alsa-utils-aplay = "${bindir}/aplay ${bindir}/arecord"
+FILES_alsa-utils-amixer = "${bindir}/amixer"
+FILES_alsa-utils-alsamixer = "${bindir}/alsamixer"
+FILES_alsa-utils-speakertest = "${bindir}/speaker-test ${datadir}/sounds/alsa/ ${datadir}/alsa/"
+FILES_alsa-utils-midi = "${bindir}/aplaymidi ${bindir}/arecordmidi ${bindir}/amidi"
+FILES_alsa-utils-aconnect = "${bindir}/aconnect"
+FILES_alsa-utils-aseqnet = "${bindir}/aseqnet"
+FILES_alsa-utils-iecset = "${bindir}/iecset"
+FILES_alsa-utils-alsactl = "${sbindir}/alsactl"
+FILES_alsa-utils-aseqdump = "${bindir}/aseqdump"
+FILES_alsa-utils-alsaconf = "${sbindir}/alsaconf"
+
+DESCRIPTION_alsa-utils-aplay = "play (and record) sound files via ALSA"
+DESCRIPTION_alsa-utils-amixer = "command-line based control for ALSA mixer and settings"
+DESCRIPTION_alsa-utils-alsamixer = "ncurses based control for ALSA mixer and settings"
+DESCRIPTION_alsa-utils-speakertest = "ALSA surround speaker test utility"
+DESCRIPTION_alsa-utils-midi = "miscalleanous MIDI utilities for ALSA"
+DESCRIPTION_alsa-utils-aconnect = "ALSA sequencer connection manager"
+DESCRIPTION_alsa-utils-aseqnet = "network client/server on ALSA sequencer"
+DESCRIPTION_alsa-utils-alsactl = "saves/restores ALSA-settings in /etc/asound.state"
+DESCRIPTION_alsa-utils-alsaconf = "a bash script that creates ALSA configuration files"
+
+ALLOW_EMPTY_alsa-utils = "1"
+