summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorEric Bénard <eric@eukrea.com>2010-11-24 18:18:54 +0100
committerEric Bénard <eric@eukrea.com>2010-11-25 17:17:40 +0100
commit158ce0dca906227560c6bcee54563efb4a61a9e8 (patch)
tree3d78f8fd7b0bca1dd0c9dac58104a269f3d515a1
parente499783981417bee3e283460da7609364454c963 (diff)
downloadopenembedded-158ce0dca906227560c6bcee54563efb4a61a9e8.tar.gz
busybox 1.17.3: add latest fixes
from http://busybox.net/downloads/fixes-1.17.3/ : * ip route (fixed bug of misplaced argv++) * ls (-g was showing user instead of group) Signed-off-by: Eric Bénard <eric@eukrea.com> Acked-by: Khem Raj <raj.khem@gmail.com>
-rw-r--r--recipes/busybox/busybox-1.17.3/busybox-1.17.3-iproute.patch13
-rw-r--r--recipes/busybox/busybox-1.17.3/busybox-1.17.3-ls.patch30
-rw-r--r--recipes/busybox/busybox_1.17.3.bb4
3 files changed, 46 insertions, 1 deletions
diff --git a/recipes/busybox/busybox-1.17.3/busybox-1.17.3-iproute.patch b/recipes/busybox/busybox-1.17.3/busybox-1.17.3-iproute.patch
new file mode 100644
index 0000000000..03c749f38f
--- /dev/null
+++ b/recipes/busybox/busybox-1.17.3/busybox-1.17.3-iproute.patch
@@ -0,0 +1,13 @@
+diff -urpN busybox-1.17.3/networking/libiproute/iproute.c busybox-1.17.3-iproute/networking/libiproute/iproute.c
+--- busybox-1.17.3/networking/libiproute/iproute.c 2010-10-09 21:57:14.000000000 +0200
++++ busybox-1.17.3-iproute/networking/libiproute/iproute.c 2010-11-04 09:13:06.307919550 +0100
+@@ -791,8 +791,8 @@ static int iproute_get(char **argv)
+ }
+ req.r.rtm_dst_len = addr.bitlen;
+ }
+- argv++;
+ }
++ argv++;
+ }
+
+ if (req.r.rtm_dst_len == 0) {
diff --git a/recipes/busybox/busybox-1.17.3/busybox-1.17.3-ls.patch b/recipes/busybox/busybox-1.17.3/busybox-1.17.3-ls.patch
new file mode 100644
index 0000000000..1c4f89516e
--- /dev/null
+++ b/recipes/busybox/busybox-1.17.3/busybox-1.17.3-ls.patch
@@ -0,0 +1,30 @@
+diff -urpN busybox-1.17.3/coreutils/ls.c busybox-1.17.3-ls/coreutils/ls.c
+--- busybox-1.17.3/coreutils/ls.c 2010-10-09 21:57:13.000000000 +0200
++++ busybox-1.17.3-ls/coreutils/ls.c 2010-11-06 00:26:48.467049575 +0100
+@@ -184,7 +184,7 @@ static const unsigned opt_flags[] = {
+ LIST_INO, /* i */
+ LIST_LONG | STYLE_LONG, /* l - remember LS_DISP_HR in mask! */
+ LIST_SHORT | STYLE_SINGLE, /* 1 */
+- 0, /* g (don't show group) - handled via OPT_g */
++ 0, /* g (don't show owner) - handled via OPT_g */
+ LIST_ID_NUMERIC, /* n */
+ LIST_BLOCKS, /* s */
+ DISP_ROWS, /* x */
+@@ -621,7 +621,7 @@ static NOINLINE unsigned list_single(con
+ if (all_fmt & LIST_ID_NAME) {
+ if (option_mask32 & OPT_g) {
+ column += printf("%-8.8s ",
+- get_cached_username(dn->dstat.st_uid));
++ get_cached_groupname(dn->dstat.st_gid));
+ } else {
+ column += printf("%-8.8s %-8.8s ",
+ get_cached_username(dn->dstat.st_uid),
+@@ -631,7 +631,7 @@ static NOINLINE unsigned list_single(con
+ #endif
+ if (all_fmt & LIST_ID_NUMERIC) {
+ if (option_mask32 & OPT_g)
+- column += printf("%-8u ", (int) dn->dstat.st_uid);
++ column += printf("%-8u ", (int) dn->dstat.st_gid);
+ else
+ column += printf("%-8u %-8u ",
+ (int) dn->dstat.st_uid,
diff --git a/recipes/busybox/busybox_1.17.3.bb b/recipes/busybox/busybox_1.17.3.bb
index 6956bde545..f1a0b74302 100644
--- a/recipes/busybox/busybox_1.17.3.bb
+++ b/recipes/busybox/busybox_1.17.3.bb
@@ -1,10 +1,12 @@
require busybox_1.1x.inc
-PR = "${INC_PR}.1"
+PR = "${INC_PR}.2"
SRC_URI += "\
file://busybox-1.17.3-sort.patch \
file://busybox-1.17.3-dnsd.patch \
file://busybox-1.17.3-unicode.patch \
+ file://busybox-1.17.3-iproute.patch \
+ file://busybox-1.17.3-ls.patch \
"
SRC_URI[md5sum] = "a2ce1a951571da8c6e0eaf75b1acef60"