aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2009-02-18 16:23:03 -0800
committerKhem Raj <raj.khem@gmail.com>2009-02-18 16:23:03 -0800
commite4eb9aab1d584978e9824261c6ecd50784b34d46 (patch)
tree27209dd5e34127670ba84bf2a367886da6110f0d
parent4e49aa53f5915890302c8dfbfbf8f38be610a30e (diff)
downloadopenembedded-e4eb9aab1d584978e9824261c6ecd50784b34d46.tar.gz
popt-1.7: Fix build with new libtool
-rw-r--r--packages/popt/popt-1.7/mkinstalldirs.patch566
-rw-r--r--packages/popt/popt_1.7.bb12
2 files changed, 578 insertions, 0 deletions
diff --git a/packages/popt/popt-1.7/mkinstalldirs.patch b/packages/popt/popt-1.7/mkinstalldirs.patch
new file mode 100644
index 0000000000..2d791f2d30
--- /dev/null
+++ b/packages/popt/popt-1.7/mkinstalldirs.patch
@@ -0,0 +1,566 @@
+Index: popt-1.7/po/Makefile.in.in
+===================================================================
+--- popt-1.7.orig/po/Makefile.in.in 2002-08-11 10:17:55.000000000 -0700
++++ popt-1.7/po/Makefile.in.in 2009-02-18 15:49:21.000000000 -0800
+@@ -1,17 +1,19 @@
+-# Makefile for program source directory in GNU NLS utilities package.
+-# Copyright (C) 1995-1997, 2000, 2001 by Ulrich Drepper <drepper@gnu.ai.mit.edu>
++# Makefile for PO directory in any package using GNU gettext.
++# Copyright (C) 1995-1997, 2000-2007 by Ulrich Drepper <drepper@gnu.ai.mit.edu>
+ #
+-# This file file be copied and used freely without restrictions. It can
+-# be used in projects which are not available under the GNU Public License
+-# but which still want to provide support for the GNU gettext functionality.
+-# Please note that the actual code is *not* freely available.
++# This file can be copied and used freely without restrictions. It can
++# be used in projects which are not available under the GNU General Public
++# License but which still want to provide support for the GNU gettext
++# functionality.
++# Please note that the actual code of GNU gettext is covered by the GNU
++# General Public License and is *not* in the public domain.
++#
++# Origin: gettext-0.17
++GETTEXT_MACRO_VERSION = 0.17
+
+ PACKAGE = @PACKAGE@
+ VERSION = @VERSION@
+-
+-# These two variables depend on the location of this directory.
+-subdir = po
+-top_builddir = ..
++PACKAGE_BUGREPORT = @PACKAGE_BUGREPORT@
+
+ SHELL = /bin/sh
+ @SET_MAKE@
+@@ -22,125 +24,315 @@
+
+ prefix = @prefix@
+ exec_prefix = @exec_prefix@
++datarootdir = @datarootdir@
+ datadir = @datadir@
+-localedir = $(datadir)/locale
++localedir = @localedir@
+ gettextsrcdir = $(datadir)/gettext/po
+
+ INSTALL = @INSTALL@
+ INSTALL_DATA = @INSTALL_DATA@
+-MKINSTALLDIRS = @MKINSTALLDIRS@
+-mkinstalldirs = $(SHELL) `case "$(MKINSTALLDIRS)" in /*) echo "$(MKINSTALLDIRS)" ;; *) echo "$(top_builddir)/$(MKINSTALLDIRS)" ;; esac`
+
+-CC = @CC@
+-GMSGFMT = @GMSGFMT@
+-MSGFMT = @MSGFMT@
+-XGETTEXT = @XGETTEXT@
++# We use $(mkdir_p).
++# In automake <= 1.9.x, $(mkdir_p) is defined either as "mkdir -p --" or as
++# "$(mkinstalldirs)" or as "$(install_sh) -d". For these automake versions,
++# @install_sh@ does not start with $(SHELL), so we add it.
++# In automake >= 1.10, @mkdir_p@ is derived from ${MKDIR_P}, which is defined
++# either as "/path/to/mkdir -p" or ".../install-sh -c -d". For these automake
++# versions, $(mkinstalldirs) and $(install_sh) are unused.
++mkinstalldirs = $(SHELL) @install_sh@ -d
++install_sh = $(SHELL) @install_sh@
++MKDIR_P = @MKDIR_P@
++mkdir_p = @mkdir_p@
++
++GMSGFMT_ = @GMSGFMT@
++GMSGFMT_no = @GMSGFMT@
++GMSGFMT_yes = @GMSGFMT_015@
++GMSGFMT = $(GMSGFMT_$(USE_MSGCTXT))
++MSGFMT_ = @MSGFMT@
++MSGFMT_no = @MSGFMT@
++MSGFMT_yes = @MSGFMT_015@
++MSGFMT = $(MSGFMT_$(USE_MSGCTXT))
++XGETTEXT_ = @XGETTEXT@
++XGETTEXT_no = @XGETTEXT@
++XGETTEXT_yes = @XGETTEXT_015@
++XGETTEXT = $(XGETTEXT_$(USE_MSGCTXT))
+ MSGMERGE = msgmerge
+-
+-DEFS = @DEFS@
+-CFLAGS = @CFLAGS@
+-CPPFLAGS = @CPPFLAGS@
+-
+-INCLUDES = -I.. -I$(top_srcdir)/intl
+-
+-COMPILE = $(CC) -c $(DEFS) $(INCLUDES) $(CPPFLAGS) $(CFLAGS) $(XCFLAGS)
++MSGMERGE_UPDATE = @MSGMERGE@ --update
++MSGINIT = msginit
++MSGCONV = msgconv
++MSGFILTER = msgfilter
+
+ POFILES = @POFILES@
+ GMOFILES = @GMOFILES@
+-DISTFILES = ChangeLog Makefile.in.in POTFILES.in $(PACKAGE).pot \
+-$(POFILES) $(GMOFILES)
++UPDATEPOFILES = @UPDATEPOFILES@
++DUMMYPOFILES = @DUMMYPOFILES@
++DISTFILES.common = Makefile.in.in remove-potcdate.sin \
++$(DISTFILES.common.extra1) $(DISTFILES.common.extra2) $(DISTFILES.common.extra3)
++DISTFILES = $(DISTFILES.common) Makevars POTFILES.in \
++$(POFILES) $(GMOFILES) \
++$(DISTFILES.extra1) $(DISTFILES.extra2) $(DISTFILES.extra3)
+
+ POTFILES = \
+
+ CATALOGS = @CATALOGS@
+
+-.SUFFIXES:
+-.SUFFIXES: .c .o .po .pox .gmo .mo
+-
+-.c.o:
+- $(COMPILE) $<
++# Makevars gets inserted here. (Don't remove this line!)
+
+-.po.pox:
+- $(MAKE) $(PACKAGE).pot
+- $(MSGMERGE) $< $(srcdir)/$(PACKAGE).pot -o $*.pox
++.SUFFIXES:
++.SUFFIXES: .po .gmo .mo .sed .sin .nop .po-create .po-update
+
+ .po.mo:
+- $(MSGFMT) -o $@ $<
++ @echo "$(MSGFMT) -c -o $@ $<"; \
++ $(MSGFMT) -c -o t-$@ $< && mv t-$@ $@
+
+ .po.gmo:
+- file=$(srcdir)/`echo $* | sed 's,.*/,,'`.gmo \
+- && rm -f $$file && $(GMSGFMT) --statistics -o $$file $<
++ @lang=`echo $* | sed -e 's,.*/,,'`; \
++ test "$(srcdir)" = . && cdcmd="" || cdcmd="cd $(srcdir) && "; \
++ echo "$${cdcmd}rm -f $${lang}.gmo && $(GMSGFMT) -c --statistics -o $${lang}.gmo $${lang}.po"; \
++ cd $(srcdir) && rm -f $${lang}.gmo && $(GMSGFMT) -c --statistics -o t-$${lang}.gmo $${lang}.po && mv t-$${lang}.gmo $${lang}.gmo
++
++.sin.sed:
++ sed -e '/^#/d' $< > t-$@
++ mv t-$@ $@
+
+
+-all: all-@USE_NLS@
++all: check-macro-version all-@USE_NLS@
+
+-all-yes: $(CATALOGS)
++all-yes: stamp-po
+ all-no:
+
+-# Note: Target 'all' must not depend on target '$(srcdir)/$(PACKAGE).pot',
++# Ensure that the gettext macros and this Makefile.in.in are in sync.
++check-macro-version:
++ @test "$(GETTEXT_MACRO_VERSION)" = "@GETTEXT_MACRO_VERSION@" \
++ || { echo "*** error: gettext infrastructure mismatch: using a Makefile.in.in from gettext version $(GETTEXT_MACRO_VERSION) but the autoconf macros are from gettext version @GETTEXT_MACRO_VERSION@" 1>&2; \
++ exit 1; \
++ }
++
++# $(srcdir)/$(DOMAIN).pot is only created when needed. When xgettext finds no
++# internationalized messages, no $(srcdir)/$(DOMAIN).pot is created (because
++# we don't want to bother translators with empty POT files). We assume that
++# LINGUAS is empty in this case, i.e. $(POFILES) and $(GMOFILES) are empty.
++# In this case, stamp-po is a nop (i.e. a phony target).
++
++# stamp-po is a timestamp denoting the last time at which the CATALOGS have
++# been loosely updated. Its purpose is that when a developer or translator
++# checks out the package via CVS, and the $(DOMAIN).pot file is not in CVS,
++# "make" will update the $(DOMAIN).pot and the $(CATALOGS), but subsequent
++# invocations of "make" will do nothing. This timestamp would not be necessary
++# if updating the $(CATALOGS) would always touch them; however, the rule for
++# $(POFILES) has been designed to not touch files that don't need to be
++# changed.
++stamp-po: $(srcdir)/$(DOMAIN).pot
++ test ! -f $(srcdir)/$(DOMAIN).pot || \
++ test -z "$(GMOFILES)" || $(MAKE) $(GMOFILES)
++ @test ! -f $(srcdir)/$(DOMAIN).pot || { \
++ echo "touch stamp-po" && \
++ echo timestamp > stamp-poT && \
++ mv stamp-poT stamp-po; \
++ }
++
++# Note: Target 'all' must not depend on target '$(DOMAIN).pot-update',
+ # otherwise packages like GCC can not be built if only parts of the source
+ # have been downloaded.
+
+-$(srcdir)/$(PACKAGE).pot: $(POTFILES) $(srcdir)/POTFILES.in
+- $(XGETTEXT) --default-domain=$(PACKAGE) --directory=$(top_srcdir) \
+- --add-comments --keyword=_ --keyword=N_ --keyword=POPT_ \
+- --files-from=$(srcdir)/POTFILES.in \
+- && test ! -f $(PACKAGE).po \
+- || ( rm -f $(srcdir)/$(PACKAGE).pot \
+- && mv $(PACKAGE).po $(srcdir)/$(PACKAGE).pot )
++# This target rebuilds $(DOMAIN).pot; it is an expensive operation.
++# Note that $(DOMAIN).pot is not touched if it doesn't need to be changed.
++$(DOMAIN).pot-update: $(POTFILES) $(srcdir)/POTFILES.in remove-potcdate.sed
++ if LC_ALL=C grep 'GNU @PACKAGE@' $(top_srcdir)/* 2>/dev/null | grep -v 'libtool:' >/dev/null; then \
++ package_gnu='GNU '; \
++ else \
++ package_gnu=''; \
++ fi; \
++ if test -n '$(MSGID_BUGS_ADDRESS)' || test '$(PACKAGE_BUGREPORT)' = '@'PACKAGE_BUGREPORT'@'; then \
++ msgid_bugs_address='$(MSGID_BUGS_ADDRESS)'; \
++ else \
++ msgid_bugs_address='$(PACKAGE_BUGREPORT)'; \
++ fi; \
++ case `$(XGETTEXT) --version | sed 1q | sed -e 's,^[^0-9]*,,'` in \
++ '' | 0.[0-9] | 0.[0-9].* | 0.1[0-5] | 0.1[0-5].* | 0.16 | 0.16.[0-1]*) \
++ $(XGETTEXT) --default-domain=$(DOMAIN) --directory=$(top_srcdir) \
++ --add-comments=TRANSLATORS: $(XGETTEXT_OPTIONS) @XGETTEXT_EXTRA_OPTIONS@ \
++ --files-from=$(srcdir)/POTFILES.in \
++ --copyright-holder='$(COPYRIGHT_HOLDER)' \
++ --msgid-bugs-address="$$msgid_bugs_address" \
++ ;; \
++ *) \
++ $(XGETTEXT) --default-domain=$(DOMAIN) --directory=$(top_srcdir) \
++ --add-comments=TRANSLATORS: $(XGETTEXT_OPTIONS) @XGETTEXT_EXTRA_OPTIONS@ \
++ --files-from=$(srcdir)/POTFILES.in \
++ --copyright-holder='$(COPYRIGHT_HOLDER)' \
++ --package-name="$${package_gnu}@PACKAGE@" \
++ --package-version='@VERSION@' \
++ --msgid-bugs-address="$$msgid_bugs_address" \
++ ;; \
++ esac
++ test ! -f $(DOMAIN).po || { \
++ if test -f $(srcdir)/$(DOMAIN).pot; then \
++ sed -f remove-potcdate.sed < $(srcdir)/$(DOMAIN).pot > $(DOMAIN).1po && \
++ sed -f remove-potcdate.sed < $(DOMAIN).po > $(DOMAIN).2po && \
++ if cmp $(DOMAIN).1po $(DOMAIN).2po >/dev/null 2>&1; then \
++ rm -f $(DOMAIN).1po $(DOMAIN).2po $(DOMAIN).po; \
++ else \
++ rm -f $(DOMAIN).1po $(DOMAIN).2po $(srcdir)/$(DOMAIN).pot && \
++ mv $(DOMAIN).po $(srcdir)/$(DOMAIN).pot; \
++ fi; \
++ else \
++ mv $(DOMAIN).po $(srcdir)/$(DOMAIN).pot; \
++ fi; \
++ }
++
++# This rule has no dependencies: we don't need to update $(DOMAIN).pot at
++# every "make" invocation, only create it when it is missing.
++# Only "make $(DOMAIN).pot-update" or "make dist" will force an update.
++$(srcdir)/$(DOMAIN).pot:
++ $(MAKE) $(DOMAIN).pot-update
++
++# This target rebuilds a PO file if $(DOMAIN).pot has changed.
++# Note that a PO file is not touched if it doesn't need to be changed.
++$(POFILES): $(srcdir)/$(DOMAIN).pot
++ @lang=`echo $@ | sed -e 's,.*/,,' -e 's/\.po$$//'`; \
++ if test -f "$(srcdir)/$${lang}.po"; then \
++ test "$(srcdir)" = . && cdcmd="" || cdcmd="cd $(srcdir) && "; \
++ echo "$${cdcmd}$(MSGMERGE_UPDATE) $${lang}.po $(DOMAIN).pot"; \
++ cd $(srcdir) && $(MSGMERGE_UPDATE) $${lang}.po $(DOMAIN).pot; \
++ else \
++ $(MAKE) $${lang}.po-create; \
++ fi
+
+
+ install: install-exec install-data
+ install-exec:
+ install-data: install-data-@USE_NLS@
+- if test "$(PACKAGE)" = "gettext"; then \
+- $(mkinstalldirs) $(DESTDIR)$(gettextsrcdir); \
+- $(INSTALL_DATA) $(srcdir)/Makefile.in.in \
+- $(DESTDIR)$(gettextsrcdir)/Makefile.in.in; \
++ if test "$(PACKAGE)" = "gettext-tools"; then \
++ $(mkdir_p) $(DESTDIR)$(gettextsrcdir); \
++ for file in $(DISTFILES.common) Makevars.template; do \
++ $(INSTALL_DATA) $(srcdir)/$$file \
++ $(DESTDIR)$(gettextsrcdir)/$$file; \
++ done; \
++ for file in Makevars; do \
++ rm -f $(DESTDIR)$(gettextsrcdir)/$$file; \
++ done; \
+ else \
+ : ; \
+ fi
+ install-data-no: all
+ install-data-yes: all
+- $(mkinstalldirs) $(DESTDIR)$(datadir)
++ $(mkdir_p) $(DESTDIR)$(datadir)
+ @catalogs='$(CATALOGS)'; \
+ for cat in $$catalogs; do \
+ cat=`basename $$cat`; \
+- lang=`echo $$cat | sed 's/\.gmo$$//'`; \
++ lang=`echo $$cat | sed -e 's/\.gmo$$//'`; \
+ dir=$(localedir)/$$lang/LC_MESSAGES; \
+- $(mkinstalldirs) $(DESTDIR)$$dir; \
+- if test -r $$cat; then \
+- $(INSTALL_DATA) $$cat $(DESTDIR)$$dir/$(PACKAGE).mo; \
+- echo "installing $$cat as $(DESTDIR)$$dir/$(PACKAGE).mo"; \
+- else \
+- $(INSTALL_DATA) $(srcdir)/$$cat $(DESTDIR)$$dir/$(PACKAGE).mo; \
+- echo "installing $(srcdir)/$$cat as" \
+- "$(DESTDIR)$$dir/$(PACKAGE).mo"; \
+- fi; \
++ $(mkdir_p) $(DESTDIR)$$dir; \
++ if test -r $$cat; then realcat=$$cat; else realcat=$(srcdir)/$$cat; fi; \
++ $(INSTALL_DATA) $$realcat $(DESTDIR)$$dir/$(DOMAIN).mo; \
++ echo "installing $$realcat as $(DESTDIR)$$dir/$(DOMAIN).mo"; \
++ for lc in '' $(EXTRA_LOCALE_CATEGORIES); do \
++ if test -n "$$lc"; then \
++ if (cd $(DESTDIR)$(localedir)/$$lang && LC_ALL=C ls -l -d $$lc 2>/dev/null) | grep ' -> ' >/dev/null; then \
++ link=`cd $(DESTDIR)$(localedir)/$$lang && LC_ALL=C ls -l -d $$lc | sed -e 's/^.* -> //'`; \
++ mv $(DESTDIR)$(localedir)/$$lang/$$lc $(DESTDIR)$(localedir)/$$lang/$$lc.old; \
++ mkdir $(DESTDIR)$(localedir)/$$lang/$$lc; \
++ (cd $(DESTDIR)$(localedir)/$$lang/$$lc.old && \
++ for file in *; do \
++ if test -f $$file; then \
++ ln -s ../$$link/$$file $(DESTDIR)$(localedir)/$$lang/$$lc/$$file; \
++ fi; \
++ done); \
++ rm -f $(DESTDIR)$(localedir)/$$lang/$$lc.old; \
++ else \
++ if test -d $(DESTDIR)$(localedir)/$$lang/$$lc; then \
++ :; \
++ else \
++ rm -f $(DESTDIR)$(localedir)/$$lang/$$lc; \
++ mkdir $(DESTDIR)$(localedir)/$$lang/$$lc; \
++ fi; \
++ fi; \
++ rm -f $(DESTDIR)$(localedir)/$$lang/$$lc/$(DOMAIN).mo; \
++ ln -s ../LC_MESSAGES/$(DOMAIN).mo $(DESTDIR)$(localedir)/$$lang/$$lc/$(DOMAIN).mo 2>/dev/null || \
++ ln $(DESTDIR)$(localedir)/$$lang/LC_MESSAGES/$(DOMAIN).mo $(DESTDIR)$(localedir)/$$lang/$$lc/$(DOMAIN).mo 2>/dev/null || \
++ cp -p $(DESTDIR)$(localedir)/$$lang/LC_MESSAGES/$(DOMAIN).mo $(DESTDIR)$(localedir)/$$lang/$$lc/$(DOMAIN).mo; \
++ echo "installing $$realcat link as $(DESTDIR)$(localedir)/$$lang/$$lc/$(DOMAIN).mo"; \
++ fi; \
++ done; \
+ done
+
+-# Define this as empty until I found a useful application.
+-installcheck:
++install-strip: install
+
+-uninstall:
+- catalogs='$(CATALOGS)'; \
++installdirs: installdirs-exec installdirs-data
++installdirs-exec:
++installdirs-data: installdirs-data-@USE_NLS@
++ if test "$(PACKAGE)" = "gettext-tools"; then \
++ $(mkdir_p) $(DESTDIR)$(gettextsrcdir); \
++ else \
++ : ; \
++ fi
++installdirs-data-no:
++installdirs-data-yes:
++ $(mkdir_p) $(DESTDIR)$(datadir)
++ @catalogs='$(CATALOGS)'; \
+ for cat in $$catalogs; do \
+ cat=`basename $$cat`; \
+- lang=`echo $$cat | sed 's/\.gmo$$//'`; \
+- rm -f $(DESTDIR)$(localedir)/$$lang/LC_MESSAGES/$(PACKAGE).mo; \
++ lang=`echo $$cat | sed -e 's/\.gmo$$//'`; \
++ dir=$(localedir)/$$lang/LC_MESSAGES; \
++ $(mkdir_p) $(DESTDIR)$$dir; \
++ for lc in '' $(EXTRA_LOCALE_CATEGORIES); do \
++ if test -n "$$lc"; then \
++ if (cd $(DESTDIR)$(localedir)/$$lang && LC_ALL=C ls -l -d $$lc 2>/dev/null) | grep ' -> ' >/dev/null; then \
++ link=`cd $(DESTDIR)$(localedir)/$$lang && LC_ALL=C ls -l -d $$lc | sed -e 's/^.* -> //'`; \
++ mv $(DESTDIR)$(localedir)/$$lang/$$lc $(DESTDIR)$(localedir)/$$lang/$$lc.old; \
++ mkdir $(DESTDIR)$(localedir)/$$lang/$$lc; \
++ (cd $(DESTDIR)$(localedir)/$$lang/$$lc.old && \
++ for file in *; do \
++ if test -f $$file; then \
++ ln -s ../$$link/$$file $(DESTDIR)$(localedir)/$$lang/$$lc/$$file; \
++ fi; \
++ done); \
++ rm -f $(DESTDIR)$(localedir)/$$lang/$$lc.old; \
++ else \
++ if test -d $(DESTDIR)$(localedir)/$$lang/$$lc; then \
++ :; \
++ else \
++ rm -f $(DESTDIR)$(localedir)/$$lang/$$lc; \
++ mkdir $(DESTDIR)$(localedir)/$$lang/$$lc; \
++ fi; \
++ fi; \
++ fi; \
++ done; \
+ done
+- if test "$(PACKAGE)" = "gettext"; then \
+- rm -f $(DESTDIR)$(gettextsrcdir)/Makefile.in.in; \
++
++# Define this as empty until I found a useful application.
++installcheck:
++
++uninstall: uninstall-exec uninstall-data
++uninstall-exec:
++uninstall-data: uninstall-data-@USE_NLS@
++ if test "$(PACKAGE)" = "gettext-tools"; then \
++ for file in $(DISTFILES.common) Makevars.template; do \
++ rm -f $(DESTDIR)$(gettextsrcdir)/$$file; \
++ done; \
+ else \
+ : ; \
+ fi
++uninstall-data-no:
++uninstall-data-yes:
++ catalogs='$(CATALOGS)'; \
++ for cat in $$catalogs; do \
++ cat=`basename $$cat`; \
++ lang=`echo $$cat | sed -e 's/\.gmo$$//'`; \
++ for lc in LC_MESSAGES $(EXTRA_LOCALE_CATEGORIES); do \
++ rm -f $(DESTDIR)$(localedir)/$$lang/$$lc/$(DOMAIN).mo; \
++ done; \
++ done
+
+ check: all
+
+-dvi info tags TAGS ID:
++info dvi ps pdf html tags TAGS ctags CTAGS ID:
+
+ mostlyclean:
+- rm -f core core.* *.pox $(PACKAGE).po *.new.po
++ rm -f remove-potcdate.sed
++ rm -f stamp-poT
++ rm -f core core.* $(DOMAIN).po $(DOMAIN).1po $(DOMAIN).2po *.new.po
+ rm -fr *.o
+
+ clean: mostlyclean
+@@ -151,45 +343,86 @@
+ maintainer-clean: distclean
+ @echo "This command is intended for maintainers to use;"
+ @echo "it deletes files that may require special tools to rebuild."
+- rm -f $(GMOFILES)
++ rm -f stamp-po $(GMOFILES)
+
+ distdir = $(top_builddir)/$(PACKAGE)-$(VERSION)/$(subdir)
+ dist distdir:
+ $(MAKE) update-po
+ @$(MAKE) dist2
+ # This is a separate target because 'update-po' must be executed before.
+-dist2: $(DISTFILES)
++dist2: stamp-po $(DISTFILES)
+ dists="$(DISTFILES)"; \
++ if test "$(PACKAGE)" = "gettext-tools"; then \
++ dists="$$dists Makevars.template"; \
++ fi; \
++ if test -f $(srcdir)/$(DOMAIN).pot; then \
++ dists="$$dists $(DOMAIN).pot stamp-po"; \
++ fi; \
++ if test -f $(srcdir)/ChangeLog; then \
++ dists="$$dists ChangeLog"; \
++ fi; \
++ for i in 0 1 2 3 4 5 6 7 8 9; do \
++ if test -f $(srcdir)/ChangeLog.$$i; then \
++ dists="$$dists ChangeLog.$$i"; \
++ fi; \
++ done; \
++ if test -f $(srcdir)/LINGUAS; then dists="$$dists LINGUAS"; fi; \
+ for file in $$dists; do \
+- if test -f $$file; then dir=.; else dir=$(srcdir); fi; \
+- cp -p $$dir/$$file $(distdir); \
++ if test -f $$file; then \
++ cp -p $$file $(distdir) || exit 1; \
++ else \
++ cp -p $(srcdir)/$$file $(distdir) || exit 1; \
++ fi; \
+ done
+
+ update-po: Makefile
+- $(MAKE) $(PACKAGE).pot
+- if test "$(PACKAGE)" = "gettext"; then PATH=`pwd`/../src:$$PATH; fi; \
++ $(MAKE) $(DOMAIN).pot-update
++ test -z "$(UPDATEPOFILES)" || $(MAKE) $(UPDATEPOFILES)
++ $(MAKE) update-gmo
++
++# General rule for creating PO files.
++
++.nop.po-create:
++ @lang=`echo $@ | sed -e 's/\.po-create$$//'`; \
++ echo "File $$lang.po does not exist. If you are a translator, you can create it through 'msginit'." 1>&2; \
++ exit 1
++
++# General rule for updating PO files.
++
++.nop.po-update:
++ @lang=`echo $@ | sed -e 's/\.po-update$$//'`; \
++ if test "$(PACKAGE)" = "gettext-tools"; then PATH=`pwd`/../src:$$PATH; fi; \
++ tmpdir=`pwd`; \
++ echo "$$lang:"; \
++ test "$(srcdir)" = . && cdcmd="" || cdcmd="cd $(srcdir) && "; \
++ echo "$${cdcmd}$(MSGMERGE) $$lang.po $(DOMAIN).pot -o $$lang.new.po"; \
+ cd $(srcdir); \
+- catalogs='$(GMOFILES)'; \
+- for cat in $$catalogs; do \
+- cat=`basename $$cat`; \
+- lang=`echo $$cat | sed 's/\.gmo$$//'`; \
+- echo "$$lang:"; \
+- if $(MSGMERGE) $$lang.po $(PACKAGE).pot -o $$lang.new.po; then \
+- mv -f $$lang.new.po $$lang.po; \
++ if $(MSGMERGE) $$lang.po $(DOMAIN).pot -o $$tmpdir/$$lang.new.po; then \
++ if cmp $$lang.po $$tmpdir/$$lang.new.po >/dev/null 2>&1; then \
++ rm -f $$tmpdir/$$lang.new.po; \
+ else \
+- echo "msgmerge for $$cat failed!"; \
+- rm -f $$lang.new.po; \
++ if mv -f $$tmpdir/$$lang.new.po $$lang.po; then \
++ :; \
++ else \
++ echo "msgmerge for $$lang.po failed: cannot move $$tmpdir/$$lang.new.po to $$lang.po" 1>&2; \
++ exit 1; \
++ fi; \
+ fi; \
+- done
+- $(MAKE) update-gmo
++ else \
++ echo "msgmerge for $$lang.po failed!" 1>&2; \
++ rm -f $$tmpdir/$$lang.new.po; \
++ fi
++
++$(DUMMYPOFILES):
+
+ update-gmo: Makefile $(GMOFILES)
+ @:
+
+-Makefile: Makefile.in.in $(top_builddir)/config.status POTFILES.in
++Makefile: Makefile.in.in Makevars $(top_builddir)/config.status @POMAKEFILEDEPS@
+ cd $(top_builddir) \
+- && CONFIG_FILES=$(subdir)/$@.in CONFIG_HEADERS= \
+- $(SHELL) ./config.status
++ && $(SHELL) ./config.status $(subdir)/$@.in po-directories
++
++force:
+
+ # Tell versions [3.59,3.63) of GNU make not to export all variables.
+ # Otherwise a system limit (for SysV at least) may be exceeded.
+Index: popt-1.7/po/Makevars
+===================================================================
+--- /dev/null 1970-01-01 00:00:00.000000000 +0000
++++ popt-1.7/po/Makevars 2009-02-18 16:08:01.000000000 -0800
+@@ -0,0 +1,41 @@
++# Makefile variables for PO directory in any package using GNU gettext.
++
++# Usually the message domain is the same as the package name.
++DOMAIN = $(PACKAGE)
++
++# These two variables depend on the location of this directory.
++subdir = po
++top_builddir = ..
++
++# These options get passed to xgettext.
++XGETTEXT_OPTIONS = --keyword=_ --keyword=N_ --keyword=POPT_
++
++# This is the copyright holder that gets inserted into the header of the
++# $(DOMAIN).pot file. Set this to the copyright holder of the surrounding
++# package. (Note that the msgstr strings, extracted from the package's
++# sources, belong to the copyright holder of the package.) Translators are
++# expected to transfer the copyright for their translations to this person
++# or entity, or to disclaim their copyright. The empty string stands for
++# the public domain; in this case the translators are expected to disclaim
++# their copyright.
++COPYRIGHT_HOLDER =
++
++# This is the email address or URL to which the translators shall report
++# bugs in the untranslated strings:
++# - Strings which are not entire sentences, see the maintainer guidelines
++# in the GNU gettext documentation, section 'Preparing Strings'.
++# - Strings which use unclear terms or require additional context to be
++# understood.
++# - Strings which make invalid assumptions about notation of date, time or
++# money.
++# - Pluralisation problems.
++# - Incorrect English spelling.
++# - Incorrect formatting.
++# It can be your email address, or a mailing list address where translators
++# can write to without being subscribed, or the URL of a web page through
++# which the translators can contact you.
++MSGID_BUGS_ADDRESS = <popt-devel@rpm5.org>
++
++# This is the list of locale categories, beyond LC_MESSAGES, for which the
++# message catalogs shall be used. It is usually empty.
++EXTRA_LOCALE_CATEGORIES =
diff --git a/packages/popt/popt_1.7.bb b/packages/popt/popt_1.7.bb
index 313e31b8fc..0b688c6217 100644
--- a/packages/popt/popt_1.7.bb
+++ b/packages/popt/popt_1.7.bb
@@ -1,5 +1,7 @@
require popt.inc
+PR = "r1"
+
DEPENDS = "gettext virtual/libintl"
inherit autotools autotools_stage
@@ -8,4 +10,14 @@ SRC_URI = "\
http://rpm.org/releases/historical/rpm-4.1.x/popt-${PV}.tar.gz \
file://m4.patch;patch=1 \
file://intl.patch;patch=1 \
+ file://mkinstalldirs.patch;patch=1 \
"
+
+do_configure() {
+ gnu-configize
+ aclocal
+ libtoolize --copy --force
+ automake --add-missing
+ autoreconf
+ oe_runconf
+}