aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorThomas Zimmermann <ml@vdm-design.de>2010-02-09 21:26:44 +0000
committerMartin Jansa <Martin.Jansa@gmail.com>2010-02-10 07:43:04 +0100
commitaefc8c29f6f6014c20c86593cf15ffd69c28b1a8 (patch)
tree20880c147d5ef307b5f5a6f365dd689f9a715352
parent65b63857c49eeb50877c4530201e624852d1c050 (diff)
downloadopenembedded-aefc8c29f6f6014c20c86593cf15ffd69c28b1a8.tar.gz
e-wm: fix flaunch in illume (SHR Bug: #821)
* change back number of flaunch buttons from 10 to 3 * change back categorie from System to Bar Signed-off-by: Martin Jansa <Martin.Jansa@gmail.com>
-rw-r--r--recipes/e17/e-wm/illume-flaunch-fix.patch15
-rw-r--r--recipes/e17/e-wm_svn.bb3
2 files changed, 17 insertions, 1 deletions
diff --git a/recipes/e17/e-wm/illume-flaunch-fix.patch b/recipes/e17/e-wm/illume-flaunch-fix.patch
new file mode 100644
index 0000000000..5aab3b5dc0
--- /dev/null
+++ b/recipes/e17/e-wm/illume-flaunch-fix.patch
@@ -0,0 +1,15 @@
+--- e/src/modules/illume/e_flaunch.c 2010-02-09 22:33:25.000000000 +0100
++++ e/src/modules/illume/e_flaunch.c 2010-02-09 22:33:25.000000000 +0100
+@@ -97,10 +97,10 @@
+ int num = 0, max, count;
+
+ // FIXME: 3 should become config here
+- max = 10;
++ max = 3;
+ // for now just look for any apps in "category" 'Bar' and add the first 3
+ // FIXME: category should be configurable...
+- bar_desktops = efreet_util_desktop_category_list("System");
++ bar_desktops = efreet_util_desktop_category_list("Bar");
+ if (bar_desktops)
+ {
+ Efreet_Desktop *desktop;
diff --git a/recipes/e17/e-wm_svn.bb b/recipes/e17/e-wm_svn.bb
index 602f78e335..043cc51d58 100644
--- a/recipes/e17/e-wm_svn.bb
+++ b/recipes/e17/e-wm_svn.bb
@@ -3,7 +3,7 @@ DEPENDS = "eet evas ecore edje efreet edbus"
LICENSE = "MIT BSD"
SRCNAME = "e"
PV = "0.16.999.060+svnr${SRCPV}"
-PR = "r10"
+PR = "r11"
inherit e update-alternatives
@@ -20,6 +20,7 @@ SRC_URI_append_openmoko = " file://illume-disable-screensaver.patch;patch=1"
SRC_URI_append_shr = " \
file://illume-disable-screensaver.patch;patch=1 \
file://wizard-module-skipping.patch;patch=1 \
+ file://illume-flaunch-fix.patch;patch=1 \
"
EXTRA_OECONF = "\