aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaul Sokolovsky <pmiscml@gmail.com>2007-12-19 02:03:27 +0000
committerPaul Sokolovsky <pmiscml@gmail.com>2007-12-19 02:03:27 +0000
commit6fab39b44dfe4abb7a68197d9eb5387190462b06 (patch)
treecd40a57eeb825312e8b6ab71964b18a76e59745e
parentc862df0a0620c8fbce67ff0c795f1489a99718ca (diff)
parentcd2cba1e48368ffa7606af8df17d39023829d69c (diff)
downloadopenembedded-6fab39b44dfe4abb7a68197d9eb5387190462b06.tar.gz
merge of '2dba387308c2873b665bd04502559a10e5fe59c0'
and '3a104d2a86c0e7a130667498d91801495e6ee27d'
-rw-r--r--conf/distro/angstrom-2008.1.conf12
-rwxr-xr-xcontrib/angstrom/build-release.sh25
-rw-r--r--packages/avahi/avahi.inc3
-rw-r--r--packages/avahi/avahi_0.6.22.bb5
-rw-r--r--packages/gtk-webcore/midori_0.0.15.bb11
-rw-r--r--packages/images/poky-base-image.bb29
-rw-r--r--packages/libxml/files/no-testapi.patch51
-rw-r--r--packages/matchbox-desktop-sato/.mtn2git_empty0
-rw-r--r--packages/matchbox-desktop-sato/matchbox-desktop-sato_svn.bb14
-rw-r--r--packages/matchbox-sato/.mtn2git_empty0
-rw-r--r--packages/matchbox-sato/matchbox-sato/.mtn2git_empty0
-rw-r--r--packages/matchbox-sato/matchbox-sato/etc/.mtn2git_empty0
-rw-r--r--packages/matchbox-sato/matchbox-sato/etc/matchbox/.mtn2git_empty0
-rwxr-xr-xpackages/matchbox-sato/matchbox-sato/etc/matchbox/session15
-rw-r--r--packages/matchbox-sato/matchbox-sato/matchbox-session24
-rw-r--r--packages/matchbox-sato/matchbox-sato_0.1.bb29
16 files changed, 146 insertions, 72 deletions
diff --git a/conf/distro/angstrom-2008.1.conf b/conf/distro/angstrom-2008.1.conf
index 145c463751..17b4f53453 100644
--- a/conf/distro/angstrom-2008.1.conf
+++ b/conf/distro/angstrom-2008.1.conf
@@ -35,14 +35,6 @@ DISTRO_TYPE ?= "debug"
# Also, it appears that no locales fit in 16Mb for now. "C" locale rules!
IMAGE_LINGUAS = '${@base_less_or_equal("ROOT_FLASH_SIZE", "16", "", "en-gb", d)}'
-FEED_URIS += " \
- no-arch##${ANGSTROM_URI}/unstable/feed/all \
- base##${ANGSTROM_URI}/unstable/feed/${FEED_ARCH}/base \
- perl##${ANGSTROM_URI}/unstable/feed/${FEED_ARCH}/perl \
- python##${ANGSTROM_URI}/unstable/feed/${FEED_ARCH}/python \
- debug##${ANGSTROM_URI}/unstable/feed/${FEED_ARCH}/debug \
- gstreamer##${ANGSTROM_URI}/unstable/feed/${FEED_ARCH}/gstreamer \
- ${MACHINE}##${ANGSTROM_URI}/unstable/feed/${FEED_ARCH}/machine/${MACHINE}"
# set feed path variables
FEED_BASEPATH = "feeds/2008/${ANGSTROM_PKG_FORMAT}/${ANGSTROM_MODE}/"
@@ -61,7 +53,7 @@ MACHINE_KERNEL_VERSION = "2.6"
PCMCIA_MANAGER = "pcmciautils"
#Preferred version for the kernel on various machines
-PREFERRED_VERSION_linux-handhelds-2.6 ?= "2.6.21-hh18"
+PREFERRED_VERSION_linux-handhelds-2.6 ?= "2.6.21-hh19"
#This is unrelated to the kernel version, but userspace apps (e.g. HAL) require a recent version to build against
PREFERRED_VERSION_linux-libc-headers = "2.6.23"
@@ -182,7 +174,7 @@ DISTRO_EXTRA_RDEPENDS += "\
update-modules \
${@base_contains("MACHINE_FEATURES", "screen", "psplash", "",d)} \
angstrom-version \
- ipkg ipkg-collateral \
+ ipkg ipkg-collateral ${ANGSTROM_FEED_CONFIGS} \
util-linux-mount util-linux-umount \
${DEBUG_APPS} \
"
diff --git a/contrib/angstrom/build-release.sh b/contrib/angstrom/build-release.sh
index 39108ad89b..8b30212790 100755
--- a/contrib/angstrom/build-release.sh
+++ b/contrib/angstrom/build-release.sh
@@ -32,17 +32,28 @@ do_report_success() {
echo "$(date -u +%s) $target $BUILD_MODE $machine" >> autobuilder.log
}
+#cross toolchain
+#for machine in ep93xx a780 efika collie ixp4xxbe
+#do
+# BUILD_MACHINE=$machine
+# BUILD_TARGETS="meta-toolchain"
+# BUILD_CLEAN="meta-toolchain"
+# do_build
+#done
+
+
# No graphics
for machine in ep93xx gumstix-connex gumstix-verdex efika omap5912osk
do
BUILD_MACHINE=$machine
- BUILD_CLEAN="libtool-cross"
+ BUILD_CLEAN="libtool-cross base-files"
BUILD_TARGETS="base-image console-image"
do_build
done
for machine in ixp4xxle ixp4xxbe
do
+ BUILD_CLEAN="base-files"
BUILD_MACHINE=$machine
BUILD_TARGETS="base-image nslu2-base-image"
do_build
@@ -51,6 +62,7 @@ done
# build altboot images for zaurus
for machine in c7x0 poodle tosa akita spitz collie
do
+ BUILD_CLEAN="base-files"
BUILD_MACHINE=$machine
BUILD_TARGETS="altboot-console-image"
do_build
@@ -59,6 +71,7 @@ done
# graphics, flash storage
for machine in fic-gta01 a780 at91sam9263ek qemuarm h2200 h3900 h4000 poodle tosa hx4700 c7x0 spitz akita collie
do
+ BUILD_CLEAN="base-files"
BUILD_MACHINE=$machine
BUILD_TARGETS="base-image console-image minimal-gpe-image x11-image"
do_build
@@ -67,6 +80,7 @@ done
# graphics, disk storage
for machine in spitz
do
+ BUILD_CLEAN="base-files"
BUILD_MACHINE=$machine
BUILD_TARGETS="x11-gpe-image x11-pimlico-image x11-office-image"
do_build
@@ -88,12 +102,3 @@ do
do_build
done
-#cross toolchain
-#for machine in ep93xx a780 efika collie ixp4xxbe
-#do
-# BUILD_MACHINE=$machine
-# BUILD_TARGETS="meta-toolchain"
-# BUILD_CLEAN="meta-toolchain"
-# do_build
-#done
-
diff --git a/packages/avahi/avahi.inc b/packages/avahi/avahi.inc
index 3864dc5135..e8e9e7c4a8 100644
--- a/packages/avahi/avahi.inc
+++ b/packages/avahi/avahi.inc
@@ -45,10 +45,11 @@ FILES_avahi-dnsconfd = "${sbindir}/avahi-dnsconfd \
${sysconfdir}/avahi/avahi-dnsconfd.action \
${sysconfdir}/init.d/avahi-dnsconfd"
FILES_libavahi-glib = "${libdir}/libavahi-glib.so.*"
+FILES_libavahi-gobject = "${libdir}/libavahi-gobject.so.*"
FILES_avahi-utils = "${bindir}/avahi-*"
FILES_avahi-autoipd = "${sbindir}/avahi-autoipd \
${sysconfdir}/avahi/avahi-autoipd.action \
- ${sysconfdir}/udhcpc.d/*avahi-autoipd"
+ ${sysconfdir}/udhcpc.d/*avahi-autoipd"
FILES_python-avahi = "${libdir}/python*/site-packages/avahi/*"
FILES_avahi-discover = "${bindir}/avahi-discover \
${datadir}/applications/avahi-discover.desktop \
diff --git a/packages/avahi/avahi_0.6.22.bb b/packages/avahi/avahi_0.6.22.bb
new file mode 100644
index 0000000000..15f56ffa95
--- /dev/null
+++ b/packages/avahi/avahi_0.6.22.bb
@@ -0,0 +1,5 @@
+require avahi.inc
+
+DEPENDS += "intltool-native"
+
+PACKAGES =+ "libavahi-gobject"
diff --git a/packages/gtk-webcore/midori_0.0.15.bb b/packages/gtk-webcore/midori_0.0.15.bb
new file mode 100644
index 0000000000..23d0179375
--- /dev/null
+++ b/packages/gtk-webcore/midori_0.0.15.bb
@@ -0,0 +1,11 @@
+DESCRIPTION = "Midori is a lightweight web browser."
+LICENSE = "GPLv2"
+
+DEPENDS = "webkit-gtk libsexy"
+
+inherit autotools pkgconfig
+
+SRC_URI = "http://software.twotoasts.de/media/midori/midori-${PV}.tar.gz \
+ "
+
+
diff --git a/packages/images/poky-base-image.bb b/packages/images/poky-base-image.bb
new file mode 100644
index 0000000000..0980fc46bf
--- /dev/null
+++ b/packages/images/poky-base-image.bb
@@ -0,0 +1,29 @@
+DISTRO_SSH_DAEMON ?= "dropbear"
+DISTRO_PACKAGE_MANAGER ?= "ipkg ipkg-collateral"
+
+IMAGE_INSTALL = "\
+ task-base-extended \
+ ${DISTRO_SSH_DAEMON} \
+ ${DISTRO_PACKAGE_MANAGER} \
+ pointercal \
+ matchbox-wm \
+ matchbox-keyboard matchbox-keyboard-applet matchbox-keyboard-im \
+ matchbox-desktop \
+ ${XSERVER} \
+ xserver-kdrive-common xserver-nodm-init \
+ ttf-liberation \
+ xauth xhost xset xrandr \
+ matchbox-sato \
+ matchbox-config-gtk \
+ matchbox-themes-gtk \
+ matchbox-applet-startup-monitor \
+ xcursor-transparent-theme \
+ sato-icon-theme \
+ settings-daemon \
+"
+
+export IMAGE_BASENAME = "poky-base-image"
+IMAGE_LINGUAS = ""
+
+inherit image
+
diff --git a/packages/libxml/files/no-testapi.patch b/packages/libxml/files/no-testapi.patch
deleted file mode 100644
index 15a4dea0ee..0000000000
--- a/packages/libxml/files/no-testapi.patch
+++ /dev/null
@@ -1,51 +0,0 @@
---- /tmp/Makefile.am 2005-11-13 14:33:15.844432536 +0100
-+++ libxml2-2.6.22/Makefile.am 2005-11-13 14:33:25.796919528 +0100
-@@ -8,7 +8,7 @@
-
- noinst_PROGRAMS=testSchemas testRelax testSAX testHTML testXPath testURI \
- testThreads testC14N testAutomata testRegexp \
-- testReader testapi testModule runtest runsuite
-+ testReader testModule runtest runsuite
-
- bin_PROGRAMS = xmllint xmlcatalog
-
-@@ -135,20 +135,9 @@
- testdso_la_LDFLAGS = -module -rpath $(libdir)
-
- # that one forces the rebuild when "make rebuild" is run on doc/
--rebuild_testapi:
-- -@(if [ "$(PYTHON)" != "" ] ; then \
-- $(PYTHON) $(srcdir)/gentest.py $(srcdir) ; fi )
-
- # that one is just to make sure it is rebuilt if missing
- # but adding the dependances generate mess
--testapi.c:
-- -@(if [ "$(PYTHON)" != "" ] ; then \
-- $(PYTHON) $(srcdir)/gentest.py $(srcdir) ; fi )
--
--testapi_SOURCES=testapi.c
--testapi_LDFLAGS =
--testapi_DEPENDENCIES = $(DEPS)
--testapi_LDADD= $(LDADDS)
-
- #testOOM_SOURCES=testOOM.c testOOMlib.h testOOMlib.c
- #testOOM_LDFLAGS =
-@@ -169,9 +158,6 @@
- @echo '## Go get a cup of coffee it is gonna take a while ...'
- $(MAKE) CHECKER='valgrind' tests
-
--APItests: testapi$(EXEEXT)
-- @echo "## Running the API regression tests this may take a little while"
-- -@($(CHECKER) $(top_builddir)/testapi -q)
-
- HTMLtests : testHTML$(EXEEXT)
- @(echo > .memdump)
-@@ -1116,7 +1102,7 @@
- dist-test: distdir
- (mkdir -p $(distdir))
- (cd $(srcdir) ; tar -cf - --exclude CVS xstc/Tests) | (cd $(distdir); tar xf -)
-- tar -cf - $(distdir)/test $(distdir)/result $(distdir)/xstc/Tests $(distdir)/Makefile.tests $(distdir)/README $(distdir)/README.tests $(distdir)/AUTHORS $(distdir)/testapi.c $(distdir)/runtest.c $(distdir)/runsuite.c | GZIP=$(GZIP_ENV) gzip -c >`echo "$(distdir)" | sed "s+libxml2+libxml2-tests+"`.tar.gz
-+ tar -cf - $(distdir)/test $(distdir)/result $(distdir)/xstc/Tests $(distdir)/Makefile.tests $(distdir)/README $(distdir)/README.tests $(distdir)/AUTHORS $(distdir)/runtest.c $(distdir)/runsuite.c | GZIP=$(GZIP_ENV) gzip -c >`echo "$(distdir)" | sed "s+libxml2+libxml2-tests+"`.tar.gz
- @(rm -rf $(distdir)/xstc/Test)
-
- cleantar:
diff --git a/packages/matchbox-desktop-sato/.mtn2git_empty b/packages/matchbox-desktop-sato/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/matchbox-desktop-sato/.mtn2git_empty
diff --git a/packages/matchbox-desktop-sato/matchbox-desktop-sato_svn.bb b/packages/matchbox-desktop-sato/matchbox-desktop-sato_svn.bb
new file mode 100644
index 0000000000..8d1a3e181d
--- /dev/null
+++ b/packages/matchbox-desktop-sato/matchbox-desktop-sato_svn.bb
@@ -0,0 +1,14 @@
+SECTION = "x11"
+DESCRIPTION = "Sato desktop folders"
+LICENSE = "LGPL"
+DEPENDS = ""
+CONFLICTS = "matchbox-common"
+SRCREV = "76"
+PV = "0.0+svnr${SRCREV}"
+
+SRC_URI = "svn://svn.o-hand.com/repos/sato/trunk;module=desktop-folders;proto=http"
+S = "${WORKDIR}/desktop-folders"
+
+inherit autotools pkgconfig
+
+FILES_${PN} += "${datadir}"
diff --git a/packages/matchbox-sato/.mtn2git_empty b/packages/matchbox-sato/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/matchbox-sato/.mtn2git_empty
diff --git a/packages/matchbox-sato/matchbox-sato/.mtn2git_empty b/packages/matchbox-sato/matchbox-sato/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/matchbox-sato/matchbox-sato/.mtn2git_empty
diff --git a/packages/matchbox-sato/matchbox-sato/etc/.mtn2git_empty b/packages/matchbox-sato/matchbox-sato/etc/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/matchbox-sato/matchbox-sato/etc/.mtn2git_empty
diff --git a/packages/matchbox-sato/matchbox-sato/etc/matchbox/.mtn2git_empty b/packages/matchbox-sato/matchbox-sato/etc/matchbox/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/matchbox-sato/matchbox-sato/etc/matchbox/.mtn2git_empty
diff --git a/packages/matchbox-sato/matchbox-sato/etc/matchbox/session b/packages/matchbox-sato/matchbox-sato/etc/matchbox/session
new file mode 100755
index 0000000000..8c8f953b47
--- /dev/null
+++ b/packages/matchbox-sato/matchbox-sato/etc/matchbox/session
@@ -0,0 +1,15 @@
+#!/bin/sh
+
+. /etc/formfactor/config
+
+if [ -e /dev/touchscreen/touchscreen0 ]; then
+ SHOWCURSOR="no"
+else
+ SHOWCURSOR="yes"
+fi
+
+matchbox-desktop &
+
+matchbox-panel --titlebar --start-applets showdesktop,windowselector --end-applets clock,battery,systray,startup &
+
+exec matchbox-window-manager -theme Sato -use_desktop_mode decorated -use_cursor $SHOWCURSOR $@
diff --git a/packages/matchbox-sato/matchbox-sato/matchbox-session b/packages/matchbox-sato/matchbox-sato/matchbox-session
new file mode 100644
index 0000000000..65f1ce72ca
--- /dev/null
+++ b/packages/matchbox-sato/matchbox-sato/matchbox-session
@@ -0,0 +1,24 @@
+#!/bin/sh
+#
+# Very simple session manager for matchbox tools
+#
+
+# Uncomment below to enable parsing of debian menu entrys
+# export MB_USE_DEB_MENUS=1
+
+if [ -e $HOME/.matchbox/session ]
+then
+exec $HOME/.matchbox/session
+fi
+
+if [ -e /etc/matchbox/session ]
+then
+exec /etc/matchbox/session
+fi
+
+# Default files to run if $HOME/.matchbox/session or /etc/matchbox/session
+# dont exist.
+
+matchbox-desktop &
+matchbox-panel --orientation south &
+exec matchbox-window-manager $@
diff --git a/packages/matchbox-sato/matchbox-sato_0.1.bb b/packages/matchbox-sato/matchbox-sato_0.1.bb
new file mode 100644
index 0000000000..b622f24586
--- /dev/null
+++ b/packages/matchbox-sato/matchbox-sato_0.1.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "Custom MB session files for poky"
+LICENSE = "GPL"
+SECTION = "x11"
+RDEPENDS = "gtk-sato-engine matchbox-theme-sato gtk-theme-sato matchbox-panel-2 matchbox-desktop-sato"
+RCONFLICTS = "matchbox-common"
+PR = "r17"
+
+SRC_URI = "file://etc file://matchbox-session"
+S = ${WORKDIR}
+
+do_install() {
+ install -d ${D}/${bindir}
+ install -m 0755 ${S}/matchbox-session ${D}/${bindir}
+ cp -R ${S}/etc ${D}/etc
+ rm -fR ${D}/etc/.svn
+ rm -fR ${D}/etc/matchbox/.svn
+ chmod -R 755 ${D}/etc
+}
+
+pkg_postinst_matchbox-sato () {
+#!/bin/sh -e
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/theme Sato
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/icon_theme Sato
+gconftool-2 --config-source=xml::$D${sysconfdir}/gconf/gconf.xml.defaults --direct --type string --set /desktop/poky/interface/font_name "Sans 9"
+}