aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorRoger Monk <r-monk@ti.com>2009-02-20 13:18:22 +0000
committerKoen Kooi <koen@openembedded.org>2009-02-20 17:05:59 +0100
commitc0ee8e8641a46803fd83c7689c476789415f7dde (patch)
tree4bd7060c7c90af572efc1ed801444e71f76989fe
parent797d7ee55602219e923350f3e1b5e5440e4a7e42 (diff)
downloadopenembedded-c0ee8e8641a46803fd83c7689c476789415f7dde.tar.gz
codec-engine: Added-scripts for loading/unloading modules for running dsplink/ce/dmai test apps
Signed-off-by: Koen Kooi <koen@openembedded.org>
-rwxr-xr-xpackages/dsplink/files/loadmodules-ti-codec-engine-apps.sh37
-rwxr-xr-xpackages/dsplink/files/loadmodules-ti-dmai-apps.sh37
-rwxr-xr-xpackages/dsplink/files/loadmodules-ti-dsplink-apps.sh25
-rwxr-xr-xpackages/dsplink/files/unloadmodules-ti-codec-engine-apps.sh12
-rwxr-xr-xpackages/dsplink/files/unloadmodules-ti-dmai-apps.sh12
-rwxr-xr-xpackages/dsplink/files/unloadmodules-ti-dsplink-apps.sh5
-rw-r--r--packages/dsplink/ti-codec-engine_2.21.bb15
-rw-r--r--packages/dsplink/ti-dmai_1.20.bb8
8 files changed, 149 insertions, 2 deletions
diff --git a/packages/dsplink/files/loadmodules-ti-codec-engine-apps.sh b/packages/dsplink/files/loadmodules-ti-codec-engine-apps.sh
new file mode 100755
index 0000000000..743a07ebba
--- /dev/null
+++ b/packages/dsplink/files/loadmodules-ti-codec-engine-apps.sh
@@ -0,0 +1,37 @@
+#
+# Default Memory Map - for OMAP3530 CE 2.21 examples
+#
+# Start Addr Size Description
+# -------------------------------------------
+# 0x80000000 80 MB Linux
+# 0x85000000 08 MB CMEM
+# 0x86000000 24 MB DDRALGHEAP
+# 0x87800000 6 MB DDR2 (BIOS, Codecs, Applications)
+# 0x87E00000 1 MB DSPLINK (MEM)
+# 0x87F00000 4 KB DSPLINK (RESET)
+# 0x87F01000 1020 KB unused
+
+# sanity check to verify that we're using the right mem=xxM (80M in this case)
+awk '/MemTotal:/ {
+ mem=$2
+
+ if (mem > 80 * 1024)
+ print "Warning! You need to use mem=80M or less on the kernel cmdline"
+
+ printf "You have %dkB total memory for Linux\n", mem
+}' /proc/meminfo
+
+# Select cmemk parameters for best fit, i.e. starting at 0x85000000
+modprobe cmemk phys_start=0x85000000 phys_end=0x86000000 pools=20x4096,8x131072,5x1048576,1x1429440,1x256000,1x3600000,5x829440
+
+# insert DSP/BIOS Link driver
+#
+modprobe dsplinkk
+
+# make /dev/dsplink
+rm -f /dev/dsplink
+mknod /dev/dsplink c `awk "\\$2==\"dsplink\" {print \\$1}" /proc/devices` 0
+
+# insert Local Power Manager driver
+#
+modprobe lpm_omap3530
diff --git a/packages/dsplink/files/loadmodules-ti-dmai-apps.sh b/packages/dsplink/files/loadmodules-ti-dmai-apps.sh
new file mode 100755
index 0000000000..af4cef9f3f
--- /dev/null
+++ b/packages/dsplink/files/loadmodules-ti-dmai-apps.sh
@@ -0,0 +1,37 @@
+#
+# Default Memory Map - for OMAP3530 dvsdk examples from 3.00.00.29 - this memory map is used for DMAI apps
+#
+# Start Addr Size Description
+# -------------------------------------------
+# 0x80000000 88 MB Linux
+# 0x85800000 08 MB CMEM
+# 0x86800000 16 MB DDRALGHEAP
+# 0x87800000 6 MB DDR2 (BIOS, Codecs, Applications)
+# 0x87E00000 1 MB DSPLINK (MEM)
+# 0x87F00000 4 KB DSPLINK (RESET)
+# 0x87F01000 1020 KB unused
+
+# sanity check to verify that we're using the right mem=xxM (88M in this case)
+awk '/MemTotal:/ {
+ mem=$2
+
+ if (mem > 88 * 1024)
+ print "Warning! You need to use mem=88M or less on the kernel cmdline"
+
+ printf "You have %dkB total memory for Linux\n", mem
+}' /proc/meminfo
+
+# Select cmemk parameters for best fit, i.e. starting at 0x85000000
+modprobe cmemk phys_start=0x85800000 phys_end=0x86800000 pools=20x4096,8x131072,5x1048576,1x1429440,1x256000,1x3600000,5x829440
+
+# insert DSP/BIOS Link driver
+#
+modprobe dsplinkk
+
+# make /dev/dsplink
+rm -f /dev/dsplink
+mknod /dev/dsplink c `awk "\\$2==\"dsplink\" {print \\$1}" /proc/devices` 0
+
+# insert Local Power Manager driver
+#
+modprobe lpm_omap3530
diff --git a/packages/dsplink/files/loadmodules-ti-dsplink-apps.sh b/packages/dsplink/files/loadmodules-ti-dsplink-apps.sh
new file mode 100755
index 0000000000..c93b637867
--- /dev/null
+++ b/packages/dsplink/files/loadmodules-ti-dsplink-apps.sh
@@ -0,0 +1,25 @@
+#
+# Default Memory Map - for OMAP3530 dsplink examples
+#
+# Start Addr Size Description
+# -------------------------------------------
+# 0x80000000 126 MB Linux
+# 0x87E00000 2 MB DSPLINK (MEM) + DDR + DSPLINK (RESET)
+
+# sanity check to verify that we're using the right mem=xxM (126M in this case)
+awk '/MemTotal:/ {
+ mem=$2
+
+ if (mem > 126 * 1024)
+ print "Warning! You need to use mem=126M or less on the kernel cmdline"
+
+ printf "You have %dkB total memory for Linux\n", mem
+}' /proc/meminfo
+
+# insert DSP/BIOS Link driver
+#
+modprobe dsplinkk
+
+# make /dev/dsplink
+rm -f /dev/dsplink
+mknod /dev/dsplink c `awk "\\$2==\"dsplink\" {print \\$1}" /proc/devices` 0
diff --git a/packages/dsplink/files/unloadmodules-ti-codec-engine-apps.sh b/packages/dsplink/files/unloadmodules-ti-codec-engine-apps.sh
new file mode 100755
index 0000000000..17436a5937
--- /dev/null
+++ b/packages/dsplink/files/unloadmodules-ti-codec-engine-apps.sh
@@ -0,0 +1,12 @@
+# Unload modules - CODEC ENGINE - OMAP3530
+
+# remove lpm module
+rmmod lpm_omap3530
+
+# remove DSP/BIOS Link driver
+rmmod dsplinkk
+rm -f /dev/dsplink
+
+# remove cmem module
+rmmod cmemk
+
diff --git a/packages/dsplink/files/unloadmodules-ti-dmai-apps.sh b/packages/dsplink/files/unloadmodules-ti-dmai-apps.sh
new file mode 100755
index 0000000000..2465c43fe9
--- /dev/null
+++ b/packages/dsplink/files/unloadmodules-ti-dmai-apps.sh
@@ -0,0 +1,12 @@
+# Unload modules - DMAI - OMAP3530
+
+# remove lpm module
+rmmod lpm_omap3530
+
+# remove DSP/BIOS Link driver
+rmmod dsplinkk
+rm -f /dev/dsplink
+
+# remove cmem module
+rmmod cmemk
+
diff --git a/packages/dsplink/files/unloadmodules-ti-dsplink-apps.sh b/packages/dsplink/files/unloadmodules-ti-dsplink-apps.sh
new file mode 100755
index 0000000000..8694114a70
--- /dev/null
+++ b/packages/dsplink/files/unloadmodules-ti-dsplink-apps.sh
@@ -0,0 +1,5 @@
+# Unload modules - DSPLINK - OMAP3530
+
+# remove DSP/BIOS Link driver
+rmmod dsplinkk
+rm -f /dev/dsplink
diff --git a/packages/dsplink/ti-codec-engine_2.21.bb b/packages/dsplink/ti-codec-engine_2.21.bb
index e3eda39f5a..b87deadaa9 100644
--- a/packages/dsplink/ti-codec-engine_2.21.bb
+++ b/packages/dsplink/ti-codec-engine_2.21.bb
@@ -8,7 +8,7 @@ RDEPENDS = "update-modules"
inherit module
# tconf from xdctools dislikes '.' in pwd :/
-PR = "r12"
+PR = "r13"
PV = "221"
# Get CE tarball from TI website, place in sources and calculate
@@ -22,6 +22,10 @@ SRC_URI = "http://install.tarball.in.source.dir/codec_engine_2_21.tar.gz \
file://lpm-make-symbol-warnings-fix.patch;patch=1 \
file://Makefile-dsplink-gpp \
file://Makefile-dsplink-dsp \
+ file://loadmodules-ti-dsplink-apps.sh \
+ file://unloadmodules-ti-dsplink-apps.sh \
+ file://loadmodules-ti-codec-engine-apps.sh \
+ file://unloadmodules-ti-codec-engine-apps.sh \
"
S = "${WORKDIR}/codec_engine_2_21"
@@ -142,6 +146,11 @@ do_install_append () {
# we change pwd so that find gives us relative path to the files, which we use to create the same structure on the target
cd ${S}/examples/ti/sdo/ce
+ #test app module un/load scripts
+ install ${WORKDIR}/loadmodules-ti-dsplink-apps.sh ${D}/${datadir}/ti-dsplink
+ install ${WORKDIR}/unloadmodules-ti-dsplink-apps.sh ${D}/${datadir}/ti-dsplink
+
+ #ce samples
# first find all the app files named '.out'
for i in $(find . -name "*.out") ; do
# first create the directory
@@ -174,6 +183,10 @@ do_install_append () {
install ${i} ${D}/${datadir}/ti-codec-engine/`dirname ${i}`
done
+ #test app module un/load scripts
+ install ${WORKDIR}/loadmodules-ti-codec-engine-apps.sh ${D}/${datadir}/ti-codec-engine
+ install ${WORKDIR}/unloadmodules-ti-codec-engine-apps.sh ${D}/${datadir}/ti-codec-engine
+
# we should install the CMEM apps as well here
# finally, strip targets that we're not supporting here
diff --git a/packages/dsplink/ti-dmai_1.20.bb b/packages/dsplink/ti-dmai_1.20.bb
index 87dcb38fd9..830143c7f2 100644
--- a/packages/dsplink/ti-dmai_1.20.bb
+++ b/packages/dsplink/ti-dmai_1.20.bb
@@ -13,12 +13,14 @@ SRC_URI = "file://dmai_1_20_00_06.tar.gz \
file://dmai-do-not-panic-on-mixer-failure.patch;patch=1 \
file://dmai-support-32bit-align.patch;patch=1 \
file://dmai-built-with-angstrom.patch;patch=1 \
+ file://loadmodules-ti-dmai-apps.sh \
+ file://unloadmodules-ti-dmai-apps.sh \
"
S = "${WORKDIR}/dmai_1_20_00_06"
# Yes, the xdc stuff still breaks with a '.' in PWD
PV = "120"
-PR = "r11"
+PR = "r12"
TARGET = "all"
TARGET_neuros-osd2 = " dm6446_al dm6446_db"
@@ -55,6 +57,10 @@ do_install () {
export EXEC_DIR="${D}/${datadir}/ti-dmai/apps"
oe_runmake install
+
+ #test app module un/load scripts
+ install ${WORKDIR}/loadmodules-ti-dmai-apps.sh ${D}/${datadir}/ti-dmai
+ install ${WORKDIR}/unloadmodules-ti-dmai-apps.sh ${D}/${datadir}/ti-dmai
}
do_stage () {