summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-09-08 10:16:47 +0000
committerKoen Kooi <koen@openembedded.org>2006-09-08 10:16:47 +0000
commit3d25e5fd944792a48cea823fc2aeec348c855826 (patch)
tree304577ac97f426accf00b1c1f6772bbd7569cf44
parent503afeb90739399a6d315d5083614861d5033930 (diff)
downloadopenembedded-3d25e5fd944792a48cea823fc2aeec348c855826.tar.gz
sync local changes
-rw-r--r--classes/packaged-staging.bbclass5
-rw-r--r--conf/distro/angstrom-2006.9.conf2
-rw-r--r--packages/gcc/gcc-cross_4.1.1.bb2
-rw-r--r--packages/gcc/gcc3-build.inc2
4 files changed, 7 insertions, 4 deletions
diff --git a/classes/packaged-staging.bbclass b/classes/packaged-staging.bbclass
index 7d5c8e30ed..a9da5af988 100644
--- a/classes/packaged-staging.bbclass
+++ b/classes/packaged-staging.bbclass
@@ -9,11 +9,14 @@
# BUGS:
# * does not distinguish between -native, -cross and other packages
+# * is oblivious to CROSSDIR
# * breaks when a recipe needs stuff from STAGING_DIR to be present during do_stage, broken behaviour IMO
# * same goes for CROSS_DIR
# TODO:
+# * also make packages for CROSSDIR
# * also build a feed for native and cross packages
+# * make package detection a bit smarter (search for compatible archs)
# * make do_clean clean staging as well
# Summary:
@@ -71,7 +74,7 @@ python do_write_ipk_list () {
do_clean_append() {
- """clear the build and temp directories"""
+ """clear the build and temp directories"""
stagepkg = bb.data.expand("${DEPLOY_DIR_PSTAGE}/${PSTAGE_PKGNAME}", d)
if stagepkg == '//': raise bb.build.FuncFailed("wrong DATADIR")
bb.note("removing " + stagepkg)
diff --git a/conf/distro/angstrom-2006.9.conf b/conf/distro/angstrom-2006.9.conf
index b7033fdb5a..77745484c1 100644
--- a/conf/distro/angstrom-2006.9.conf
+++ b/conf/distro/angstrom-2006.9.conf
@@ -22,7 +22,7 @@ FEED_URIS += " \
# ${MACHINE}##${ANGSTROM_URI}/releases/${DISTRO_VERSION}/feed/${MACHINE} \
# updates##${ANGSTROM_URI}/releases/${DISTRO_VERSION}/feed/updates"
-SRCDATE = "20060518"
+SRCDATE = "20060706"
#SRCDATE_handhelds-pxa-2.6 = "20060516"
CVS_TARBALL_STASH += "\
diff --git a/packages/gcc/gcc-cross_4.1.1.bb b/packages/gcc/gcc-cross_4.1.1.bb
index 4b0b5a1311..76e14ddca1 100644
--- a/packages/gcc/gcc-cross_4.1.1.bb
+++ b/packages/gcc/gcc-cross_4.1.1.bb
@@ -5,7 +5,7 @@ inherit cross
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/gcc-${PV}"
# NOTE: split PR. If the main .oe changes something that affects its *build*
# remember to increment this one too.
-PR = "r1"
+PR = "r2"
DEPENDS = "virtual/${TARGET_PREFIX}binutils virtual/${TARGET_PREFIX}libc-for-gcc gmp-native mpfr-native"
PROVIDES = "virtual/${TARGET_PREFIX}gcc virtual/${TARGET_PREFIX}g++"
diff --git a/packages/gcc/gcc3-build.inc b/packages/gcc/gcc3-build.inc
index 8048b45fba..1b14dd4ccd 100644
--- a/packages/gcc/gcc3-build.inc
+++ b/packages/gcc/gcc3-build.inc
@@ -18,7 +18,7 @@ JAVA_mipsel = ""
JAVA_sh3 = ""
# gcc4-build sets this to f95
FORTRAN ?= "f77"
-LANGUAGES ?= "c,c++,${FORTRAN}${JAVA}"
+LANGUAGES = "c,c++"
EXTRA_OECONF = "${@['--enable-clocale=generic', ''][bb.data.getVar('USE_NLS', d, 1) != 'no']} \
--with-gnu-ld \