summaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-06-04 13:57:32 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-06-04 13:57:32 +0000
commit1053022417f79433b3b015f64d3caa62c3479ffd (patch)
tree94f1b6d77a14931be99d344c59f44cdc4156c4da
parent93afd89e9e2cdb0b540d8ef55741cf605207949e (diff)
downloadopenembedded-1053022417f79433b3b015f64d3caa62c3479ffd.tar.gz
classes/packaged-staging.bbclass: delete package in do_clean
-rw-r--r--classes/packaged-staging.bbclass8
1 files changed, 8 insertions, 0 deletions
diff --git a/classes/packaged-staging.bbclass b/classes/packaged-staging.bbclass
index d733565985..ab12664000 100644
--- a/classes/packaged-staging.bbclass
+++ b/classes/packaged-staging.bbclass
@@ -25,6 +25,14 @@ PSTAGE_BUILD_CMD = "${IPKGBUILDCMD}"
PSTAGE_INSTALL_CMD = "ipkg-cl install -f ${DEPLOY_DIR_PSTAGE}/ipkg.conf -force-depends -o "
PSTAGE_PKGNAME = "staging-${PN}_${PV}-${PR}_${PACKAGE_ARCH}.ipk"
+do_clean_append() {
+ """clear the build and temp directories"""
+ stagepkg = bb.data.expand("${DEPLOY_DIR_PSTAGE}/${PSTAGE_PKGNAME}", d)
+ if stagepkg == '//': raise bb.build.FuncFailed("wrong DATADIR")
+ bb.note("removing " + stagepkg)
+ os.system('rm -rf ' + stagepkg)
+}
+
do_stage_prepend() {
#move away the staging dir to avoid relocation troubles