aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Patrin <papercrane@gmail.com>2007-01-23 20:33:42 +0000
committerJustin Patrin <papercrane@gmail.com>2007-01-23 20:33:42 +0000
commit2eaf1df6b9273f006b69eccfee1007304d923a13 (patch)
tree45ec69607debf38290f67803ae34860c427ccc13
parentc13ae79be2dccc598de6a4b1be39a916be065b1c (diff)
downloadopenembedded-2eaf1df6b9273f006b69eccfee1007304d923a13.tar.gz
mpd: add svn version as 0.21.x releases have autoreconf problems
-rw-r--r--packages/musicpd/mpd_svn.bb36
1 files changed, 36 insertions, 0 deletions
diff --git a/packages/musicpd/mpd_svn.bb b/packages/musicpd/mpd_svn.bb
new file mode 100644
index 0000000000..da8d595f17
--- /dev/null
+++ b/packages/musicpd/mpd_svn.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "Music Player Daemon (mpd)"
+HOMEPAGE = "http://www.musicpd.org"
+LICENSE = "GPLv2"
+MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
+SECTION = "console/multimedia"
+DEPENDS = "libvorbis libogg libid3tag libao zlib libmikmod libmad flac audiofile virtual/libiconv faad2"
+SRCDATE = "20070120"
+PV = "0.12.1+svn${SRCDATE}"
+PR = "r0"
+
+SRC_URI = "svn://svn.musicpd.org/mpd;module=trunk;proto=https"
+# file://save-volume-state.patch;patch=1"
+S = "${WORKDIR}/trunk"
+
+inherit autotools
+
+# Setting --enable-mpd-{mad,id3tag} causes local caches of the libraries to
+# be built, instead we use the OE built versions which should be installed
+# in staging - remove the --with and replace with --enable to use the local
+# versions.
+
+EXTRA_OECONF = "--enable-ogg \
+ --with-id3tag-libraries=${STAGING_LIBDIR} \
+ --with-id3tag-includes=${STAGING_INCDIR} \
+ --with-mad-libraries=${STAGING_LIBDIR} \
+ --with-mad-includes=${STAGING_INCDIR} \
+ --with-faad-libraries=${STAGING_LIBDIR} \
+ --with-faad-includes=${STAGING_INCDIR} \
+ --disable-jack \
+ --disable-pulse \
+ --enable-mod \
+ --disable-oggflac"
+
+do_compile_prepend() {
+ find -name Makefile | xargs sed -i 's~-I/usr/include~-I${STAGING_INCDIR}~g'
+}