aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJustin Patrin <papercrane@gmail.com>2007-01-27 19:05:09 +0000
committerJustin Patrin <papercrane@gmail.com>2007-01-27 19:05:09 +0000
commit0bd2d9328aa527749fb73e12ce2ff82a021632d0 (patch)
treea41a631223d5bee25e1233448253631f98e93851
parent22934fa6743681429e16592ef5973e35e9f4e961 (diff)
downloadopenembedded-0bd2d9328aa527749fb73e12ce2ff82a021632d0.tar.gz
libnl: add libnl 0.5.0
-rw-r--r--packages/libnl/.mtn2git_empty0
-rw-r--r--packages/libnl/files/.mtn2git_empty0
-rw-r--r--packages/libnl/files/fix-helpers.patch49
-rw-r--r--packages/libnl/files/libnl-0.5.0-include.diff10
-rw-r--r--packages/libnl/libnl_0.5.0.bb12
5 files changed, 71 insertions, 0 deletions
diff --git a/packages/libnl/.mtn2git_empty b/packages/libnl/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/libnl/.mtn2git_empty
diff --git a/packages/libnl/files/.mtn2git_empty b/packages/libnl/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/libnl/files/.mtn2git_empty
diff --git a/packages/libnl/files/fix-helpers.patch b/packages/libnl/files/fix-helpers.patch
new file mode 100644
index 0000000000..b6a6ff8509
--- /dev/null
+++ b/packages/libnl/files/fix-helpers.patch
@@ -0,0 +1,49 @@
+Index: libnl-0.5.0/lib/helpers.c
+===================================================================
+--- libnl-0.5.0.orig/lib/helpers.c
++++ libnl-0.5.0/lib/helpers.c
+@@ -29,6 +29,7 @@
+ #include <netlink/netlink.h>
+ #include <netlink/helpers.h>
+ #include <linux/socket.h>
++#include <linux/if_ether.h>
+
+ int nl_debug = 0;
+
+Index: libnl-0.5.0/lib/route/filter.c
+===================================================================
+--- libnl-0.5.0.orig/lib/route/filter.c
++++ libnl-0.5.0/lib/route/filter.c
+@@ -40,6 +40,7 @@
+ #include <netlink/route/filter.h>
+ #include <netlink/route/link.h>
+ #include <netlink/route/rtattr.h>
++#include <linux/if_ether.h>
+
+ static struct rtnl_filter_ops *filter_ops;
+
+Index: libnl-0.5.0/lib/Makefile
+===================================================================
+--- libnl-0.5.0.orig/lib/Makefile
++++ libnl-0.5.0/lib/Makefile
+@@ -68,7 +68,7 @@ distclean:
+
+ install:
+ mkdir -p $(DESTDIR)$(prefix)/lib/
+- install -o root -g root -m 0644 $(OUT_SLIB) $(DESTDIR)$(prefix)/lib
++ install -m 0644 $(OUT_SLIB) $(DESTDIR)$(prefix)/lib
+ rm -f $(DESTDIR)$(prefix)/lib/$(LN1_SLIB) ; \
+ $(LN) -s $(DESTDIR)$(prefix)/lib/$(OUT_SLIB) $(DESTDIR)$(prefix)/lib/$(LN1_SLIB)
+ rm -f $(DESTDIR)$(prefix)/lib/$(LN_SLIB) ; \
+Index: libnl-0.5.0/include/Makefile
+===================================================================
+--- libnl-0.5.0.orig/include/Makefile
++++ libnl-0.5.0/include/Makefile
+@@ -37,5 +37,5 @@ distclean:
+
+ install:
+ mkdir -p $(DESTDIR)$(prefix)/include/netlink/route/
+- install -o root -g root -m 0644 netlink/*.h $(DESTDIR)$(prefix)/include/netlink/
+- install -o root -g root -m 0644 netlink/route/*.h $(DESTDIR)$(prefix)/include/netlink/route/
++ install -m 0644 netlink/*.h $(DESTDIR)$(prefix)/include/netlink/
++ install -m 0644 netlink/route/*.h $(DESTDIR)$(prefix)/include/netlink/route/
diff --git a/packages/libnl/files/libnl-0.5.0-include.diff b/packages/libnl/files/libnl-0.5.0-include.diff
new file mode 100644
index 0000000000..f858953c8a
--- /dev/null
+++ b/packages/libnl/files/libnl-0.5.0-include.diff
@@ -0,0 +1,10 @@
+--- libnl-0.5.0.orig/include/netlink/route/tc.h 2005-09-08 19:13:15.000000000 -0300
++++ libnl-0.5.0/include/netlink/route/tc.h 2005-09-08 19:32:33.000000000 -0300
+@@ -24,6 +24,7 @@
+ #include <netlink/netlink.h>
+ #include <netlink/cache.h>
+ #include <netlink/data.h>
++#include <linux/pkt_sched.h>
+
+ #define TCA_HAS_HANDLE 0x001
+ #define TCA_HAS_PARENT 0x002
diff --git a/packages/libnl/libnl_0.5.0.bb b/packages/libnl/libnl_0.5.0.bb
new file mode 100644
index 0000000000..092ceb2795
--- /dev/null
+++ b/packages/libnl/libnl_0.5.0.bb
@@ -0,0 +1,12 @@
+DESCRIPTION = "Netlink library"
+HOMEPAGE = "http://people.suug.ch/~tgr/libnl/"
+SECTION = "libraries/network"
+LICENSE = "GPLv2.1"
+MAINTAINER = "Justin Patrin <papercrane@reversefold.com>"
+PR = "r0"
+
+SRC_URI = "http://people.suug.ch/~tgr/libnl/files/libnl-0.5.0.tar.gz \
+ file://libnl-0.5.0-include.diff;patch=1 \
+ file://fix-helpers.patch;patch=1"
+
+inherit autotools