aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorErik Hovland <erik@hovland.org>2006-05-23 20:12:32 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-05-23 20:12:32 +0000
commit35776eb2bfde6260e732a24aea89872fb494debf (patch)
treecc7d6eeab28909328c997cce8d66375a8a4dfb8f
parent07239ec0be09ec3d423d21f5483c86e93ec75c31 (diff)
downloadopenembedded-35776eb2bfde6260e732a24aea89872fb494debf.tar.gz
This commit adds a patch which is deemed helpful to the proper
operation in the face of an execve call. It also ups the rev of the bb packaging.
-rw-r--r--packages/strace/strace-4.5.12/strace-fix-arm-bad-syscall.patch18
-rw-r--r--packages/strace/strace_4.5.12.bb5
2 files changed, 21 insertions, 2 deletions
diff --git a/packages/strace/strace-4.5.12/strace-fix-arm-bad-syscall.patch b/packages/strace/strace-4.5.12/strace-fix-arm-bad-syscall.patch
new file mode 100644
index 0000000000..d7d7426b74
--- /dev/null
+++ b/packages/strace/strace-4.5.12/strace-fix-arm-bad-syscall.patch
@@ -0,0 +1,18 @@
+--- strace-4.5.12-orig/syscall.c 2005-06-08 21:45:28.000000000 +0100
++++ strace-4.5.12/syscall.c 2005-10-25 19:26:39.000000000 +0100
+@@ -1013,6 +1013,15 @@ struct tcb *tcp;
+ /*
+ * Note: we only deal with only 32-bit CPUs here.
+ */
++
++ if (!(tcp->flags & TCB_INSYSCALL) &&
++ (tcp->flags & TCB_WAITEXECVE)) {
++ /* caught a fake syscall from the execve's exit */
++ tcp->flags &= ~TCB_WAITEXECVE;
++ return 0;
++ }
++
++
+ if (regs.ARM_cpsr & 0x20) {
+ /*
+ * Get the Thumb-mode system call number
diff --git a/packages/strace/strace_4.5.12.bb b/packages/strace/strace_4.5.12.bb
index 95a5b7fa9b..3a15563100 100644
--- a/packages/strace/strace_4.5.12.bb
+++ b/packages/strace/strace_4.5.12.bb
@@ -1,12 +1,13 @@
LICENSE = "GPL"
SECTION = "console/utils"
-PR = "r0"
+PR = "r1"
DESCRIPTION = "strace is a system call tracing tool."
SRC_URI = "${SOURCEFORGE_MIRROR}/strace/strace-${PV}.tar.bz2 \
file://arm-syscallent.patch;patch=1 \
- file://quota.patch;patch=1"
+ file://quota.patch;patch=1 \
+ file://strace-fix-arm-bad-syscall.patch;patch=1"
inherit autotools