aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorghost <andreas.monzner@multimedia-labs.de>2009-08-21 07:49:56 +0200
committerghost <andreas.monzner@multimedia-labs.de>2009-08-21 07:49:56 +0200
commitf9895c43872fb45688bcc29ce0f621adf9291f02 (patch)
treef501557963a5135ceeb61a0d8047ea905aff0c10
parenta4ae604f8a36148cdb846a8554662000e55b3fbd (diff)
parent149e52a5f40177d03c8934c4048667dbf2f02650 (diff)
downloadopenembedded-f9895c43872fb45688bcc29ce0f621adf9291f02.tar.gz
Merge branch 'org.openembedded.dreambox' of git://git.openembedded.net/openembedded into org.openembedded.dreambox
-rw-r--r--packages/dreambox/dreambox-tpmd.bb3
-rw-r--r--packages/twisted/twisted-native_8.2.0.bb8
-rw-r--r--packages/twisted/twisted-web_8.2.0.bb17
-rw-r--r--packages/twisted/twisted_8.2.0.bb36
4 files changed, 63 insertions, 1 deletions
diff --git a/packages/dreambox/dreambox-tpmd.bb b/packages/dreambox/dreambox-tpmd.bb
index 8eea38182e..0a10582ba7 100644
--- a/packages/dreambox/dreambox-tpmd.bb
+++ b/packages/dreambox/dreambox-tpmd.bb
@@ -4,9 +4,10 @@ PRIORITY = "optional"
LICENSE = "proprietary"
MAINTAINER = "Felix Domke <tmbinc@elitedvb.net>"
DEPENDS = "dreambox-wdog"
+RDEPENDS = "dreambox-wdog"
PV = "1"
-PR = "r1"
+PR = "r2"
SRC_URI = "http://sources.dreamboxupdate.com/download/7020/tpmd-${MACHINE}-${PV} \
file://tpmd"
diff --git a/packages/twisted/twisted-native_8.2.0.bb b/packages/twisted/twisted-native_8.2.0.bb
new file mode 100644
index 0000000000..a54359c5fe
--- /dev/null
+++ b/packages/twisted/twisted-native_8.2.0.bb
@@ -0,0 +1,8 @@
+include twisted_${PV}.bb
+inherit native
+DEPENDS = "python-native zope-interface-native"
+
+do_stage() {
+ BUILD_SYS=${BUILD_SYS} HOST_SYS=${HOST_SYS} \
+ ${STAGING_BINDIR}/python setup.py install --prefix=${STAGING_BINDIR}/.. --install-data=${STAGING_DATADIR}
+}
diff --git a/packages/twisted/twisted-web_8.2.0.bb b/packages/twisted/twisted-web_8.2.0.bb
new file mode 100644
index 0000000000..204d6ba234
--- /dev/null
+++ b/packages/twisted/twisted-web_8.2.0.bb
@@ -0,0 +1,17 @@
+DESCRIPTION = "Twisted web is a web server, and also provides basic HTTP \
+client support. You may want to check out Nevow, a templating toolkit \
+designed for twisted.web, and Twisted Web2, the next generation Twisted web server."
+
+HOMEPAGE = "http://www.twistedmatrix.com"
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+DEPENDS = "twisted-native"
+RDEPENDS = "twisted"
+
+SRC_URI = "http://tmrc.mit.edu/mirror/twisted/Web/8.2/TwistedWeb-${PV}.tar.bz2"
+
+S = "${WORKDIR}/TwistedWeb-${PV}"
+
+inherit distutils
+
diff --git a/packages/twisted/twisted_8.2.0.bb b/packages/twisted/twisted_8.2.0.bb
new file mode 100644
index 0000000000..5661b762ee
--- /dev/null
+++ b/packages/twisted/twisted_8.2.0.bb
@@ -0,0 +1,36 @@
+DESCRIPTION = "Twisted is an event-driven networking framework written in Python and licensed under the LGPL. \
+Twisted supports TCP, UDP, SSL/TLS, multicast, Unix sockets, a large number of protocols \
+(including HTTP, NNTP, IMAP, SSH, IRC, FTP, and others), and much more."
+HOMEPAGE = "http://www.twistedmatrix.com"
+SECTION = "console/network"
+PRIORITY = "optional"
+LICENSE = "LGPL"
+DEPENDS = "zope-interface-native zope-interface python-crypto twisted-native"
+RDEPENDS = "python-core zope-interface python-pickle python-fcntl python-crypto"
+
+SRC_URI = "http://tmrc.mit.edu/mirror/twisted/Twisted/8.2/Twisted-${PV}.tar.bz2"
+
+S = "${WORKDIR}/Twisted-${PV}"
+
+inherit distutils
+
+SP = "${libdir}/${PYTHON_DIR}/site-packages/twisted"
+
+FILES_twisted-conch = "${SP}/conch/"
+FILES_twisted-lore = "${SP}/lore/"
+FILES_twisted-mail = "${SP}/mail/"
+FILES_twisted-names = "${SP}/names/"
+FILES_twisted-news = "${SP}/news/"
+FILES_twisted-runner = "${SP}/runner/"
+FILES_twisted-web = "${SP}/web/"
+FILES_twisted-words = "${SP}/words/"
+FILES_twisted-trial = "${SP}/trial/ ${SP}/test/"
+PACKAGES = "twisted-conch twisted-lore twisted-mail twisted-names twisted-news twisted-runner twisted-web twisted-words twisted-trial twisted"
+
+do_compile_prepend() {
+ export PYTHONPATH=${S}/TwistedCore-${PV}
+}
+
+do_install_prepend() {
+ export PYTHONPATH=${S}/TwistedCore-${PV}
+}