aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorghost <andreas.monzner@multimedia-labs.de>2009-08-24 14:48:19 +0200
committerghost <andreas.monzner@multimedia-labs.de>2009-08-24 14:48:19 +0200
commitbae63090c4953f6830013be40935745d4d090655 (patch)
tree3c6ac03f9ce2384008cc8f492d25dc309d48296a
parent08dce6ac44bed21df7dabc5ef5e3eee7a5a64742 (diff)
downloadopenembedded-bae63090c4953f6830013be40935745d4d090655.tar.gz
packages/gstreamer: hotfix for refcounting problem (not from gstreamer team)
-rw-r--r--packages/gstreamer/files/playsink_fix_double_refcount.patch16
-rw-r--r--packages/gstreamer/gst-plugins-base_0.10.24.bb5
2 files changed, 19 insertions, 2 deletions
diff --git a/packages/gstreamer/files/playsink_fix_double_refcount.patch b/packages/gstreamer/files/playsink_fix_double_refcount.patch
new file mode 100644
index 0000000000..5221b9f6c7
--- /dev/null
+++ b/packages/gstreamer/files/playsink_fix_double_refcount.patch
@@ -0,0 +1,16 @@
+--- gst-plugins-base-0.10.24.org/gst/playback/gstplaysink.c 2009-07-14 12:03:45.000000000 +0200
++++ gst-plugins-base-0.10.24/gst/playback/gstplaysink.c 2009-08-24 14:42:32.000000000 +0200
+@@ -418,11 +418,11 @@
+ }
+ if (chainp) {
+ /* we have an active chain with a sink, get the sink */
+- result = gst_object_ref (chainp);
++ result = chainp;
+ }
+ /* nothing found, return last configured sink */
+ if (result == NULL && elem)
+- result = gst_object_ref (elem);
++ result = elem;
+ GST_PLAY_SINK_UNLOCK (playsink);
+
+ return result;
diff --git a/packages/gstreamer/gst-plugins-base_0.10.24.bb b/packages/gstreamer/gst-plugins-base_0.10.24.bb
index 8da04b9ddd..4aa4f0fe41 100644
--- a/packages/gstreamer/gst-plugins-base_0.10.24.bb
+++ b/packages/gstreamer/gst-plugins-base_0.10.24.bb
@@ -3,6 +3,7 @@ PROVIDES_${PN} += "gst-plugins"
RCONFLICTS_gst-plugins-base = "libgstapp-0.10-0"
RREPLACES_gst-plugins-base = "libgstapp-0.10-0"
EXTRA_OECONF += "--with-audioresample-format=int"
-PR = "r1"
+PR = "r2"
SRC_URI += "file://gst-plugins_configure_skip_shave.patch;patch=1;pnum=0 \
-file://playsink-textsink.diff;patch=1;pnum=1"
+ file://playsink-textsink.diff;patch=1;pnum=1 \
+ file://playsink_fix_double_refcount.patch;patch=1;pnum=1" \ No newline at end of file