aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authoracid-burn <acidburn@opendreambox.org>2009-09-01 15:30:08 +0200
committeracid-burn <acidburn@opendreambox.org>2009-09-01 15:30:08 +0200
commit00e5c225513b6a7cd91189a2c9c03146580f4c77 (patch)
tree9ab9441f69ce324dfe5a227a52205e68b5369326
parentb6129d962c159ea584a96fc487f595ad9f16578f (diff)
downloadopenembedded-00e5c225513b6a7cd91189a2c9c03146580f4c77.tar.gz
python-imaging: update to version 1.1.6 and split out .debug and docs into separate sub-packages to save space.
-rw-r--r--packages/python/python-imaging_1.1.5.bb36
-rwxr-xr-xpackages/python/python-imaging_1.1.6.bb47
2 files changed, 47 insertions, 36 deletions
diff --git a/packages/python/python-imaging_1.1.5.bb b/packages/python/python-imaging_1.1.5.bb
deleted file mode 100644
index ae0024918b..0000000000
--- a/packages/python/python-imaging_1.1.5.bb
+++ /dev/null
@@ -1,36 +0,0 @@
-DESCRIPTION = "Python Imaging Library"
-SECTION = "devel/python"
-PRIORITY = "optional"
-LICENSE = "GPL"
-DEPENDS = "freetype jpeg"
-RDEPENDS = "python-lang python-stringold"
-SRCNAME = "Imaging"
-
-PR = "r1"
-
-SRC_URI = "http://effbot.org/downloads/Imaging-${PV}.tar.gz \
-file://path.patch;patch=1"
-
-S = "${WORKDIR}/${SRCNAME}-${PV}"
-
-inherit distutils
-
-do_compile() {
-
- export STAGING_LIBDIR=${STAGING_LIBDIR}
- export STAGING_INCDIR=${STAGING_INCDIR}
- distutils_do_compile
-}
-
-do_install() {
-
- export STAGING_LIBDIR=${STAGING_LIBDIR}
- export STAGING_INCDIR=${STAGING_INCDIR}
-
- distutils_do_install
-
- install -d ${D}${datadir}/doc/${PN}/html/
- install -m 0644 ${S}/README ${D}${datadir}/doc/${PN}/
- install -m 0644 ${S}/Docs/* ${D}${datadir}/doc/${PN}/html/
-
-}
diff --git a/packages/python/python-imaging_1.1.6.bb b/packages/python/python-imaging_1.1.6.bb
new file mode 100755
index 0000000000..7c8c733a5e
--- /dev/null
+++ b/packages/python/python-imaging_1.1.6.bb
@@ -0,0 +1,47 @@
+DESCRIPTION = "Python Imaging Library"
+SECTION = "devel/python"
+PRIORITY = "optional"
+LICENSE = "GPL"
+DEPENDS = "freetype jpeg tiff"
+RDEPENDS = "python-lang python-stringold"
+RDEPENDS_${PN}-doc = "${PN}"
+SRCNAME = "Imaging"
+PR = "ml2"
+
+SRC_URI = "http://effbot.org/downloads/Imaging-${PV}.tar.gz \
+ file://path.patch;patch=1"
+S = "${WORKDIR}/${SRCNAME}-${PV}"
+
+inherit distutils
+
+# Exclude debug files from the main packages
+FILES_${PN} = " \
+ ${bindir}/* \
+ ${libdir}/${PYTHON_DIR}/site-packages/PIL.pth \
+ ${libdir}/${PYTHON_DIR}/site-packages/PIL/*egg-info \
+ ${libdir}/${PYTHON_DIR}/site-packages/PIL/*.py* \
+ ${libdir}/${PYTHON_DIR}/site-packages/PIL/*.so \
+"
+
+FILES_${PN}-dbg += " \
+ ${libdir}/${PYTHON_DIR}/site-packages/PIL/.debug \
+"
+
+FILES_${PN}-doc += " \
+ ${docdir}/* \
+"
+
+do_compile() {
+ export STAGING_LIBDIR=${STAGING_LIBDIR}
+ export STAGING_INCDIR=${STAGING_INCDIR}
+ distutils_do_compile
+}
+
+do_install() {
+ export STAGING_LIBDIR=${STAGING_LIBDIR}
+ export STAGING_INCDIR=${STAGING_INCDIR}
+ distutils_do_install
+ install -d ${D}${datadir}/doc/${PN}/html/
+ install -m 0644 ${S}/README ${D}${datadir}/doc/${PN}/
+ install -m 0644 ${S}/Docs/* ${D}${datadir}/doc/${PN}/html/
+}