aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2007-04-29 13:27:08 +0000
committerJamie Lenehan <lenehan@twibble.org>2007-04-29 13:27:08 +0000
commit61459e55980ecc0aa5cbd94cfa8e5ef658150ec0 (patch)
tree387ab6c542b71ed20bd21b0478260d05b3928239
parente9793ea0f027b9e64811a9dbf2e017e10430123e (diff)
downloadopenembedded-61459e55980ecc0aa5cbd94cfa8e5ef658150ec0.tar.gz
recipes: Clean up some of the spelling and grammar in the DEFAULT_PREFERENCE section.
-rw-r--r--usermanual/chapters/recipes.xml59
1 files changed, 31 insertions, 28 deletions
diff --git a/usermanual/chapters/recipes.xml b/usermanual/chapters/recipes.xml
index 7ed33868f5..a7904f2b58 100644
--- a/usermanual/chapters/recipes.xml
+++ b/usermanual/chapters/recipes.xml
@@ -3210,50 +3210,53 @@ do_configure() {
<section id="recipes_defaultpreference" xreflabel="default preference">
<title>Preferences: How to disable packages</title>
- <para>When bitbake is asked to build a package and multiple version of
- that package are available it will normally select the version with the
- highest version number (where the version is defined via the
- <command>PV</command> variable).</para>
+ <para>When bitbake is asked to build a package and multiple versions of
+ that package are available then bitbake will normally select the version
+ that has the highest version number (where the version number is defined
+ via the <command>PV</command> variable).</para>
<para>For example if we were to ask bitbake to build procps and the
following packages are available:<screen>~/oe%&gt; ls packages/procps
procps-3.1.15/ procps-3.2.1/ procps-3.2.5/ procps-3.2.7/ procps.inc
procps_3.1.15.bb procps_3.2.1.bb procps_3.2.5.bb procps_3.2.7.bb
-~/oe%&gt;</screen>then we would expect that version <command>3.2.7</command>
- (the highest version number) would be built.</para>
-
- <para>Sometimes this is not what you actually want to happen though.
- Perhaps you have added a new version does not yet work or maybe the new
- version has no support for your target yet. Help is at hand since bitbake
- is not only looking at the version to decided which version to build but
- is also looking at the preference for the versions, as defined via a
- <command>DEFAULT_PREFERENCE</command> variable contained without the
- recipes.</para>
-
- <para>By default <command>DEFAULT_PREFERENCE</command> is set to zero.
- Bitbake will find the highest preference that is available and then for
- all the packages at the preference level it will select the package with
- the highest version. In general this means that adding a positive
+~/oe%&gt;</screen>then we would expect it to select version
+ <command>3.2.7</command> (the highest version number) to build.</para>
+
+ <para>Sometimes this is not actually what you want to happen though.
+ Perhaps you have added a new version of the package that does not yet work
+ or maybe the new version has no support for your target yet. Help is at
+ hand since bitbake is not only looking at the version numbers to decided
+ which version to build but it is also looking at the preference for each
+ of those version. The preference is defined via the
+ <command>DEFAULT_PREFERENCE</command> variable contained within the
+ recipe.</para>
+
+ <para>The default preference (when no
+ <command>DEFAULT_PREFERENCE</command> is specified) is zero. Bitbake will
+ find the highest preference that is available and then for all the
+ packages at the preference level it will select the package with the
+ highest version. In general this means that adding a positive
<command>DEFAULT_PREFERENCE</command> will cause the package to be
preferred over other versions and a negative
<command>DEFAULT_PREFERENCE</command> will cause all other packages to be
preferred.</para>
<para>Imagine that you are adding procps version 4.0.0, but that it does
- not yet work. You could delete it to make procps build so you can build a
- working image, but what you really want it just for version 4.0.0 to be
- ignored until it works. By adding:<screen>DEFAULT_PREFERENCE = "-1"</screen>to
- the recipe it'll cause it to be ignored by bitbake (since all the existing
- versions have a preference of 0). Note that you can still call bitbake
- directly on the recipe:<screen>bitbake -b packages/procps/procps_4.0.0.bb</screen>This
+ not yet work. You could delete or rename your new recipe so you can build
+ a working image, but what you really to do is just ignore the new 4.0.0
+ version until it works. By adding:<screen>DEFAULT_PREFERENCE = "-1"</screen>to
+ the recipe this is what will happen. Bitbake will now ignore this version
+ (since all of the existing versions have a preference of 0). Note that you
+ can still call bitbake directly on the recipe:<screen>bitbake -b packages/procps/procps_4.0.0.bb</screen>This
enables you to test, and fix the package manually without having bitbake
automatically select normally.</para>
- <para>By using this in conjunction with overrides you can also disable (or
- select) specific version for a specific architecture. The following
+ <para>By using this feature in conjunction with overrides you can also
+ disable (or select) specific versions based on the override. The following
example from glibc shows that this version has been disabled for the sh3
architecture because it doesn't support sh3. This will force bitbake to
- try and select one of the other versions instead:<screen>packages/glibc/glibc_2.3.2+cvs20040726.bb:DEFAULT_PREFERENCE_sh3 = "-99"</screen></para>
+ try and select one of the other available versions of glibc
+ instead:<screen>packages/glibc/glibc_2.3.2+cvs20040726.bb:DEFAULT_PREFERENCE_sh3 = "-99"</screen></para>
</section>
<section id="recipes_initscripts" xreflabel="initscripts">