aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2011-12-12 10:02:36 +0100
committerFlorian Boor <florian.boor@kernelconcepts.de>2012-09-27 17:09:07 +0200
commit21b37400533dfd45574ffbaa9261d0b582f630a1 (patch)
treebfd2078e07fc6ad35247248dd2658cca2fa2f812
parentc4fafabadb09e9e649abed7ba1e958a76914ae1e (diff)
downloadopenembedded-21b37400533dfd45574ffbaa9261d0b582f630a1.tar.gz
iproute2: add 2.6.38.1 since 2.6.38 is not fetchable any more
Signed-off-by: Florian Boor <florian.boor@kernelconcepts.de>
-rw-r--r--recipes/iproute2/iproute2-2.6.38.1/configure-cross.patch58
-rw-r--r--recipes/iproute2/iproute2_2.6.38.1.bb20
2 files changed, 78 insertions, 0 deletions
diff --git a/recipes/iproute2/iproute2-2.6.38.1/configure-cross.patch b/recipes/iproute2/iproute2-2.6.38.1/configure-cross.patch
new file mode 100644
index 0000000000..631d6bf958
--- /dev/null
+++ b/recipes/iproute2/iproute2-2.6.38.1/configure-cross.patch
@@ -0,0 +1,58 @@
+Index: iproute2-2.6.34/configure
+===================================================================
+--- iproute2-2.6.34.orig/configure
++++ iproute2-2.6.34/configure
+@@ -4,7 +4,7 @@
+ INCLUDE=${1:-"$PWD/include"}
+
+ TABLES=
+-
++SYSROOT=$1
+ check_atm()
+ {
+ cat >/tmp/atmtest.c <<EOF
+@@ -15,7 +15,7 @@ int main(int argc, char **argv) {
+ return 0;
+ }
+ EOF
+-gcc -I$INCLUDE -o /tmp/atmtest /tmp/atmtest.c -latm >/dev/null 2>&1
++$CC -I$INCLUDE -o /tmp/atmtest /tmp/atmtest.c -latm >/dev/null 2>&1
+ if [ $? -eq 0 ]
+ then
+ echo "TC_CONFIG_ATM:=y" >>Config
+@@ -49,7 +49,7 @@ int main(int argc, char **argv)
+
+ EOF
+
+-if gcc -I$INCLUDE $IPTC -o /tmp/ipttest /tmp/ipttest.c $IPTL -ldl -lxtables >/dev/null 2>&1
++if $CC -I$INCLUDE $IPTC -o /tmp/ipttest /tmp/ipttest.c $IPTL -ldl -lxtables >/dev/null 2>&1
+ then
+ echo "TC_CONFIG_XT:=y" >>Config
+ echo "using xtables"
+@@ -86,7 +86,7 @@ int main(int argc, char **argv) {
+ }
+
+ EOF
+-gcc -I$INCLUDE $IPTC -o /tmp/ipttest /tmp/ipttest.c $IPTL -ldl >/dev/null 2>&1
++$CC -I$INCLUDE $IPTC -o /tmp/ipttest /tmp/ipttest.c $IPTL -ldl >/dev/null 2>&1
+
+ if [ $? -eq 0 ]
+ then
+@@ -126,7 +126,7 @@ int main(int argc, char **argv) {
+ }
+
+ EOF
+-gcc -I$INCLUDE $IPTC -o /tmp/ipttest /tmp/ipttest.c $IPTL -ldl >/dev/null 2>&1
++$CC -I$INCLUDE $IPTC -o /tmp/ipttest /tmp/ipttest.c $IPTL -ldl >/dev/null 2>&1
+
+ if [ $? -eq 0 ]
+ then
+@@ -150,7 +150,7 @@ check_ipt()
+ check_ipt_lib_dir()
+ {
+ IPT_LIB_DIR=""
+- for dir in /lib /usr/lib /usr/local/lib
++ for dir in $SYSROOT/lib $SYSROOT/usr/lib $SYSROOT/usr/local/lib
+ do
+ for file in $dir/$TABLES/lib*t_*so ; do
+ if [ -f $file ]; then
diff --git a/recipes/iproute2/iproute2_2.6.38.1.bb b/recipes/iproute2/iproute2_2.6.38.1.bb
new file mode 100644
index 0000000000..1cf991a356
--- /dev/null
+++ b/recipes/iproute2/iproute2_2.6.38.1.bb
@@ -0,0 +1,20 @@
+require iproute2.inc
+
+PR = "${INC_PR}.0"
+
+SRC_URI = "http://pkgs.fedoraproject.org/repo/pkgs/iproute/iproute2-2.6.38.1.tar.bz2/c18932fb8570af4456dbde50b1e90806/${P}.tar.bz2 \
+ file://configure-cross.patch \
+ "
+
+SRC_URI[md5sum] = "c18932fb8570af4456dbde50b1e90806"
+SRC_URI[sha256sum] = "c04d55ad353386184bc2a53482dcd5849249ce5b958b90115ff61d6b628ce61b"
+
+S = "${WORKDIR}/iproute2-${PV}"
+
+do_configure () {
+ ./configure ${STAGING_DIR_TARGET}
+}
+
+do_install_append() {
+ install -m 0755 tc/tc ${D}${base_sbindir}
+}