aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorJunqian Gordon Xu <xjqian@gmail.com>2008-03-25 09:48:36 +0000
committerJunqian Gordon Xu <xjqian@gmail.com>2008-03-25 09:48:36 +0000
commitf090e8fb62cbf5f78ecff87d514aa5f0373c4629 (patch)
treed88a9b1391c978a7c5db87b328431cb02fa99ea9
parent898dfc71ad8c84bcd51077ed5a3840c3da8c7d7f (diff)
downloadopenembedded-f090e8fb62cbf5f78ecff87d514aa5f0373c4629.tar.gz
applied changes from 69b3066d0bd612829be7ae8c9e78a3501e5cdb3c
through a6d2d41d484ef7827260add2c94d270077592a01 applied changes from f460277636d213d6a3257745ceaac42b26814877 through 578f199bc6b531a09543f38044f98199ef5f49ad applied changes from e60db6ca0d9d6a0b3b02507a6068c2d803af4d6c through 848c6e3f16104e7b87568edf06d0d9cc79b5e860 a6d2d41d484ef7827260add2c94d270077592a01 db_4.3.29: fix packaging QA <xjqian koen> 578f199bc6b531a09543f38044f98199ef5f49ad db: sync with poky <xjqian koen> 848c6e3f16104e7b87568edf06d0d9cc79b5e860 db: fix upstream SRC_URI, unify db4. <xjqian koen>
-rw-r--r--packages/db/db-native_4.2.52.bb13
-rw-r--r--packages/db/db-native_4.3.29.bb17
-rw-r--r--packages/db/db3_3.2.9.bb8
-rw-r--r--packages/db/db4-native.inc28
-rw-r--r--packages/db/db4.inc96
-rw-r--r--packages/db/db_4.2.52.bb96
-rw-r--r--packages/db/db_4.3.29.bb97
7 files changed, 140 insertions, 215 deletions
diff --git a/packages/db/db-native_4.2.52.bb b/packages/db/db-native_4.2.52.bb
index 12a875ff13..0e6381bca1 100644
--- a/packages/db/db-native_4.2.52.bb
+++ b/packages/db/db-native_4.2.52.bb
@@ -1,13 +1,2 @@
-# This wrapper builds a native version of the SleepyCat
-# Berkeley DB for those packages which need it (e.g.
-# perl).
-SECTION = "libs"
-VIRTUAL_NAME = "virtual/db-native"
-CONFLICTS = "db3-native"
-#PR tracks the non-native package
-
-inherit native
-
require db_${PV}.bb
-
-PACKAGES = ""
+require db4-native.inc
diff --git a/packages/db/db-native_4.3.29.bb b/packages/db/db-native_4.3.29.bb
index aac4e2021b..0e6381bca1 100644
--- a/packages/db/db-native_4.3.29.bb
+++ b/packages/db/db-native_4.3.29.bb
@@ -1,17 +1,2 @@
-# This wrapper builds a native version of the SleepyCat
-# Berkeley DB for those packages which need it (e.g.
-# perl).
-SECTION = "libs"
-VIRTUAL_NAME = "virtual/db-native"
-CONFLICTS = "db3-native"
-#PR tracks the non-native package
-
-inherit native
-
require db_${PV}.bb
-
-do_package() {
-:
-}
-
-PACKAGES = ""
+require db4-native.inc
diff --git a/packages/db/db3_3.2.9.bb b/packages/db/db3_3.2.9.bb
index 7edba4f543..872ceeab87 100644
--- a/packages/db/db3_3.2.9.bb
+++ b/packages/db/db3_3.2.9.bb
@@ -1,8 +1,8 @@
SECTION = "libs"
DESCRIPTION = "Berkeley DB v3."
-HOMEPAGE = "http://www.sleepycat.com"
-LICENSE = "BSD Sleepycat"
-PR = "r2"
+HOMEPAGE = "http://www.oracle.com/technology/products/berkeley-db/db/index.html"
+LICENSE = "BSD"
+PR = "r3"
VIRTUAL_NAME ?= "virtual/db"
CONFLICTS = "db"
@@ -11,7 +11,7 @@ CONFLICTS = "db"
# a build to select the desired one.
PROVIDES += "${VIRTUAL_NAME}"
-SRC_URI = "http://download-west.oracle.com/berkeley-db/db-${PV}.tar.gz \
+SRC_URI = "http://download.oracle.com/berkeley-db/db-${PV}.tar.gz \
file://autofoo.patch;patch=1"
S = "${WORKDIR}/db-${PV}/dist"
B = "${WORKDIR}/db-${PV}/build_unix"
diff --git a/packages/db/db4-native.inc b/packages/db/db4-native.inc
new file mode 100644
index 0000000000..cc83d86dd8
--- /dev/null
+++ b/packages/db/db4-native.inc
@@ -0,0 +1,28 @@
+# This wrapper builds a native version of the Oracal
+# Berkeley DB for those packages which need it (e.g.
+# perl).
+
+VIRTUAL_NAME = "virtual/db-native"
+CONFLICTS = "db3-native"
+#PR tracks the non-native package
+
+inherit native
+
+do_package() {
+:
+}
+
+PACKAGES = ""
+
+do_stage() {
+ # The .h files get installed read-only, the autostage
+ # function just uses cp -pPR, so do this by hand
+ rm -rf ${STAGE_TEMP}
+ mkdir -p ${STAGE_TEMP}
+ oe_runmake DESTDIR="${STAGE_TEMP}" install_include
+ cp -pPRf ${STAGE_TEMP}/${includedir}/* ${STAGING_INCDIR}/.
+ rm -rf ${STAGE_TEMP}
+ oe_libinstall -so -C .libs libdb-${PVM} ${STAGING_LIBDIR}
+ ln -sf libdb-${PVM}.so ${STAGING_LIBDIR}/libdb.so
+ ln -sf libdb-${PVM}.a ${STAGING_LIBDIR}/libdb.a
+}
diff --git a/packages/db/db4.inc b/packages/db/db4.inc
new file mode 100644
index 0000000000..12d4ad2166
--- /dev/null
+++ b/packages/db/db4.inc
@@ -0,0 +1,96 @@
+# Version 4 of the Berkeley DB from Oracle
+#
+# At present this package only installs the DB code
+# itself (shared libraries, .a in the dev package),
+# documentation and headers.
+#
+# The headers have the same names as those as v3
+# of the DB, only one version can be used *for dev*
+# at once - DB3 and DB4 can both be installed on the
+# same system at the same time if really necessary.
+
+
+DESCRIPTION = "Berkeley DB v4."
+HOMEPAGE = "http://www.oracle.com/technology/products/berkeley-db/db/index.html"
+SECTION = "libs"
+LICENSE = "BSD"
+VIRTUAL_NAME ?= "virtual/db"
+CONFLICTS = "db3"
+
+SRC_URI = "http://download.oracle.com/berkeley-db/db-${PV}.tar.gz"
+
+inherit autotools
+
+# Put virtual/db in any appropriate provider of a
+# relational database, use it as a dependency in
+# place of a specific db and use:
+#
+# PREFERRED_PROVIDER_virtual/db
+#
+# to select the correct db in the build (distro) .conf
+PROVIDES += "${VIRTUAL_NAME}"
+
+# bitbake isn't quite clever enough to deal with db,
+# the distribution sits in the expected directory, but all
+# the builds must occur from a sub-directory. The following
+# persuades bitbake to go to the right place
+S = "${WORKDIR}/db-${PV}/dist"
+B = "${WORKDIR}/db-${PV}/build_unix"
+
+# The executables go in a separate package - typically there
+# is no need to install these unless doing real database
+# management on the system.
+PACKAGES += " ${PN}-bin"
+
+# Package contents
+FILES_${PN} = "${libdir}/libdb-4*so*"
+FILES_${PN}-bin = "${bindir}/*"
+# The dev package has the .so link (as in db3) and the .a's -
+# it is therefore incompatible (cannot be installed at the
+# same time) as the db3 package
+FILES_${PN}-dev = "${includedir} ${libdir}/*"
+
+EXTRA_OECONF = "${DB4_CONFIG}"
+
+# Override the MUTEX setting here, the POSIX library is
+# the default - "POSIX/pthreads/library".
+# Don't ignore the nice SWP instruction on the ARM:
+# These enable the ARM assembler mutex code, this won't
+# work with thumb compilation...
+ARM_MUTEX = "--with-mutex=ARM/gcc-assembly"
+MUTEX = ""
+MUTEX_arm = "${ARM_MUTEX}"
+MUTEX_armeb = "${ARM_MUTEX}"
+EXTRA_OECONF += "${MUTEX}"
+
+# Cancel the site stuff - it's set for db3 and destroys the
+# configure.
+CONFIG_SITE = ""
+do_configure() {
+ ( cd ${WORKDIR}/db-${PV}/dist ; gnu-configize )
+ oe_runconf
+}
+
+
+do_install_append() {
+ # The docs end up in /usr/docs - not right.
+ if test -d "${D}/${prefix}/docs"
+ then
+ mkdir -p "${D}/${datadir}"
+ test ! -d "${D}/${docdir}" || rm -rf "${D}/${docdir}"
+ mv "${D}/${prefix}/docs" "${D}/${docdir}"
+ fi
+}
+
+do_stage() {
+ # The .h files get installed read-only, the autostage
+ # function just uses cp -pPR, so do this by hand
+ rm -rf ${STAGE_TEMP}
+ mkdir -p ${STAGE_TEMP}
+ oe_runmake DESTDIR="${STAGE_TEMP}" install_include
+ cp -pPRf ${STAGE_TEMP}/${includedir}/* ${STAGING_INCDIR}/.
+ rm -rf ${STAGE_TEMP}
+ oe_libinstall -so -C .libs libdb-${PVM} ${STAGING_LIBDIR}
+ ln -sf libdb-${PVM}.so ${STAGING_LIBDIR}/libdb.so
+ ln -sf libdb-${PVM}.a ${STAGING_LIBDIR}/libdb.a
+}
diff --git a/packages/db/db_4.2.52.bb b/packages/db/db_4.2.52.bb
index a0c394f7a4..ae9591ddcb 100644
--- a/packages/db/db_4.2.52.bb
+++ b/packages/db/db_4.2.52.bb
@@ -1,97 +1,11 @@
-# Version 4 of the Berkeley DB from Sleepycat
-#
-# At present this package only installs the DB code
-# itself (shared libraries, .a in the dev package),
-# documentation and headers.
-#
-# The headers have the same names as those as v3
-# of the DB, only one version can be used *for dev*
-# at once - DB3 and DB4 can both be installed on the
-# same system at the same time if really necessary.
-SECTION = "libs"
-DESCRIPTION = "Berkeley DB v4."
-HOMEPAGE = "http://www.sleepycat.com"
-LICENSE = "BSD Sleepycat"
-VIRTUAL_NAME ?= "virtual/db"
-CONFLICTS = "db3"
-PR = "r6"
+PR = "r8"
-SRC_URI = "http://downloads.sleepycat.com/db-${PV}.tar.gz"
-#SRC_URI_MD5 = "http://downloads.sleepycat.com/db-${PV}.tar.gz.md5"
-#TODO SRC_URI += "file://arm-thumb-mutex.patch;patch=1"
-
-inherit autotools
-
-# Put virtual/db in any appropriate provider of a
-# relational database, use it as a dependency in
-# place of a specific db and use:
-#
-# PREFERRED_PROVIDER_virtual/db
-#
-# to select the correct db in the build (distro) .conf
-PROVIDES += "${VIRTUAL_NAME}"
+#major version number
+PVM = "4.2"
-# bitbake isn't quite clever enough to deal with sleepycat,
-# the distribution sits in the expected directory, but all
-# the builds must occur from a sub-directory. The following
-# persuades bitbake to go to the right place
-S = "${WORKDIR}/db-${PV}/dist"
-B = "${WORKDIR}/db-${PV}/build_unix"
+require db4.inc
-# The executables go in a separate package - typically there
-# is no need to install these unless doing real database
-# management on the system.
-PACKAGES += " ${PN}-bin"
-
-# Package contents
-FILES_${PN} = "${libdir}/libdb-4*so*"
-FILES_${PN}-bin = "${bindir}/*"
-# The dev package has the .so link (as in db3) and the .a's -
-# it is therefore incompatible (cannot be installed at the
-# same time) as the db3 package
-FILES_${PN}-dev = "${includedir} ${libdir}/*"
+#TODO SRC_URI += "file://arm-thumb-mutex.patch;patch=1"
#configuration - set in local.conf to override
DB4_CONFIG ?= " --disable-cryptography --disable-queue --disable-replication --disable-verify --enable-hash"
-EXTRA_OECONF = "${DB4_CONFIG}"
-
-# Override the MUTEX setting here, the POSIX library is
-# the default - "POSIX/pthreads/library".
-# Don't ignore the nice SWP instruction on the ARM:
-# These enable the ARM assembler mutex code, this won't
-# work with thumb compilation...
-ARM_MUTEX = "--with-mutex=ARM/gcc-assembly"
-MUTEX = ""
-MUTEX_arm = "${ARM_MUTEX}"
-MUTEX_armeb = "${ARM_MUTEX}"
-EXTRA_OECONF += "${MUTEX}"
-
-# Cancel the site stuff - it's set for db3 and destroys the
-# configure.
-CONFIG_SITE = ""
-do_configure() {
- oe_runconf
-}
-
-do_stage() {
- # The .h files get installed read-only, the autostage
- # function just uses cp -pPR, so do this by hand
- rm -rf ${STAGE_TEMP}
- mkdir -p ${STAGE_TEMP}
- oe_runmake DESTDIR="${STAGE_TEMP}" install_include
- cp -pPRf ${STAGE_TEMP}/${includedir}/* ${STAGING_INCDIR}/.
- rm -rf ${STAGE_TEMP}
- oe_libinstall -so -C .libs libdb-4.2 ${STAGING_LIBDIR}
- ln -sf libdb-4.2.so ${STAGING_LIBDIR}/libdb.so
- ln -sf libdb-4.2.a ${STAGING_LIBDIR}/libdb.a
-}
-
-do_install_append() {
- # The docs end up in /usr/docs - not right.
- if test -d "${D}/${prefix}/docs"
- then
- mkdir -p "${D}/${datadir}"
- test ! -d "${D}/${docdir}" || rm -rf "${D}/${docdir}"
- mv "${D}/${prefix}/docs" "${D}/${docdir}"
- fi
-}
diff --git a/packages/db/db_4.3.29.bb b/packages/db/db_4.3.29.bb
index 750822fafe..d5733beb39 100644
--- a/packages/db/db_4.3.29.bb
+++ b/packages/db/db_4.3.29.bb
@@ -1,99 +1,12 @@
-# Version 4 of the Berkeley DB from Sleepycat
-#
-# At present this package only installs the DB code
-# itself (shared libraries, .a in the dev package),
-# documentation and headers.
-#
-# The headers have the same names as those as v3
-# of the DB, only one version can be used *for dev*
-# at once - DB3 and DB4 can both be installed on the
-# same system at the same time if really necessary.
-SECTION = "libs"
-DESCRIPTION = "Berkeley DB v4."
-HOMEPAGE = "http://www.sleepycat.com"
-LICENSE = "BSD Sleepycat"
-VIRTUAL_NAME ?= "virtual/db"
-CONFLICTS = "db3"
-PR = "r8"
+PR = "r10"
-SRC_URI = "http://downloads.sleepycat.com/db-${PV}.tar.gz"
-#SRC_URI_MD5 = "http://downloads.sleepycat.com/db-${PV}.tar.gz.md5"
-SRC_URI += "file://arm-thumb-mutex.patch;patch=1"
-
-inherit autotools
-
-# Put virtual/db in any appropriate provider of a
-# relational database, use it as a dependency in
-# place of a specific db and use:
-#
-# PREFERRED_PROVIDER_virtual/db
-#
-# to select the correct db in the build (distro) .conf
-PROVIDES += "${VIRTUAL_NAME}"
+# major version number
+PVM = "4.3"
-# bitbake isn't quite clever enough to deal with sleepycat,
-# the distribution sits in the expected directory, but all
-# the builds must occur from a sub-directory. The following
-# persuades bitbake to go to the right place
-S = "${WORKDIR}/db-${PV}/dist"
-B = "${WORKDIR}/db-${PV}/build_unix"
+require db4.inc
-# The executables go in a separate package - typically there
-# is no need to install these unless doing real database
-# management on the system.
-PACKAGES += " ${PN}-bin"
-
-# Package contents
-FILES_${PN} = "${libdir}/libdb-4*so*"
-FILES_${PN}-bin = "${bindir}/*"
-# The dev package has the .so link (as in db3) and the .a's -
-# it is therefore incompatible (cannot be installed at the
-# same time) as the db3 package
-FILES_${PN}-dev = "${includedir} ${libdir}/*"
+SRC_URI += "file://arm-thumb-mutex.patch;patch=1"
#configuration - set in local.conf to override
# All the --disable-* options replace --enable-smallbuild, which breaks a bunch of stuff (eg. postfix)
DB4_CONFIG ?= "--enable-o_direct --disable-cryptography --disable-queue --disable-replication --disable-statistics --disable-verify --enable-compat185"
-EXTRA_OECONF = "${DB4_CONFIG}"
-
-# Override the MUTEX setting here, the POSIX library is
-# the default - "POSIX/pthreads/library".
-# Don't ignore the nice SWP instruction on the ARM:
-# These enable the ARM assembler mutex code, this won't
-# work with thumb compilation...
-ARM_MUTEX = "--with-mutex=ARM/gcc-assembly"
-MUTEX = ""
-MUTEX_arm = "${ARM_MUTEX}"
-MUTEX_armeb = "${ARM_MUTEX}"
-EXTRA_OECONF += "${MUTEX}"
-
-# Cancel the site stuff - it's set for db3 and destroys the
-# configure.
-CONFIG_SITE = ""
-do_configure() {
- ( cd ${WORKDIR}/db-${PV}/dist ; gnu-configize )
- oe_runconf
-}
-
-do_stage() {
- # The .h files get installed read-only, the autostage
- # function just uses cp -pPR, so do this by hand
- rm -rf ${STAGE_TEMP}
- mkdir -p ${STAGE_TEMP}
- oe_runmake DESTDIR="${STAGE_TEMP}" install_include
- cp -pPRf ${STAGE_TEMP}/${includedir}/* ${STAGING_INCDIR}/.
- rm -rf ${STAGE_TEMP}
- oe_libinstall -so -C .libs libdb-4.3 ${STAGING_LIBDIR}
- ln -sf libdb-4.3.so ${STAGING_LIBDIR}/libdb.so
- ln -sf libdb-4.3.a ${STAGING_LIBDIR}/libdb.a
-}
-
-do_install_append() {
- # The docs end up in /usr/docs - not right.
- if test -d "${D}/${prefix}/docs"
- then
- mkdir -p "${D}/${datadir}"
- test ! -d "${D}/${docdir}" || rm -rf "${D}/${docdir}"
- mv "${D}/${prefix}/docs" "${D}/${docdir}"
- fi
-}