aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-03-07 13:05:25 +0000
committerKoen Kooi <koen@openembedded.org>2008-03-07 13:05:25 +0000
commit7e79fb438e7ff303edc0729bad992725c02e07fa (patch)
tree73adc99db041c1c525dd7cc34993890e4c91a36a
parentc9939aadda2a2f0449996be2ce2ce95c085439a8 (diff)
downloadopenembedded-7e79fb438e7ff303edc0729bad992725c02e07fa.tar.gz
alsa-state:
Revision: c72441dc719a5903a8fdc705f309c086346249b0 Ancestor: 1b3281155a76e1b96f9c232d53e0b275b6f50ef2 Fixed default ALSA state for SL-Cxx00 (OE#2617). * Fixes bass/treble levels (reflects kernel fix alsa-wm8750-treble.patch (>2.6.24)). * Increased Mic Levels and Boost. * Enabled Capture Switch. * Improved Headphones / Speaker volume balance. * Disabled all bypasses. * Disabled Left -> Right routing. * All Mono signals decreased to 0 (not connected). * Line Mux changed to differential, keeping PGA unused. * Using Digital mono for recording (jack supports ony mono). * Enabled Automatic Level Control, optimized for voice recording. * Enabled Zero Cross volume changes. applied changes from 1b3281155a76e1b96f9c232d53e0b275b6f50ef2 through c72441dc719a5903a8fdc705f309c086346249b0
-rw-r--r--BACKPORTS.txt1
-rw-r--r--packages/alsa/alsa-state.bb2
-rw-r--r--packages/alsa/alsa-state/akita/asound.state66
-rw-r--r--packages/alsa/alsa-state/spitz/asound.state82
4 files changed, 76 insertions, 75 deletions
diff --git a/BACKPORTS.txt b/BACKPORTS.txt
index 55b670e999..68854c0350 100644
--- a/BACKPORTS.txt
+++ b/BACKPORTS.txt
@@ -195,4 +195,5 @@ a9ec71b4b3a7b6500927fc2c0f61184d610a91e6 Added PXA27x resume fix from Russell Ki
eb1c40b4c0c0e45af72840032d1f8ffdf59afecc linux-rp-2.6.24: Add tosa supprot from Dmitry Baryshkov (#3879) (Hans, Koen)
9a5df4f82194968b8ea8a94d7effc5bf61c1e650 zaurusd fixes (Stanislav, Koen)
3ea27c0c881e1f8965e9208c8a3d98d022602838 xkdrive medium-raw fixes (Stanislav, Koen)
+c72441dc719a5903a8fdc705f309c086346249b0 alsa-state spitz + akita fixes (Stanislav, Koen)
diff --git a/packages/alsa/alsa-state.bb b/packages/alsa/alsa-state.bb
index 2707aa224a..796f74d973 100644
--- a/packages/alsa/alsa-state.bb
+++ b/packages/alsa/alsa-state.bb
@@ -8,7 +8,7 @@ DESCRIPTION = "Default ALSA configuration"
LICENSE = "GPL"
RRECOMMENDS_alsa-state = "alsa-states"
PV = "0.1.0"
-PR = "r7"
+PR = "r8"
SRC_URI = " \
file://asoundrc \
diff --git a/packages/alsa/alsa-state/akita/asound.state b/packages/alsa/alsa-state/akita/asound.state
index ee5ef519c3..d1bacfb708 100644
--- a/packages/alsa/alsa-state/akita/asound.state
+++ b/packages/alsa/alsa-state/akita/asound.state
@@ -6,8 +6,8 @@ state.Spitz {
comment.range '0 - 63'
iface MIXER
name 'Capture Volume'
- value.0 23
- value.1 23
+ value.0 48
+ value.1 48
}
control.2 {
comment.access 'read write'
@@ -15,8 +15,8 @@ state.Spitz {
comment.count 2
iface MIXER
name 'Capture ZC Switch'
- value.0 false
- value.1 false
+ value.0 true
+ value.1 true
}
control.3 {
comment.access 'read write'
@@ -24,8 +24,8 @@ state.Spitz {
comment.count 2
iface MIXER
name 'Capture Switch'
- value.0 false
- value.1 false
+ value.0 true
+ value.1 true
}
control.4 {
comment.access 'read write'
@@ -33,8 +33,8 @@ state.Spitz {
comment.count 2
iface MIXER
name 'Headphone Playback ZC Switch'
- value.0 false
- value.1 false
+ value.0 true
+ value.1 true
}
control.5 {
comment.access 'read write'
@@ -42,8 +42,8 @@ state.Spitz {
comment.count 2
iface MIXER
name 'Speaker Playback ZC Switch'
- value.0 false
- value.1 false
+ value.0 true
+ value.1 true
}
control.6 {
comment.access 'read write'
@@ -92,8 +92,8 @@ state.Spitz {
comment.range '0 - 255'
iface MIXER
name 'PCM Volume'
- value.0 255
- value.1 255
+ value.0 220
+ value.1 220
}
control.11 {
comment.access 'read write'
@@ -122,7 +122,7 @@ state.Spitz {
comment.range '0 - 15'
iface MIXER
name 'Bass Volume'
- value 11
+ value 0
}
control.14 {
comment.access 'read write'
@@ -131,7 +131,7 @@ state.Spitz {
comment.range '0 - 15'
iface MIXER
name 'Treble Volume'
- value 11
+ value 0
}
control.15 {
comment.access 'read write'
@@ -158,7 +158,7 @@ state.Spitz {
comment.range '0 - 15'
iface MIXER
name '3D Volume'
- value 9
+ value 0
}
control.18 {
comment.access 'read write'
@@ -226,7 +226,7 @@ state.Spitz {
comment.count 1
iface MIXER
name 'ALC Capture ZC Switch'
- value false
+ value true
}
control.25 {
comment.access 'read write'
@@ -235,7 +235,7 @@ state.Spitz {
comment.range '0 - 15'
iface MIXER
name 'ALC Capture Hold Time'
- value 0
+ value 9
}
control.26 {
comment.access 'read write'
@@ -244,7 +244,7 @@ state.Spitz {
comment.range '0 - 15'
iface MIXER
name 'ALC Capture Decay Time'
- value 3
+ value 9
}
control.27 {
comment.access 'read write'
@@ -253,7 +253,7 @@ state.Spitz {
comment.range '0 - 15'
iface MIXER
name 'ALC Capture Attack Time'
- value 2
+ value 3
}
control.28 {
comment.access 'read write'
@@ -298,7 +298,7 @@ state.Spitz {
comment.range '0 - 255'
iface MIXER
name 'Right ADC Capture Volume'
- value 0
+ value 195
}
control.33 {
comment.access 'read write'
@@ -306,7 +306,7 @@ state.Spitz {
comment.count 1
iface MIXER
name 'ZC Timeout Switch'
- value false
+ value true
}
control.34 {
comment.access 'read write'
@@ -331,8 +331,8 @@ state.Spitz {
comment.range '0 - 3'
iface MIXER
name 'Mic Boost'
- value.0 0
- value.1 0
+ value.0 3
+ value.1 3
}
control.37 {
comment.access 'read write'
@@ -379,8 +379,8 @@ state.Spitz {
comment.range '0 - 127'
iface MIXER
name 'Headphone Playback Volume'
- value.0 121
- value.1 121
+ value.0 105
+ value.1 105
}
control.42 {
comment.access 'read write'
@@ -389,8 +389,8 @@ state.Spitz {
comment.range '0 - 127'
iface MIXER
name 'Speaker Playback Volume'
- value.0 121
- value.1 121
+ value.0 127
+ value.1 127
}
control.43 {
comment.access 'read write'
@@ -411,7 +411,7 @@ state.Spitz {
comment.item.3 'Digital Mono'
iface MIXER
name 'Right ADC Mux'
- value 'Mono (Left)'
+ value 'Digital Mono'
}
control.45 {
comment.access 'read write'
@@ -423,7 +423,7 @@ state.Spitz {
comment.item.3 'Digital Mono'
iface MIXER
name 'Left ADC Mux'
- value 'Mono (Left)'
+ value 'Digital Mono'
}
control.46 {
comment.access 'read write'
@@ -458,7 +458,7 @@ state.Spitz {
comment.item.4 Differential
iface MIXER
name 'Right Line Mux'
- value 'Line 2'
+ value Differential
}
control.49 {
comment.access 'read write'
@@ -471,7 +471,7 @@ state.Spitz {
comment.item.4 Differential
iface MIXER
name 'Left Line Mux'
- value 'Line 1'
+ value Differential
}
control.50 {
comment.access 'read write'
@@ -483,7 +483,7 @@ state.Spitz {
comment.item.3 Differential
iface MIXER
name 'Right PGA Mux'
- value 'Line 2'
+ value Differential
}
control.51 {
comment.access 'read write'
@@ -495,7 +495,7 @@ state.Spitz {
comment.item.3 Differential
iface MIXER
name 'Left PGA Mux'
- value 'Line 1'
+ value Differential
}
control.52 {
comment.access 'read write'
diff --git a/packages/alsa/alsa-state/spitz/asound.state b/packages/alsa/alsa-state/spitz/asound.state
index 81b6ed9814..d1bacfb708 100644
--- a/packages/alsa/alsa-state/spitz/asound.state
+++ b/packages/alsa/alsa-state/spitz/asound.state
@@ -6,8 +6,8 @@ state.Spitz {
comment.range '0 - 63'
iface MIXER
name 'Capture Volume'
- value.0 23
- value.1 23
+ value.0 48
+ value.1 48
}
control.2 {
comment.access 'read write'
@@ -15,8 +15,8 @@ state.Spitz {
comment.count 2
iface MIXER
name 'Capture ZC Switch'
- value.0 false
- value.1 false
+ value.0 true
+ value.1 true
}
control.3 {
comment.access 'read write'
@@ -24,8 +24,8 @@ state.Spitz {
comment.count 2
iface MIXER
name 'Capture Switch'
- value.0 false
- value.1 false
+ value.0 true
+ value.1 true
}
control.4 {
comment.access 'read write'
@@ -33,8 +33,8 @@ state.Spitz {
comment.count 2
iface MIXER
name 'Headphone Playback ZC Switch'
- value.0 false
- value.1 false
+ value.0 true
+ value.1 true
}
control.5 {
comment.access 'read write'
@@ -42,8 +42,8 @@ state.Spitz {
comment.count 2
iface MIXER
name 'Speaker Playback ZC Switch'
- value.0 false
- value.1 false
+ value.0 true
+ value.1 true
}
control.6 {
comment.access 'read write'
@@ -92,8 +92,8 @@ state.Spitz {
comment.range '0 - 255'
iface MIXER
name 'PCM Volume'
- value.0 255
- value.1 255
+ value.0 220
+ value.1 220
}
control.11 {
comment.access 'read write'
@@ -131,7 +131,7 @@ state.Spitz {
comment.range '0 - 15'
iface MIXER
name 'Treble Volume'
- value 15
+ value 0
}
control.15 {
comment.access 'read write'
@@ -188,7 +188,7 @@ state.Spitz {
comment.item.1 Playback
iface MIXER
name '3D Mode'
- value Capture
+ value Playback
}
control.21 {
comment.access 'read write'
@@ -218,7 +218,7 @@ state.Spitz {
comment.item.3 Stereo
iface MIXER
name 'ALC Capture Function'
- value Off
+ value Left
}
control.24 {
comment.access 'read write'
@@ -226,7 +226,7 @@ state.Spitz {
comment.count 1
iface MIXER
name 'ALC Capture ZC Switch'
- value false
+ value true
}
control.25 {
comment.access 'read write'
@@ -235,7 +235,7 @@ state.Spitz {
comment.range '0 - 15'
iface MIXER
name 'ALC Capture Hold Time'
- value 0
+ value 9
}
control.26 {
comment.access 'read write'
@@ -244,7 +244,7 @@ state.Spitz {
comment.range '0 - 15'
iface MIXER
name 'ALC Capture Decay Time'
- value 3
+ value 9
}
control.27 {
comment.access 'read write'
@@ -253,7 +253,7 @@ state.Spitz {
comment.range '0 - 15'
iface MIXER
name 'ALC Capture Attack Time'
- value 2
+ value 3
}
control.28 {
comment.access 'read write'
@@ -306,7 +306,7 @@ state.Spitz {
comment.count 1
iface MIXER
name 'ZC Timeout Switch'
- value false
+ value true
}
control.34 {
comment.access 'read write'
@@ -322,7 +322,7 @@ state.Spitz {
comment.count 1
iface MIXER
name 'Right Speaker Playback Invert Switch'
- value false
+ value true
}
control.36 {
comment.access 'read write'
@@ -331,8 +331,8 @@ state.Spitz {
comment.range '0 - 3'
iface MIXER
name 'Mic Boost'
- value.0 0
- value.1 0
+ value.0 3
+ value.1 3
}
control.37 {
comment.access 'read write'
@@ -341,8 +341,8 @@ state.Spitz {
comment.range '0 - 7'
iface MIXER
name 'Bypass Left Playback Volume'
- value.0 2
- value.1 2
+ value.0 0
+ value.1 0
}
control.38 {
comment.access 'read write'
@@ -351,8 +351,8 @@ state.Spitz {
comment.range '0 - 7'
iface MIXER
name 'Bypass Right Playback Volume'
- value.0 2
- value.1 2
+ value.0 0
+ value.1 0
}
control.39 {
comment.access 'read write'
@@ -361,8 +361,8 @@ state.Spitz {
comment.range '0 - 7'
iface MIXER
name 'Bypass Mono Playback Volume'
- value.0 2
- value.1 2
+ value.0 0
+ value.1 0
}
control.40 {
comment.access 'read write'
@@ -379,8 +379,8 @@ state.Spitz {
comment.range '0 - 127'
iface MIXER
name 'Headphone Playback Volume'
- value.0 121
- value.1 121
+ value.0 105
+ value.1 105
}
control.42 {
comment.access 'read write'
@@ -389,8 +389,8 @@ state.Spitz {
comment.range '0 - 127'
iface MIXER
name 'Speaker Playback Volume'
- value.0 121
- value.1 121
+ value.0 127
+ value.1 127
}
control.43 {
comment.access 'read write'
@@ -399,7 +399,7 @@ state.Spitz {
comment.range '0 - 127'
iface MIXER
name 'Mono Playback Volume'
- value 121
+ value 0
}
control.44 {
comment.access 'read write'
@@ -411,7 +411,7 @@ state.Spitz {
comment.item.3 'Digital Mono'
iface MIXER
name 'Right ADC Mux'
- value Stereo
+ value 'Digital Mono'
}
control.45 {
comment.access 'read write'
@@ -423,7 +423,7 @@ state.Spitz {
comment.item.3 'Digital Mono'
iface MIXER
name 'Left ADC Mux'
- value Stereo
+ value 'Digital Mono'
}
control.46 {
comment.access 'read write'
@@ -458,7 +458,7 @@ state.Spitz {
comment.item.4 Differential
iface MIXER
name 'Right Line Mux'
- value 'Line 1'
+ value Differential
}
control.49 {
comment.access 'read write'
@@ -471,7 +471,7 @@ state.Spitz {
comment.item.4 Differential
iface MIXER
name 'Left Line Mux'
- value 'Line 1'
+ value Differential
}
control.50 {
comment.access 'read write'
@@ -483,7 +483,7 @@ state.Spitz {
comment.item.3 Differential
iface MIXER
name 'Right PGA Mux'
- value 'Line 1'
+ value Differential
}
control.51 {
comment.access 'read write'
@@ -495,7 +495,7 @@ state.Spitz {
comment.item.3 Differential
iface MIXER
name 'Left PGA Mux'
- value 'Line 1'
+ value Differential
}
control.52 {
comment.access 'read write'
@@ -535,7 +535,7 @@ state.Spitz {
comment.count 1
iface MIXER
name 'Right Mixer Left Playback Switc'
- value true
+ value false
}
control.57 {
comment.access 'read write'