aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-03-07 12:59:07 +0000
committerKoen Kooi <koen@openembedded.org>2008-03-07 12:59:07 +0000
commit2cb014cbaf8e3845a8e8b99d65aa40a4e0c5dcb2 (patch)
treef9a62a217d8b08cb74507b59db524079181ca200
parentc6af21e628c2dd219f0b2148007b22c75747c8a3 (diff)
downloadopenembedded-2cb014cbaf8e3845a8e8b99d65aa40a4e0c5dcb2.tar.gz
zaurusd:
Revision: 9a5df4f82194968b8ea8a94d7effc5bf61c1e650 Ancestor: bd72b021bed4043fc9c546810adf98565821e12e - Ignore false toggle signals (work-around for OE#3390). - Fixed default ALSA state for SL-Cxx00 (OE#2617). - Do not alter incorrect mixer levels by zaurus-mixer-callback. - Allow to disable rotation by touch ~/.norot. - Fixed detection of panel_user. applied changes from bd72b021bed4043fc9c546810adf98565821e12e through 9a5df4f82194968b8ea8a94d7effc5bf61c1e650
-rw-r--r--BACKPORTS.txt2
-rw-r--r--packages/zaurusd/files/01-check-toggle-landscape9
-rw-r--r--packages/zaurusd/files/01-check-toggle-portait9
-rw-r--r--packages/zaurusd/files/alsa-cxx00-default.state.patch276
-rw-r--r--packages/zaurusd/files/zaurus-hinge.in7
-rw-r--r--packages/zaurusd/files/zaurusd-mixer-callback.patch11
-rw-r--r--packages/zaurusd/zaurusd_svn.bb10
7 files changed, 239 insertions, 85 deletions
diff --git a/BACKPORTS.txt b/BACKPORTS.txt
index 779824cde9..a915c93467 100644
--- a/BACKPORTS.txt
+++ b/BACKPORTS.txt
@@ -193,4 +193,6 @@ a9ec71b4b3a7b6500927fc2c0f61184d610a91e6 Added PXA27x resume fix from Russell Ki
816caaf243e40e8a4af131a3d54249bffd11fe51 linux-rp 2.6.24: remove repeated content from pxafb.patch (Hans, Koen)
95605d9087fdf6917d1950bf9008c71fe0efdfda linux-rp-2.6.24: add netfilter modules for qemux86, make 2.6.24 preferred (Hans, Koen)
eb1c40b4c0c0e45af72840032d1f8ffdf59afecc linux-rp-2.6.24: Add tosa supprot from Dmitry Baryshkov (#3879) (Hans, Koen)
+9a5df4f82194968b8ea8a94d7effc5bf61c1e650 zaurusd fixes (Stanislav, Koen)
+
diff --git a/packages/zaurusd/files/01-check-toggle-landscape b/packages/zaurusd/files/01-check-toggle-landscape
new file mode 100644
index 0000000000..13ae9a4e68
--- /dev/null
+++ b/packages/zaurusd/files/01-check-toggle-landscape
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+# Try to determine and ignore false rotation signals caused by
+# headphones removal or remote removal remembering the old state.
+# OE#3390
+if test "`cat /var/run/last-screen-rotation`" = landscape ; then
+ exit
+fi
+echo landscape > /var/run/last-screen-rotation
diff --git a/packages/zaurusd/files/01-check-toggle-portait b/packages/zaurusd/files/01-check-toggle-portait
new file mode 100644
index 0000000000..4c3b7f1291
--- /dev/null
+++ b/packages/zaurusd/files/01-check-toggle-portait
@@ -0,0 +1,9 @@
+#!/bin/sh
+
+# Try to determine and ignore false rotation signals caused by
+# headphones removal or remote removal remembering the old state.
+# OE#3390
+if test "`cat /var/run/last-screen-rotation`" = portait ; then
+ exit
+fi
+echo portait > /var/run/last-screen-rotation
diff --git a/packages/zaurusd/files/alsa-cxx00-default.state.patch b/packages/zaurusd/files/alsa-cxx00-default.state.patch
index c3e234b534..b10e6c85dd 100644
--- a/packages/zaurusd/files/alsa-cxx00-default.state.patch
+++ b/packages/zaurusd/files/alsa-cxx00-default.state.patch
@@ -1,64 +1,194 @@
---- zaurusd/config/alsa/cxx00-default.state.orig 2006-06-28 08:45:07.000000000 +0000
-+++ zaurusd/config/alsa/cxx00-default.state 2007-05-21 21:40:50.000000000 +0000
-@@ -32,7 +32,7 @@
+http://bugs.openembedded.org/show_bug.cgi?id=2617
+- Fixes default ALSA state for SL-Cxx00.
+ * Treble level reflects kernel fix alsa-wm8750-treble.patch (>2.6.24).
+ * Increased Mic Levels and Boost.
+ * Enabled Capture Switch.
+ * Improved Headphones / Speaker volume balance.
+ * 3D Mode changed to "Playback" (still Off by default).
+ * Disabled all bypasses.
+ * All Mono signals decreased to 0 (not connected).
+ * Line Mux changed to differential, keeping PGA unused.
+ * Using Digital mono for recording (jack supports ony mono).
+ * Enabled Automatic Level Control, optimized for voice recording.
+ * Enabled Zero Cross volume changes.
+- Do not alter incorrect mixer levels by zaurus-mixer-callback.
+
+Index: zaurusd/config/alsa/cxx00-default.state
+===================================================================
+--- zaurusd.orig/config/alsa/cxx00-default.state 2006-06-28 08:45:07.000000000 +0000
++++ zaurusd/config/alsa/cxx00-default.state 2007-11-27 23:06:43.000000000 +0000
+@@ -6,8 +6,8 @@
+ comment.range '0 - 63'
+ iface MIXER
+ name 'Capture Volume'
+- value.0 23
+- value.1 23
++ value.0 48
++ value.1 48
+ }
+ control.2 {
+ comment.access 'read write'
+@@ -15,8 +15,8 @@
+ comment.count 2
+ iface MIXER
+ name 'Capture ZC Switch'
+- value.0 false
+- value.1 false
++ value.0 true
++ value.1 true
+ }
+ control.3 {
+ comment.access 'read write'
+@@ -24,26 +24,26 @@
+ comment.count 2
+ iface MIXER
+ name 'Capture Switch'
+- value.0 false
+- value.1 false
++ value.0 true
++ value.1 true
+ }
+ control.4 {
+ comment.access 'read write'
comment.type BOOLEAN
comment.count 2
iface MIXER
- name 'Out1 Playback ZC Switch'
+- value.0 false
+- value.1 false
+ name 'Headphone Playback ZC Switch'
- value.0 false
- value.1 false
++ value.0 true
++ value.1 true
}
-@@ -41,7 +41,7 @@
+ control.5 {
+ comment.access 'read write'
comment.type BOOLEAN
comment.count 2
iface MIXER
- name 'Out2 Playback ZC Switch'
+- value.0 false
+- value.1 false
+ name 'Speaker Playback ZC Switch'
- value.0 false
- value.1 false
++ value.0 true
++ value.1 true
+ }
+ control.6 {
+ comment.access 'read write'
+@@ -92,8 +92,8 @@
+ comment.range '0 - 255'
+ iface MIXER
+ name 'PCM Volume'
+- value.0 255
+- value.1 255
++ value.0 220
++ value.1 220
}
-@@ -218,7 +218,7 @@
- comment.item.3 Stereo
+ control.11 {
+ comment.access 'read write'
+@@ -131,7 +131,7 @@
+ comment.range '0 - 15'
+ iface MIXER
+ name 'Treble Volume'
+- value 15
++ value 0
+ }
+ control.15 {
+ comment.access 'read write'
+@@ -188,7 +188,7 @@
+ comment.item.1 Playback
iface MIXER
- name 'ALC Capture Function'
-- value Left
-+ value Off
+ name '3D Mode'
+- value Capture
++ value Playback
}
- control.24 {
+ control.21 {
comment.access 'read write'
-@@ -321,8 +321,8 @@
+@@ -226,7 +226,7 @@
+ comment.count 1
+ iface MIXER
+ name 'ALC Capture ZC Switch'
+- value false
++ value true
+ }
+ control.25 {
+ comment.access 'read write'
+@@ -235,7 +235,7 @@
+ comment.range '0 - 15'
+ iface MIXER
+ name 'ALC Capture Hold Time'
+- value 0
++ value 9
+ }
+ control.26 {
+ comment.access 'read write'
+@@ -244,7 +244,7 @@
+ comment.range '0 - 15'
+ iface MIXER
+ name 'ALC Capture Decay Time'
+- value 3
++ value 9
+ }
+ control.27 {
+ comment.access 'read write'
+@@ -253,7 +253,7 @@
+ comment.range '0 - 15'
+ iface MIXER
+ name 'ALC Capture Attack Time'
+- value 2
++ value 3
+ }
+ control.28 {
+ comment.access 'read write'
+@@ -306,7 +306,7 @@
+ comment.count 1
+ iface MIXER
+ name 'ZC Timeout Switch'
+- value false
++ value true
+ }
+ control.34 {
+ comment.access 'read write'
+@@ -321,7 +321,7 @@
comment.type BOOLEAN
comment.count 1
iface MIXER
- name 'Right Out2 Playback Invert Switch'
-- value true
+ name 'Right Speaker Playback Invert Switch'
-+ value false
+ value true
}
control.36 {
- comment.access 'read write'
@@ -331,8 +331,8 @@
comment.range '0 - 3'
iface MIXER
name 'Mic Boost'
- value.0 2
- value.1 2
++ value.0 3
++ value.1 3
+ }
+ control.37 {
+ comment.access 'read write'
+@@ -341,8 +341,8 @@
+ comment.range '0 - 7'
+ iface MIXER
+ name 'Bypass Left Playback Volume'
+- value.0 2
+- value.1 2
+ value.0 0
+ value.1 0
}
- control.37 {
+ control.38 {
comment.access 'read write'
-@@ -351,8 +351,8 @@
+@@ -361,8 +361,8 @@
comment.range '0 - 7'
iface MIXER
- name 'Bypass Right Playback Volume'
-- value.0 0
-- value.1 0
-+ value.0 2
-+ value.1 2
+ name 'Bypass Mono Playback Volume'
+- value.0 2
+- value.1 2
++ value.0 0
++ value.1 0
}
- control.39 {
+ control.40 {
comment.access 'read write'
@@ -378,9 +378,9 @@
comment.count 2
@@ -68,8 +198,8 @@
- value.0 120
- value.1 120
+ name 'Headphone Playback Volume'
-+ value.0 121
-+ value.1 121
++ value.0 105
++ value.1 105
}
control.42 {
comment.access 'read write'
@@ -81,17 +211,26 @@
- value.0 119
- value.1 119
+ name 'Speaker Playback Volume'
-+ value.0 121
-+ value.1 121
++ value.0 127
++ value.1 127
}
control.43 {
comment.access 'read write'
+@@ -399,7 +399,7 @@
+ comment.range '0 - 127'
+ iface MIXER
+ name 'Mono Playback Volume'
+- value 121
++ value 0
+ }
+ control.44 {
+ comment.access 'read write'
@@ -411,7 +411,7 @@
comment.item.3 'Digital Mono'
iface MIXER
name 'Right ADC Mux'
- value 'Mono (Left)'
-+ value Stereo
++ value 'Digital Mono'
}
control.45 {
comment.access 'read write'
@@ -100,55 +239,19 @@
iface MIXER
name 'Left ADC Mux'
- value 'Mono (Left)'
-+ value Stereo
++ value 'Digital Mono'
}
control.46 {
comment.access 'read write'
-@@ -458,7 +458,7 @@
- comment.item.4 Differential
- iface MIXER
- name 'Right Line Mux'
-- value Differential
-+ value 'Line 1'
- }
- control.49 {
- comment.access 'read write'
@@ -471,7 +471,7 @@
comment.item.4 Differential
iface MIXER
name 'Left Line Mux'
- value PGA
-+ value 'Line 1'
++ value Differential
}
control.50 {
comment.access 'read write'
-@@ -483,7 +483,7 @@
- comment.item.3 Differential
- iface MIXER
- name 'Right PGA Mux'
-- value Differential
-+ value 'Line 1'
- }
- control.51 {
- comment.access 'read write'
-@@ -495,7 +495,7 @@
- comment.item.3 Differential
- iface MIXER
- name 'Left PGA Mux'
-- value Differential
-+ value 'Line 1'
- }
- control.52 {
- comment.access 'read write'
-@@ -535,7 +535,7 @@
- comment.count 1
- iface MIXER
- name 'Right Mixer Left Playback Switc'
-- value false
-+ value true
- }
- control.57 {
- comment.access 'read write'
@@ -610,9 +610,8 @@
comment.access 'read write'
comment.type ENUMERATED
@@ -161,3 +264,38 @@
iface MIXER
name 'Speaker Function'
value On
+Index: zaurusd/scripts/zaurus-mixer-callback.in
+===================================================================
+--- zaurusd.orig/scripts/zaurus-mixer-callback.in 2007-11-27 23:32:45.000000000 +0000
++++ zaurusd/scripts/zaurus-mixer-callback.in 2007-11-27 23:36:54.000000000 +0000
+@@ -16,8 +16,6 @@
+ JACK="$1"
+ SPK="$2"
+ LEFT="true"
+-RLPLAYBACK="false"
+-RLBYPASS="false"
+
+ case $SPK in
+ "On")
+@@ -37,8 +35,6 @@
+ ;;
+ "Headset" | "Mic" | "Line")
+ LEFT="false"
+- RLPLAYBACK="true"
+- RLBYPASS="true"
+ SPK="Off"
+ ;;
+ *)
+@@ -58,12 +54,6 @@
+ }; /Speaker Function/ {
+ N
+ s:\(Speaker Function.*\n.*value \).*$:\1$SPK:
+-}; /Right Mixer Left Playback/ {
+-N
+-s:\(Right Mixer Left Playback.*\n.*value \).*$:\1$RLPLAYBACK:
+-}; /Right Mixer Left Bypass/ {
+-N
+-s:\(Right Mixer Left Bypass.*\n.*value \).*$:\1$RLBYPASS:
+ }; /Left Mixer Playback/ {
+ N
+ s:\(Left Mixer Playback.*\n.*value \).*$:\1$LEFT:
diff --git a/packages/zaurusd/files/zaurus-hinge.in b/packages/zaurusd/files/zaurus-hinge.in
index f719ba3c76..9670e8803e 100644
--- a/packages/zaurusd/files/zaurus-hinge.in
+++ b/packages/zaurusd/files/zaurus-hinge.in
@@ -19,9 +19,12 @@ if [ -z "$1" ]; then
exit 1
fi
-panel_user="`ps aux|grep matchbox-panel|grep -v grep | awk '{print $2}'`"
-
+panel_user="`ps aux|grep matchbox-panel|grep -v grep | awk '{print $1}'`"
+# touch ~/.norot can disable rotation.
+if test -f /home/$panel_user/.norot ; then
+ exit
+fi
STATE=$1
diff --git a/packages/zaurusd/files/zaurusd-mixer-callback.patch b/packages/zaurusd/files/zaurusd-mixer-callback.patch
deleted file mode 100644
index 7c9455d042..0000000000
--- a/packages/zaurusd/files/zaurusd-mixer-callback.patch
+++ /dev/null
@@ -1,11 +0,0 @@
---- zaurusd/scripts/zaurus-mixer-callback.in.orig 2007-06-05 03:15:30.000000000 +0000
-+++ zaurusd/scripts/zaurus-mixer-callback.in 2007-06-05 03:14:53.000000000 +0000
-@@ -16,7 +16,7 @@
- JACK="$1"
- SPK="$2"
- LEFT="true"
--RLPLAYBACK="false"
-+RLPLAYBACK="true"
- RLBYPASS="false"
-
- case $SPK in
diff --git a/packages/zaurusd/zaurusd_svn.bb b/packages/zaurusd/zaurusd_svn.bb
index 3ea0d2b22f..be9379eced 100644
--- a/packages/zaurusd/zaurusd_svn.bb
+++ b/packages/zaurusd/zaurusd_svn.bb
@@ -4,7 +4,7 @@ LICENSE = "GPL"
DEPENDS = "tslib"
RDEPENDS = "procps"
PV = "0.0+svn${SRCDATE}"
-PR = "r16"
+PR = "r17"
SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=zaurusd;proto=http \
file://zaurus-hinge.in \
@@ -14,10 +14,11 @@ SRC_URI = "svn://svn.o-hand.com/repos/misc/trunk;module=zaurusd;proto=http \
file://disable-alsa-handling.patch;patch=1 \
file://zaurus-hinge.matchbox-portrait \
file://zaurus-hinge.matchbox-landscape \
- file://zaurusd-mixer-callback.patch;patch=1 \
file://tslib-1.diff;patch=1 \
file://zaurus-hinge.bl-on \
- file://zaurus-hinge.bl-off"
+ file://zaurus-hinge.bl-off \
+ file://01-check-toggle-landscape \
+ file://01-check-toggle-portait"
S = "${WORKDIR}/${PN}"
@@ -39,6 +40,9 @@ do_install_append() {
install -m 0755 "${WORKDIR}/zaurus-hinge.bl-on" "${D}/etc/zaurusd/hinge-portrait.d/00-backlight-on"
install -m 0755 "${WORKDIR}/zaurus-hinge.bl-off" "${D}/etc/zaurusd/hinge-close.d/00-backlight-off"
+ install -m 0755 "${WORKDIR}/01-check-toggle-landscape" "${D}/etc/zaurusd/hinge-landscape.d/01-check-toggle"
+ install -m 0755 "${WORKDIR}/01-check-toggle-portait" "${D}/etc/zaurusd/hinge-portrait.d/01-check-toggle"
+
install -m 0755 "${WORKDIR}/zaurus-hinge.matchbox-landscape" "${D}/etc/zaurusd/hinge-landscape.d/20-matchbox-landscape"
install -m 0755 "${WORKDIR}/zaurus-hinge.matchbox-portrait" "${D}/etc/zaurusd/hinge-portrait.d/20-matchbox-portrait"
}