aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Woestenberg <leon@sidebranch.com>2009-11-24 23:56:03 +0100
committerLeon Woestenberg <leon@sidebranch.com>2009-11-24 23:56:03 +0100
commitde2505dcd75e64c33f705c6d49d46a163fbe081e (patch)
tree7a36f815e9e91dc645846af116a0f3d2ec6324a0
parent127101eaa412bd763881f53d5eb758ccf7c237e4 (diff)
downloadopenembedded-de2505dcd75e64c33f705c6d49d46a163fbe081e.tar.gz
elf2flt-cross-nios2: Use CROSS_DIR paths.
Signed-off-by: Leon Woestenberg <leon@sidebranch.com>
-rw-r--r--recipes/elf2flt/elf2flt-cross_nios2-git.bb10
1 files changed, 6 insertions, 4 deletions
diff --git a/recipes/elf2flt/elf2flt-cross_nios2-git.bb b/recipes/elf2flt/elf2flt-cross_nios2-git.bb
index c58fe5e2fc..7aba8dd745 100644
--- a/recipes/elf2flt/elf2flt-cross_nios2-git.bb
+++ b/recipes/elf2flt/elf2flt-cross_nios2-git.bb
@@ -8,8 +8,10 @@ SRC_URI = "git://sopc.et.ntust.edu.tw/git/elf2flt.git;protocol=git;branch=nios2;
S = "${WORKDIR}/git"
-EXTRA_OECONF = " --with-libbfd=/home/walter//nios2-linux/toolchain-build/build/binutils-build/bfd/libbfd.a \
- --with-libiberty=/home/walter/nios2-linux/toolchain-build/build/binutils-build/libiberty/libiberty.a \
- --with-bfd-include-dir=${STAGING_INCDIR} \
- --disable-emit-relocs \
+EXTRA_OECONF = " --with-libiberty=${CROSS_DIR}/lib/libiberty.a \
+ --with-libbfd=${CROSS_DIR}/${HOST_SYS}/${TARGET_SYS}/lib/libbfd.a \
+ --with-bfd-include-dir=${CROSS_DIR}/${HOST_SYS}/${TARGET_SYS}/include \
+ --with-binutils-include-dir=${CROSS_DIR}/include \
+ --disable-emit-relocs \
"
+