aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorLeon Woestenberg <leon@sidebranch.com>2009-11-25 22:37:20 +0100
committerLeon Woestenberg <leon@sidebranch.com>2009-11-25 22:37:20 +0100
commitbe324b76b2ee0514fde61830a651a3d5036b575e (patch)
tree47f0610836d66a30bd7e8b03dd3f91e95f684118
parent576f5b040c54c1a0f7d974fe4965eb0dbd815ba9 (diff)
downloadopenembedded-be324b76b2ee0514fde61830a651a3d5036b575e.tar.gz
linux-libc-headers-nios2-2.6.28: Add hardware.mk to workaround script.
The script that interprets system.ptf asks two additional questions that cannot be automated. It used to accept 4 arguments rather than 2 to automated this, no idea why these were ditched. Signed-off-by: Leon Woestenberg <leon@sidebranch.com>
-rw-r--r--conf/distro/include/sane-srcrevs.inc3
-rw-r--r--recipes/linux-libc-headers/linux-libc-headers-nios2-2.6.28/defconfig0
-rw-r--r--recipes/linux-libc-headers/linux-libc-headers-nios2-2.6.28/hardware.mk3
-rw-r--r--recipes/linux-libc-headers/linux-libc-headers_nios2-2.6.28.bb8
4 files changed, 11 insertions, 3 deletions
diff --git a/conf/distro/include/sane-srcrevs.inc b/conf/distro/include/sane-srcrevs.inc
index cbe6799186..95e43f5116 100644
--- a/conf/distro/include/sane-srcrevs.inc
+++ b/conf/distro/include/sane-srcrevs.inc
@@ -160,7 +160,8 @@ SRCREV_pn-linux-bfin ?= "3758"
SRCREV_pn-linux-eten ?= "ab2d414f4f13816af0ec0401b608133ca946624a"
SRCREV_pn-linux-hackndev-2.6 ?= "1308"
SRCREV_pn-linux-ixp4xx ?= "1089"
-SRCREV_pn-linux-libs-headers_nios2 = "3146b39c185f8a436d430132457e84fa1d8f8208"
+SRCREV_pn-linux-libs-headers = "d01303a1035a39e445007c7522d89ad985c4153c"
+SRCREV_pn-linux-libs-headers_nios2 = "d01303a1035a39e445007c7522d89ad985c4153c"
SRCREV_pn-linux-openmoko-2.6.24 ?= "fb42ce6724576fc173faf8abfb04aa2c36d213b7"
SRCREV_pn-linux-openmoko-2.6.28 ?= "8aa6cdde17381dd8865d10ba15ee62c092ec2ba5"
SRCREV_pn-linux-openmoko-2.6.31 ?= "4331f6c95fadc37ea89359d6afb915be838790f9"
diff --git a/recipes/linux-libc-headers/linux-libc-headers-nios2-2.6.28/defconfig b/recipes/linux-libc-headers/linux-libc-headers-nios2-2.6.28/defconfig
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/recipes/linux-libc-headers/linux-libc-headers-nios2-2.6.28/defconfig
diff --git a/recipes/linux-libc-headers/linux-libc-headers-nios2-2.6.28/hardware.mk b/recipes/linux-libc-headers/linux-libc-headers-nios2-2.6.28/hardware.mk
new file mode 100644
index 0000000000..0cbb2c741d
--- /dev/null
+++ b/recipes/linux-libc-headers/linux-libc-headers-nios2-2.6.28/hardware.mk
@@ -0,0 +1,3 @@
+SYSPTF = ../system.ptf
+CPU = cpu
+EXEMEM = cfi_flash
diff --git a/recipes/linux-libc-headers/linux-libc-headers_nios2-2.6.28.bb b/recipes/linux-libc-headers/linux-libc-headers_nios2-2.6.28.bb
index 97f68165d1..7e448b3f82 100644
--- a/recipes/linux-libc-headers/linux-libc-headers_nios2-2.6.28.bb
+++ b/recipes/linux-libc-headers/linux-libc-headers_nios2-2.6.28.bb
@@ -9,7 +9,10 @@ SRCREV = "d01303a1035a39e445007c7522d89ad985c4153c"
SRC_URI = "git://sopc.et.ntust.edu.tw/git/linux-2.6.git;branch=test-nios2;protocol=http \
file://procinfo.h \
- file://system.ptf"
+ file://system.ptf \
+ file://hardware.mk \
+ file://defconfig"
+
S = "${WORKDIR}/git"
#SRC_URI = "http://127.0.0.1/linux-nios2-2.6.28-git.tbz \
@@ -41,7 +44,8 @@ set_arch() {
do_configure() {
set_arch
- oe_runmake hwselect SYSPTF=../system.ptf CPU_SELECTION=1 MEM_SELECTION=2 ARCH=$ARCH
+ cp ../hardware.mk arch/nios2
+# oe_runmake hwselect SYSPTF=../system.ptf CPU_SELECTION=1 MEM_SELECTION=2 ARCH=$ARCH
oe_runmake allnoconfig ARCH=$ARCH
}