aboutsummaryrefslogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichael Lippautz <michael.lippautz@gmail.com>2010-09-03 04:14:46 +0000
committerMichael Lippautz <michael.lippautz@gmail.com>2010-09-04 10:34:35 +0200
commitc30c54d574f87bcb5a4315d2fa5c8c8dcde49507 (patch)
treebddad79482a1cb20ec0dd9a92a8eeb901fc61d5a
parent3c80d12dffb34aaee65f97c6df90ccfdeede5e12 (diff)
downloadopenembedded-c30c54d574f87bcb5a4315d2fa5c8c8dcde49507.tar.gz
u-boot: Unbreak u-boot 2009.08 for gcc >= 4.4
Signed-off-by: Michael Lippautz <michael.lippautz@gmail.com> Acked-by: Khem Raj <raj.khem@gmail.com> Acked-by: Frans Meulenbroeks <fransmeulenbroeks@gmail.com>
-rw-r--r--recipes/u-boot/u-boot-2009.08/dont-inline-weak-symbols.patch45
-rw-r--r--recipes/u-boot/u-boot_2009.08.bb5
2 files changed, 49 insertions, 1 deletions
diff --git a/recipes/u-boot/u-boot-2009.08/dont-inline-weak-symbols.patch b/recipes/u-boot/u-boot-2009.08/dont-inline-weak-symbols.patch
new file mode 100644
index 0000000000..5931ccf00b
--- /dev/null
+++ b/recipes/u-boot/u-boot-2009.08/dont-inline-weak-symbols.patch
@@ -0,0 +1,45 @@
+Patch initially created by Ron Lee and archived in OE patchwork at
+http://patchwork.openembedded.org/patch/1534/.
+
+GCC 4.4 complains about this now.
+
+Signed-off-by: Ron Lee <ron@debian.org>
+---
+ lib_arm/board.c | 18 +++++++++---------
+ 1 files changed, 9 insertions(+), 9 deletions(-)
+
+--- a/lib_arm/board.c
++++ b/lib_arm/board.c
+@@ -124,23 +124,23 @@
+ * May be supplied by boards if desired
+ */
+ void inline __coloured_LED_init (void) {}
+-void inline coloured_LED_init (void) __attribute__((weak, alias("__coloured_LED_init")));
++void coloured_LED_init (void) __attribute__((weak, alias("__coloured_LED_init")));
+ void inline __red_LED_on (void) {}
+-void inline red_LED_on (void) __attribute__((weak, alias("__red_LED_on")));
++void red_LED_on (void) __attribute__((weak, alias("__red_LED_on")));
+ void inline __red_LED_off(void) {}
+-void inline red_LED_off(void) __attribute__((weak, alias("__red_LED_off")));
++void red_LED_off(void) __attribute__((weak, alias("__red_LED_off")));
+ void inline __green_LED_on(void) {}
+-void inline green_LED_on(void) __attribute__((weak, alias("__green_LED_on")));
++void green_LED_on(void) __attribute__((weak, alias("__green_LED_on")));
+ void inline __green_LED_off(void) {}
+-void inline green_LED_off(void)__attribute__((weak, alias("__green_LED_off")));
++void green_LED_off(void)__attribute__((weak, alias("__green_LED_off")));
+ void inline __yellow_LED_on(void) {}
+-void inline yellow_LED_on(void)__attribute__((weak, alias("__yellow_LED_on")));
++void yellow_LED_on(void)__attribute__((weak, alias("__yellow_LED_on")));
+ void inline __yellow_LED_off(void) {}
+-void inline yellow_LED_off(void)__attribute__((weak, alias("__yellow_LED_off")));
++void yellow_LED_off(void)__attribute__((weak, alias("__yellow_LED_off")));
+ void inline __blue_LED_on(void) {}
+-void inline blue_LED_on(void)__attribute__((weak, alias("__blue_LED_on")));
++void blue_LED_on(void)__attribute__((weak, alias("__blue_LED_on")));
+ void inline __blue_LED_off(void) {}
+-void inline blue_LED_off(void)__attribute__((weak, alias("__blue_LED_off")));
++void blue_LED_off(void)__attribute__((weak, alias("__blue_LED_off")));
+
+ /************************************************************************
+ * Init Utilities *
diff --git a/recipes/u-boot/u-boot_2009.08.bb b/recipes/u-boot/u-boot_2009.08.bb
index 506a0cb2c5..868e618607 100644
--- a/recipes/u-boot/u-boot_2009.08.bb
+++ b/recipes/u-boot/u-boot_2009.08.bb
@@ -7,7 +7,10 @@ DEFAULT_PREFERENCE_at91sam9g45ek = "1"
DEFAULT_PREFERENCE_igep0020 = "1"
DEFAULT_PREFERENCE_babbage = "1"
-SRC_URI = "ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2 "
+SRC_URI = "\
+ ftp://ftp.denx.de/pub/u-boot/u-boot-${PV}.tar.bz2 \
+ file://dont-inline-weak-symbols.patch \
+"
SRC_URI_append_igep0020 = " \
file://update-mach-types.patch \